Fix compat with glibc 2.36
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
This commit is contained in:
parent
0eeaeaae15
commit
34254733fe
100
0011-linux-user-fix-compat-with-glibc-2.36-sys-mount.h.patch
Normal file
100
0011-linux-user-fix-compat-with-glibc-2.36-sys-mount.h.patch
Normal file
@ -0,0 +1,100 @@
|
||||
From a7f14aae85022007a4c77e0792a1abb0509a08eb Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Tue, 2 Aug 2022 12:34:23 -0400
|
||||
Subject: [PATCH] linux-user: fix compat with glibc >= 2.36 sys/mount.h
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The latest glibc 2.36 has extended sys/mount.h so that it
|
||||
defines the FSCONFIG_* enum constants. These are historically
|
||||
defined in linux/mount.h, and thus if you include both headers
|
||||
the compiler complains:
|
||||
|
||||
In file included from /usr/include/linux/fs.h:19,
|
||||
from ../linux-user/syscall.c:98:
|
||||
/usr/include/linux/mount.h:95:6: error: redeclaration of 'enum fsconfig_command'
|
||||
95 | enum fsconfig_command {
|
||||
| ^~~~~~~~~~~~~~~~
|
||||
In file included from ../linux-user/syscall.c:31:
|
||||
/usr/include/sys/mount.h:189:6: note: originally defined here
|
||||
189 | enum fsconfig_command
|
||||
| ^~~~~~~~~~~~~~~~
|
||||
/usr/include/linux/mount.h:96:9: error: redeclaration of enumerator 'FSCONFIG_SET_FLAG'
|
||||
96 | FSCONFIG_SET_FLAG = 0, /* Set parameter, supplying no value */
|
||||
| ^~~~~~~~~~~~~~~~~
|
||||
/usr/include/sys/mount.h:191:3: note: previous definition of 'FSCONFIG_SET_FLAG' with type 'enum fsconfig_command'
|
||||
191 | FSCONFIG_SET_FLAG = 0, /* Set parameter, supplying no value */
|
||||
| ^~~~~~~~~~~~~~~~~
|
||||
...snip...
|
||||
|
||||
QEMU doesn't include linux/mount.h, but it does use
|
||||
linux/fs.h and thus gets linux/mount.h indirectly.
|
||||
|
||||
glibc acknowledges this problem but does not appear to
|
||||
be intending to fix it in the forseeable future, simply
|
||||
documenting it as a known incompatibility with no
|
||||
workaround:
|
||||
|
||||
https://sourceware.org/glibc/wiki/Release/2.36#Usage_of_.3Clinux.2Fmount.h.3E_and_.3Csys.2Fmount.h.3E
|
||||
https://sourceware.org/glibc/wiki/Synchronizing_Headers
|
||||
|
||||
To address this requires either removing use of sys/mount.h
|
||||
or linux/fs.h, despite QEMU needing declarations from
|
||||
both.
|
||||
|
||||
This patch removes linux/fs.h, meaning we have to define
|
||||
various FS_IOC constants that are now unavailable.
|
||||
|
||||
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
|
||||
---
|
||||
linux-user/syscall.c | 18 ++++++++++++++++++
|
||||
meson.build | 2 ++
|
||||
2 files changed, 20 insertions(+)
|
||||
|
||||
diff --git a/linux-user/syscall.c b/linux-user/syscall.c
|
||||
index b27a6552aa..52d178afe7 100644
|
||||
--- a/linux-user/syscall.c
|
||||
+++ b/linux-user/syscall.c
|
||||
@@ -95,7 +95,25 @@
|
||||
#include <linux/soundcard.h>
|
||||
#include <linux/kd.h>
|
||||
#include <linux/mtio.h>
|
||||
+
|
||||
+#ifdef HAVE_SYS_MOUNT_FSCONFIG
|
||||
+/*
|
||||
+ * glibc >= 2.36 linux/mount.h conflicts with sys/mount.h,
|
||||
+ * which in turn prevents use of linux/fs.h. So we have to
|
||||
+ * define the constants ourselves for now.
|
||||
+ */
|
||||
+#define FS_IOC_GETFLAGS _IOR('f', 1, long)
|
||||
+#define FS_IOC_SETFLAGS _IOW('f', 2, long)
|
||||
+#define FS_IOC_GETVERSION _IOR('v', 1, long)
|
||||
+#define FS_IOC_SETVERSION _IOW('v', 2, long)
|
||||
+#define FS_IOC_FIEMAP _IOWR('f', 11, struct fiemap)
|
||||
+#define FS_IOC32_GETFLAGS _IOR('f', 1, int)
|
||||
+#define FS_IOC32_SETFLAGS _IOW('f', 2, int)
|
||||
+#define FS_IOC32_GETVERSION _IOR('v', 1, int)
|
||||
+#define FS_IOC32_SETVERSION _IOW('v', 2, int)
|
||||
+#else
|
||||
#include <linux/fs.h>
|
||||
+#endif
|
||||
#include <linux/fd.h>
|
||||
#if defined(CONFIG_FIEMAP)
|
||||
#include <linux/fiemap.h>
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 294e9a8f32..30a380752c 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1963,6 +1963,8 @@ config_host_data.set('HAVE_OPTRESET',
|
||||
cc.has_header_symbol('getopt.h', 'optreset'))
|
||||
config_host_data.set('HAVE_IPPROTO_MPTCP',
|
||||
cc.has_header_symbol('netinet/in.h', 'IPPROTO_MPTCP'))
|
||||
+config_host_data.set('HAVE_SYS_MOUNT_FSCONFIG',
|
||||
+ cc.has_header_symbol('sys/mount.h', 'FSCONFIG_SET_FLAG'))
|
||||
|
||||
# has_member
|
||||
config_host_data.set('HAVE_SIGEV_NOTIFY_THREAD_ID',
|
||||
--
|
||||
2.37.1
|
||||
|
@ -317,7 +317,7 @@ Obsoletes: %{name}-system-unicore32-core <= %{epoch}:%{version}-%{release}
|
||||
%endif
|
||||
|
||||
# To prevent rpmdev-bumpspec breakage
|
||||
%global baserelease 8
|
||||
%global baserelease 9
|
||||
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
@ -352,6 +352,8 @@ Patch: 0007-virtio-scsi-move-request-related-items-from-.h-to-.c.patch
|
||||
Patch: 0008-Disable-flakey-dbus-display-test.patch
|
||||
Patch: 0009-Fix-iotests-with-modules-and-qemu-system-s390x.patch
|
||||
Patch: 0010-Skip-iotests-entirely.patch
|
||||
# Not yet upstream, fix glibc 2.36 compat
|
||||
Patch: 0011-linux-user-fix-compat-with-glibc-2.36-sys-mount.h.patch
|
||||
|
||||
BuildRequires: meson >= %{meson_version}
|
||||
BuildRequires: zlib-devel
|
||||
@ -2716,6 +2718,9 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 2 2022 Daniel P. Berrangé <berrange@redhat.com> - 7.0.0-9
|
||||
- Fix compat with glibc 2.36 headers
|
||||
|
||||
* Mon Jul 25 2022 Paolo Bonzini <pbonzini@redhat.com> - 2:7.0.0-8
|
||||
- Replace pcre-static dependency with pcre2-static, to adjust for glib switching
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user