Added VNC password & TLS/x509 auth. Default to rtl8139 nic. Fix rtl8139
MMIO regions
This commit is contained in:
parent
76b47ee470
commit
304b40289f
24
qemu-0.9.0-nic-defaults.patch
Normal file
24
qemu-0.9.0-nic-defaults.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -rup qemu-0.9.0.orig/hw/pc.c qemu-0.9.0.new/hw/pc.c
|
||||
--- qemu-0.9.0.orig/hw/pc.c 2007-08-28 11:35:35.000000000 -0400
|
||||
+++ qemu-0.9.0.new/hw/pc.c 2007-08-28 11:36:18.000000000 -0400
|
||||
@@ -682,7 +682,7 @@ static void pc_init1(int ram_size, int v
|
||||
nd = &nd_table[i];
|
||||
if (!nd->model) {
|
||||
if (pci_enabled) {
|
||||
- nd->model = "ne2k_pci";
|
||||
+ nd->model = "rtl8139";
|
||||
} else {
|
||||
nd->model = "ne2k_isa";
|
||||
}
|
||||
diff -rup qemu-0.9.0.orig/vl.c qemu-0.9.0.new/vl.c
|
||||
--- qemu-0.9.0.orig/vl.c 2007-08-28 11:35:35.000000000 -0400
|
||||
+++ qemu-0.9.0.new/vl.c 2007-08-28 11:36:18.000000000 -0400
|
||||
@@ -7082,7 +7082,7 @@ int main(int argc, char **argv)
|
||||
const char *model = nd_table[i].model;
|
||||
char buf[1024];
|
||||
if (model == NULL)
|
||||
- model = "ne2k_pci";
|
||||
+ model = "rtl8139";
|
||||
snprintf(buf, sizeof(buf), "%s/pxe-%s.bin", bios_dir, model);
|
||||
if (get_image_size(buf) > 0) {
|
||||
option_rom[nb_option_roms] = strdup(buf);
|
25
qemu-0.9.0-rtl8139-mmio-regions.patch
Normal file
25
qemu-0.9.0-rtl8139-mmio-regions.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -rup qemu-0.9.0.orig/hw/rtl8139.c qemu-0.9.0.new/hw/rtl8139.c
|
||||
--- qemu-0.9.0.orig/hw/rtl8139.c 2007-02-05 18:01:54.000000000 -0500
|
||||
+++ qemu-0.9.0.new/hw/rtl8139.c 2007-08-28 11:37:29.000000000 -0400
|
||||
@@ -3325,7 +3325,7 @@ static void rtl8139_mmio_map(PCIDevice *
|
||||
PCIRTL8139State *d = (PCIRTL8139State *)pci_dev;
|
||||
RTL8139State *s = &d->rtl8139;
|
||||
|
||||
- cpu_register_physical_memory(addr + 0, 0x100, s->rtl8139_mmio_io_addr);
|
||||
+ cpu_register_physical_memory(addr + 0, 0x1000, s->rtl8139_mmio_io_addr);
|
||||
}
|
||||
|
||||
static void rtl8139_ioport_map(PCIDevice *pci_dev, int region_num,
|
||||
@@ -3438,10 +3438,10 @@ void pci_rtl8139_init(PCIBus *bus, NICIn
|
||||
s->rtl8139_mmio_io_addr =
|
||||
cpu_register_io_memory(0, rtl8139_mmio_read, rtl8139_mmio_write, s);
|
||||
|
||||
- pci_register_io_region(&d->dev, 0, 0x100,
|
||||
+ pci_register_io_region(&d->dev, 0, 0x1000,
|
||||
PCI_ADDRESS_SPACE_IO, rtl8139_ioport_map);
|
||||
|
||||
- pci_register_io_region(&d->dev, 1, 0x100,
|
||||
+ pci_register_io_region(&d->dev, 1, 0x1000,
|
||||
PCI_ADDRESS_SPACE_MEM, rtl8139_mmio_map);
|
||||
|
||||
s->irq = 16; /* PCI interrupt */
|
1989
qemu-0.9.0-vnc-authentication.patch
Normal file
1989
qemu-0.9.0-vnc-authentication.patch
Normal file
File diff suppressed because it is too large
Load Diff
18
qemu.spec
18
qemu.spec
@ -8,7 +8,7 @@
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 0.9.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPL/LGPL
|
||||
Group: Development/Tools
|
||||
URL: http://www.qemu.org/
|
||||
@ -17,8 +17,14 @@ Source1: qemu.init
|
||||
Patch0: qemu-0.7.0-build.patch
|
||||
Patch1: qemu-0.8.0-sdata.patch
|
||||
Patch2: qemu-0.9.0-load-initrd.patch
|
||||
# Change default NIC to rtl8139 to get link-state detection
|
||||
Patch3: qemu-0.9.0-nic-defaults.patch
|
||||
# Add VNC auth. Upstream backport. Remove at next upgrade
|
||||
Patch4: qemu-0.9.0-vnc-authentication.patch
|
||||
# Fix RTL8139 MMIO regions. Remove at next upgrade
|
||||
Patch5: qemu-0.9.0-rtl8139-mmio-regions.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: SDL-devel compat-gcc-%{gccver} zlib-devel which texi2html
|
||||
BuildRequires: SDL-devel compat-gcc-%{gccver} zlib-devel which texi2html gnutls-devel
|
||||
Requires(post): /sbin/chkconfig
|
||||
Requires(preun): /sbin/service /sbin/chkconfig
|
||||
Requires(postun): /sbin/service
|
||||
@ -42,6 +48,9 @@ As QEMU requires no host kernel patches to run, it is safe and easy to use.
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p0
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%build
|
||||
./configure \
|
||||
@ -92,6 +101,11 @@ fi
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 28 2007 Daniel P. Berrange <berrange@redhat.com> - 0.9.0-3.fc8
|
||||
- Added backport of VNC password auth, and TLS+x509 cert auth
|
||||
- Switch to rtl8139 NIC by default for linkstate reporting
|
||||
- Fix rtl8139 mmio region mappings with multiple NICs
|
||||
|
||||
* Sun Apr 1 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9.0-2
|
||||
- Fix direct loading of a linux kernel with -kernel & -initrd (bz 234681)
|
||||
- Remove spurious execute bits from manpages (bz 222573)
|
||||
|
Loading…
Reference in New Issue
Block a user