Fix qxl pci id, and grab ksm updates.
This commit is contained in:
parent
a81953e710
commit
2b6f88d8cb
25
0040-qxl-flip-default-to-stable-pci-revision.patch
Normal file
25
0040-qxl-flip-default-to-stable-pci-revision.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From b0f3b268c79c532725ae23af56621ab2948ac480 Mon Sep 17 00:00:00 2001
|
||||
From: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Date: Thu, 16 Sep 2010 12:07:51 +0000
|
||||
Subject: [PATCH 40/40] qxl: flip default to stable pci revision.
|
||||
|
||||
---
|
||||
hw/qxl.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/hw/qxl.c b/hw/qxl.c
|
||||
index 8448893..d2a0c16 100644
|
||||
--- a/hw/qxl.c
|
||||
+++ b/hw/qxl.c
|
||||
@@ -1455,7 +1455,7 @@ static PCIDeviceInfo qxl_info = {
|
||||
.qdev.props = (Property[]) {
|
||||
DEFINE_PROP_UINT32("ram_size", PCIQXLDevice, vga.vram_size, 64 * 1024 * 1024),
|
||||
DEFINE_PROP_UINT32("vram_size", PCIQXLDevice, vram_size, 64 * 1024 * 1024),
|
||||
- DEFINE_PROP_UINT32("revision", PCIQXLDevice, revision, 3),
|
||||
+ DEFINE_PROP_UINT32("revision", PCIQXLDevice, revision, 2),
|
||||
DEFINE_PROP_UINT32("debug", PCIQXLDevice, debug, 0),
|
||||
DEFINE_PROP_UINT32("cmdlog", PCIQXLDevice, cmdlog, 0),
|
||||
DEFINE_PROP_END_OF_LIST(),
|
||||
--
|
||||
1.7.2.3
|
||||
|
6
ksm.init
6
ksm.init
@ -40,8 +40,10 @@ default_max_kernel_pages () {
|
||||
|
||||
start() {
|
||||
echo -n $"Starting $prog: "
|
||||
KSM_MAX_KERNEL_PAGES=${KSM_MAX_KERNEL_PAGES:-`default_max_kernel_pages`}
|
||||
echo $KSM_MAX_KERNEL_PAGES > /sys/kernel/mm/ksm/max_kernel_pages
|
||||
if [ -f /sys/kernel/mm/ksm/max_kernel_pages ]; then
|
||||
KSM_MAX_KERNEL_PAGES=${KSM_MAX_KERNEL_PAGES:-`default_max_kernel_pages`}
|
||||
echo $KSM_MAX_KERNEL_PAGES > /sys/kernel/mm/ksm/max_kernel_pages
|
||||
fi
|
||||
echo 1 > /sys/kernel/mm/ksm/run
|
||||
RETVAL=$?
|
||||
[ $RETVAL = 0 ] && success $"$prog startup" || failure $"$prog startup"
|
||||
|
4
ksmtuned
4
ksmtuned
@ -71,8 +71,8 @@ KSMCTL () {
|
||||
committed_memory () {
|
||||
# calculate how much memory is committed to running qemu processes
|
||||
local progname
|
||||
progname=${1:-qemu}
|
||||
ps -o vsz `pgrep $progname` | awk '{ sum += $1 }; END { print sum }'
|
||||
progname=${1:-qemu-kvm}
|
||||
ps -C "$progname" -o rsz | awk '{ sum += $1 }; END { print sum }'
|
||||
}
|
||||
|
||||
free_memory () {
|
||||
|
10
qemu.spec
10
qemu.spec
@ -1,7 +1,7 @@
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 0.13.0
|
||||
Release: 0.6.rc1%{?dist}
|
||||
Release: 0.7.rc1%{?dist}
|
||||
# Epoch because we pushed a qemu-1.0 package
|
||||
Epoch: 2
|
||||
License: GPLv2+ and LGPLv2+ and BSD
|
||||
@ -77,6 +77,7 @@ Patch36: 0036-Revert-spice-add-pci-vdi-port-backend-obsolete.patch
|
||||
Patch37: 0037-Revert-spice-add-virtio-serial-based-vdi-port-backen.patch
|
||||
Patch38: 0038-spice-add-virtio-serial-based-spice-vmchannel-backen.patch
|
||||
Patch39: 0039-qxl-fix-release-ring-overrun.patch
|
||||
Patch40: 0040-qxl-flip-default-to-stable-pci-revision.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
||||
@ -313,6 +314,7 @@ such as kvm_stat.
|
||||
%patch37 -p1
|
||||
%patch38 -p1
|
||||
%patch39 -p1
|
||||
%patch40 -p1
|
||||
|
||||
%build
|
||||
# By default we build everything, but allow x86 to build a minimal version
|
||||
@ -627,7 +629,11 @@ fi
|
||||
%{_mandir}/man1/qemu-img.1*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2010 Justin M. Forbes <jforbes@redhat.com> - 2:0.13.0-0.6.rc1
|
||||
* Tue Sep 21 2010 Justin M. Forbes <jforbes@redhat.com> - 2:0.13.0-0.7.rc1
|
||||
- Flip qxl pci id from unstable to stable (#634535)
|
||||
- KSM Fixes from upstream (#558281)
|
||||
|
||||
* Tue Sep 14 2010 Justin M. Forbes <jforbes@redhat.com> - 2:0.13.0-0.6.rc1
|
||||
- Move away from git snapshots as 0.13 is close to release
|
||||
- Updates for spice 0.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user