Merge remote-tracking branch 'up/main' into main-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
1d003b9d3d
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/x86_64/
|
||||
/*.src.rpm
|
||||
/qemu-*.tar.xz
|
||||
/qemu-*.tar.xz.sig
|
||||
|
@ -0,0 +1,36 @@
|
||||
From 9d5b42beb6978dc6219d5dc029c9d453c6b8d503 Mon Sep 17 00:00:00 2001
|
||||
From: Elen Avan <elen.avan@bk.ru>
|
||||
Date: Fri, 22 Dec 2023 22:17:21 +0300
|
||||
Subject: [PATCH] include/ui/rect.h: fix qemu_rect_init() mis-assignment
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Elen Avan <elen.avan@bk.ru>
|
||||
Resolves: https://gitlab.com/qemu-project/qemu/-/issues/2051
|
||||
Resolves: https://gitlab.com/qemu-project/qemu/-/issues/2050
|
||||
Fixes: a200d53b1fde "virtio-gpu: replace PIXMAN for region/rect test"
|
||||
Cc: qemu-stable@nongnu.org
|
||||
Reviewed-by: Michael Tokarev <mjt@tls.msk.ru>
|
||||
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
||||
Signed-off-by: Michael Tokarev <mjt@tls.msk.ru>
|
||||
---
|
||||
include/ui/rect.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/include/ui/rect.h b/include/ui/rect.h
|
||||
index 94898f92d0..68f05d78a8 100644
|
||||
--- a/include/ui/rect.h
|
||||
+++ b/include/ui/rect.h
|
||||
@@ -19,7 +19,7 @@ static inline void qemu_rect_init(QemuRect *rect,
|
||||
uint16_t width, uint16_t height)
|
||||
{
|
||||
rect->x = x;
|
||||
- rect->y = x;
|
||||
+ rect->y = y;
|
||||
rect->width = width;
|
||||
rect->height = height;
|
||||
}
|
||||
--
|
||||
2.43.0
|
||||
|
@ -0,0 +1,35 @@
|
||||
From 98287d67f3ea6c49795838beda4b020cf236fc20 Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Mon, 27 Nov 2023 12:51:25 -0500
|
||||
Subject: [PATCH] pc-bios/optionrom: Fix pvh.img ld build failure on fedora
|
||||
rawhide
|
||||
Content-type: text/plain
|
||||
|
||||
binutils 2.39 shows some warnings when building pvh.img
|
||||
|
||||
/usr/bin/ld: warning: pvh.o: missing .note.GNU-stack section implies executable stack
|
||||
/usr/bin/ld: NOTE: This behaviour is deprecated and will be removed in a future version of the linker
|
||||
/usr/bin/ld: warning: pvh.img has a LOAD segment with RWX permissions
|
||||
|
||||
The latter of which is fatal on Fedora rawhide for some reason.
|
||||
|
||||
Add linker options to suppress the errors
|
||||
|
||||
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
||||
---
|
||||
pc-bios/optionrom/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
|
||||
index 30d07026c7..f54ed39b54 100644
|
||||
--- a/pc-bios/optionrom/Makefile
|
||||
+++ b/pc-bios/optionrom/Makefile
|
||||
@@ -36,7 +36,7 @@ config-cc.mak: Makefile
|
||||
$(call cc-option,-Wno-array-bounds)) 3> config-cc.mak
|
||||
-include config-cc.mak
|
||||
|
||||
-override LDFLAGS = -nostdlib -Wl,--build-id=none,-T,$(SRC_DIR)/flat.lds
|
||||
+override LDFLAGS = -nostdlib -Wl,--build-id=none,-T,$(SRC_DIR)/flat.lds -Wl,--no-warn-rwx-segments -Wl,--no-warn-execstack
|
||||
|
||||
pvh.img: pvh.o pvh_main.o
|
||||
|
@ -1,58 +0,0 @@
|
||||
From e4a112c75a02a789e7710e805f66211426087d55 Mon Sep 17 00:00:00 2001
|
||||
Message-ID: <e4a112c75a02a789e7710e805f66211426087d55.1692544104.git.crobinso@redhat.com>
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Sun, 20 Aug 2023 10:49:12 -0400
|
||||
Subject: [PATCH] tests: Disable iotests, like RHEL does
|
||||
Content-type: text/plain
|
||||
|
||||
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
||||
---
|
||||
tests/qemu-iotests/meson.build | 34 +++++++++++++++++-----------------
|
||||
1 file changed, 17 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/tests/qemu-iotests/meson.build b/tests/qemu-iotests/meson.build
|
||||
index 44761e1e4d..78c5836325 100644
|
||||
--- a/tests/qemu-iotests/meson.build
|
||||
+++ b/tests/qemu-iotests/meson.build
|
||||
@@ -51,21 +51,21 @@ foreach format, speed: qemu_iotests_formats
|
||||
check: true,
|
||||
)
|
||||
|
||||
- foreach item: rc.stdout().strip().split()
|
||||
- args = [qemu_iotests_check_cmd,
|
||||
- '-tap', '-' + format, item,
|
||||
- '--source-dir', meson.current_source_dir(),
|
||||
- '--build-dir', meson.current_build_dir()]
|
||||
- # Some individual tests take as long as 45 seconds
|
||||
- # Bump the timeout to 3 minutes for some headroom
|
||||
- # on slow machines to minimize spurious failures
|
||||
- test('io-' + format + '-' + item,
|
||||
- python,
|
||||
- args: args,
|
||||
- depends: qemu_iotests_binaries,
|
||||
- env: qemu_iotests_env,
|
||||
- protocol: 'tap',
|
||||
- timeout: 180,
|
||||
- suite: suites)
|
||||
- endforeach
|
||||
+# foreach item: rc.stdout().strip().split()
|
||||
+# args = [qemu_iotests_check_cmd,
|
||||
+# '-tap', '-' + format, item,
|
||||
+# '--source-dir', meson.current_source_dir(),
|
||||
+# '--build-dir', meson.current_build_dir()]
|
||||
+# # Some individual tests take as long as 45 seconds
|
||||
+# # Bump the timeout to 3 minutes for some headroom
|
||||
+# # on slow machines to minimize spurious failures
|
||||
+# test('io-' + format + '-' + item,
|
||||
+# python,
|
||||
+# args: args,
|
||||
+# depends: qemu_iotests_binaries,
|
||||
+# env: qemu_iotests_env,
|
||||
+# protocol: 'tap',
|
||||
+# timeout: 180,
|
||||
+# suite: suites)
|
||||
+# endforeach
|
||||
endforeach
|
||||
--
|
||||
2.41.0
|
||||
|
BIN
gpgkey-CEACC9E15534EBABB82D3FA03353C9CEF108B584.gpg
Normal file
BIN
gpgkey-CEACC9E15534EBABB82D3FA03353C9CEF108B584.gpg
Normal file
Binary file not shown.
20
rpminspect.yaml
Normal file
20
rpminspect.yaml
Normal file
@ -0,0 +1,20 @@
|
||||
# complains about qemu use of: gethostbyname, inet_aton, inet_ntoa
|
||||
# but warning here isn't really accomplishing anything
|
||||
badfuncs:
|
||||
exclude_path: .*
|
||||
|
||||
# These pre-compiled files have `.symtab`
|
||||
debuginfo:
|
||||
ignore:
|
||||
- /usr/share/qemu/palcode-clipper
|
||||
- /usr/share/qemu/hppa-firmware.img
|
||||
|
||||
# More pre-compiled rom warnings:
|
||||
# - Program built without GNU_STACK: /usr/share/qemu/u-boot.e500
|
||||
# - Stack is still executable: /usr/share/qemu/hppa-firmware.img
|
||||
elf:
|
||||
exclude_path: ^/usr/share/qemu/(u-boot.e500|hppa-firmware.img)$
|
||||
|
||||
# CryptoPkg fuzz tests have invalid unicode, but I assume that's intentional
|
||||
unicode:
|
||||
exclude: .*edk2/CryptoPkg.*
|
3
sources
3
sources
@ -1 +1,2 @@
|
||||
SHA512 (qemu-8.1.0.tar.xz) = c5f5e7ce2d8e3c93a02012b136c866e8577df07da4705a0045916c71caeaa21fa1b2d59a4b22a660789a4159b192e12a443e7cbb0724ee85fea258251731724c
|
||||
SHA512 (qemu-8.2.0.tar.xz) = 92ec41196ff145cdbb98948f6b6e43214fa4b4419554a8a1927fb4527080c8212ccb703e184baf8ee0bdfa50ad7a84689e8f5a69eba1bd7bbbdfd69e3b91256c
|
||||
SHA512 (qemu-8.2.0.tar.xz.sig) = 05412219ab0ff145f56708f99bc60b378b2b9ef6fbf3c48bffd32a2952188b2ee34a798949b09d6d8fc9f2483094fa0e3b488f52f69508604747ad4e2960f302
|
||||
|
Loading…
Reference in New Issue
Block a user