Update to qemu 2.0-rc3
Fix crash when restoring from snapshot (bz #1085632)
This commit is contained in:
parent
75f0c8715a
commit
17908043da
@ -1,4 +1,4 @@
|
||||
From aaf9408dd279d9aa0bf1af6da07813a274fcb530 Mon Sep 17 00:00:00 2001
|
||||
From 6b4fcd4bb73c86c7754bcc912a557ba62180ae0b Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Wed, 19 Mar 2014 14:57:27 -0400
|
||||
Subject: [PATCH] Change gtk quit accelerator to ctrl+shift+q (bz 1062393)
|
||||
@ -9,10 +9,10 @@ Similar patches queued for 2.1
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/ui/gtk.c b/ui/gtk.c
|
||||
index c3ac448..0500134 100644
|
||||
index 00fbbcc..264326a 100644
|
||||
--- a/ui/gtk.c
|
||||
+++ b/ui/gtk.c
|
||||
@@ -1293,7 +1293,6 @@ static GtkWidget *gd_create_menu_machine(GtkDisplayState *s, GtkAccelGroup *acce
|
||||
@@ -1351,7 +1351,6 @@ static GtkWidget *gd_create_menu_machine(GtkDisplayState *s, GtkAccelGroup *acce
|
||||
{
|
||||
GtkWidget *machine_menu;
|
||||
GtkWidget *separator;
|
||||
@ -20,7 +20,7 @@ index c3ac448..0500134 100644
|
||||
|
||||
machine_menu = gtk_menu_new();
|
||||
gtk_menu_set_accel_group(GTK_MENU(machine_menu), accel_group);
|
||||
@@ -1313,11 +1312,11 @@ static GtkWidget *gd_create_menu_machine(GtkDisplayState *s, GtkAccelGroup *acce
|
||||
@@ -1371,11 +1370,11 @@ static GtkWidget *gd_create_menu_machine(GtkDisplayState *s, GtkAccelGroup *acce
|
||||
separator = gtk_separator_menu_item_new();
|
||||
gtk_menu_shell_append(GTK_MENU_SHELL(machine_menu), separator);
|
||||
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 60fd6c348917c108fccc50bb5a3e8805275eed64 Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Fri, 21 Mar 2014 14:27:05 -0400
|
||||
Subject: [PATCH] spice: input: Fix absolute mouse y coordinates
|
||||
|
||||
Current tablet + spice is unusable. Regressed with the UI input rework.
|
||||
|
||||
(cherry picked from commit 2445826353f0c65fd9920260f682fb725a36b399)
|
||||
---
|
||||
ui/spice-input.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ui/spice-input.c b/ui/spice-input.c
|
||||
index 6dab23b..c342e0d 100644
|
||||
--- a/ui/spice-input.c
|
||||
+++ b/ui/spice-input.c
|
||||
@@ -176,7 +176,7 @@ static void tablet_position(SpiceTabletInstance* sin, int x, int y,
|
||||
|
||||
spice_update_buttons(pointer, 0, buttons_state);
|
||||
qemu_input_queue_abs(NULL, INPUT_AXIS_X, x, pointer->width);
|
||||
- qemu_input_queue_abs(NULL, INPUT_AXIS_Y, y, pointer->width);
|
||||
+ qemu_input_queue_abs(NULL, INPUT_AXIS_Y, y, pointer->height);
|
||||
qemu_input_event_sync();
|
||||
}
|
||||
|
14
qemu.spec
14
qemu.spec
@ -147,7 +147,7 @@
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 2.0.0
|
||||
Release: 0.2.rc0%{?dist}
|
||||
Release: 0.3.rc3%{?dist}
|
||||
Epoch: 2
|
||||
License: GPLv2+ and LGPLv2+ and BSD
|
||||
Group: Development/Tools
|
||||
@ -163,7 +163,7 @@ ExclusiveArch: %{kvm_archs}
|
||||
%endif
|
||||
|
||||
#Source0: http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
|
||||
Source0: http://wiki.qemu-project.org/download/%{name}-%{version}-rc0.tar.bz2
|
||||
Source0: http://wiki.qemu-project.org/download/%{name}-%{version}-rc3.tar.bz2
|
||||
|
||||
Source1: qemu.binfmt
|
||||
|
||||
@ -191,9 +191,6 @@ Source13: qemu-kvm.sh
|
||||
# Change gtk quit accelerator to ctrl+shift+q (bz #1062393)
|
||||
# Patches queued for 2.1
|
||||
Patch0001: 0001-Change-gtk-quit-accelerator-to-ctrl-shift-q-bz-10623.patch
|
||||
# Fix mouse with spice
|
||||
# Patches queued for 2.0
|
||||
Patch0002: 0002-spice-input-Fix-absolute-mouse-y-coordinates.patch
|
||||
|
||||
BuildRequires: SDL2-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -703,9 +700,6 @@ CAC emulation development files.
|
||||
# Change gtk quit accelerator to ctrl+shift+q (bz #1062393)
|
||||
# Patches queued for 2.1
|
||||
%patch0001 -p1
|
||||
# Fix mouse with spice
|
||||
# Patches queued for 2.0
|
||||
%patch0002 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -1457,6 +1451,10 @@ getent passwd qemu >/dev/null || \
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Apr 15 2014 Cole Robinson <crobinso@redhat.com> - 2:2.0.0-0.3.rc3
|
||||
- Update to qemu 2.0-rc3
|
||||
- Fix crash when restoring from snapshot (bz #1085632)
|
||||
|
||||
* Mon Mar 24 2014 Cole Robinson <crobinso@redhat.com> - 2:2.0.0-0.2.rc0
|
||||
- Change gtk quit accelerator to ctrl+shift+q (bz #1062393)
|
||||
- Fix mouse with spice
|
||||
|
Loading…
x
Reference in New Issue
Block a user