Merge remote-tracking branch 'up/main' into main-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2024-09-12 14:33:25 +03:00
commit 00242a13a5
Signed by: davidlt
GPG Key ID: 7A5F42FAF91FACC3
3 changed files with 121 additions and 66 deletions

View File

@ -0,0 +1,49 @@
From 34acc8e0028bf059c9c4e725c653df56eac7c296 Mon Sep 17 00:00:00 2001
Message-ID: <34acc8e0028bf059c9c4e725c653df56eac7c296.1724767601.git.crobinso@redhat.com>
From: Cole Robinson <crobinso@redhat.com>
Date: Mon, 26 Aug 2024 14:06:14 -0400
Subject: [PATCH] Disable 9p `local` tests that fail on copr aarch64
Content-type: text/plain
Upstream issue:
https://gitlab.com/qemu-project/qemu/-/issues/2541
Signed-off-by: Cole Robinson <crobinso@redhat.com>
---
tests/qtest/virtio-9p-test.c | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/tests/qtest/virtio-9p-test.c b/tests/qtest/virtio-9p-test.c
index 3c8cd235cf..1d550eafb1 100644
--- a/tests/qtest/virtio-9p-test.c
+++ b/tests/qtest/virtio-9p-test.c
@@ -748,16 +748,16 @@ static void register_virtio_9p_test(void)
/* 9pfs test cases using the 'local' filesystem driver */
opts.before = assign_9p_local_driver;
qos_add_test("local/config", "virtio-9p", pci_config, &opts);
- qos_add_test("local/create_dir", "virtio-9p", fs_create_dir, &opts);
- qos_add_test("local/unlinkat_dir", "virtio-9p", fs_unlinkat_dir, &opts);
- qos_add_test("local/create_file", "virtio-9p", fs_create_file, &opts);
- qos_add_test("local/unlinkat_file", "virtio-9p", fs_unlinkat_file, &opts);
- qos_add_test("local/symlink_file", "virtio-9p", fs_symlink_file, &opts);
- qos_add_test("local/unlinkat_symlink", "virtio-9p", fs_unlinkat_symlink,
- &opts);
- qos_add_test("local/hardlink_file", "virtio-9p", fs_hardlink_file, &opts);
- qos_add_test("local/unlinkat_hardlink", "virtio-9p", fs_unlinkat_hardlink,
- &opts);
+ /* qos_add_test("local/create_dir", "virtio-9p", fs_create_dir, &opts); */
+ /* qos_add_test("local/unlinkat_dir", "virtio-9p", fs_unlinkat_dir, &opts); */
+ /* qos_add_test("local/create_file", "virtio-9p", fs_create_file, &opts); */
+ /* qos_add_test("local/unlinkat_file", "virtio-9p", fs_unlinkat_file, &opts); */
+ /* qos_add_test("local/symlink_file", "virtio-9p", fs_symlink_file, &opts); */
+ /* qos_add_test("local/unlinkat_symlink", "virtio-9p", fs_unlinkat_symlink, */
+ /* &opts); */
+ /* qos_add_test("local/hardlink_file", "virtio-9p", fs_hardlink_file, &opts); */
+ /* qos_add_test("local/unlinkat_hardlink", "virtio-9p", fs_unlinkat_hardlink, */
+ /* &opts); */
}
libqos_init(register_virtio_9p_test);
--
2.46.0

134
qemu.spec
View File

@ -11,17 +11,20 @@
%global usbredir_version 0.7.1
%global ipxe_version 20200823-5.git4bd064de
%define have_vmsr_helper 0
%global have_memlock_limits 0
%global need_qemu_kvm 0
%ifarch %{ix86}
%global kvm_package system-x86
# need_qemu_kvm should only ever be used by x86
%global need_qemu_kvm 1
%define have_vmsr_helper 1
%endif
%ifarch x86_64
%global kvm_package system-x86
# need_qemu_kvm should only ever be used by x86
%global need_qemu_kvm 1
%define have_vmsr_helper 1
%endif
%ifarch %{power64}
%global have_memlock_limits 1
@ -227,7 +230,6 @@
%define requires_device_display_virtio_gpu_pci Requires: %{name}-device-display-virtio-gpu-pci = %{evr}
%define requires_device_display_virtio_gpu_ccw Requires: %{name}-device-display-virtio-gpu-ccw = %{evr}
%define requires_device_display_virtio_vga Requires: %{name}-device-display-virtio-vga = %{evr}
%define requires_device_display_virtio_vga_gl Requires: %{name}-device-display-virtio-vga-gl = %{evr}
%define requires_package_qemu_pr_helper Requires: qemu-pr-helper
%ifnarch %{ix86}
%if 0%{?fedora} || 0%{?rhel} > 9
@ -245,10 +247,12 @@
%define requires_device_display_vhost_user_gpu Requires: %{name}-device-display-vhost-user-gpu = %{evr}
%define requires_device_display_virtio_gpu_gl Requires: %{name}-device-display-virtio-gpu-gl = %{evr}
%define requires_device_display_virtio_gpu_pci_gl Requires: %{name}-device-display-virtio-gpu-pci-gl = %{evr}
%define requires_device_display_virtio_vga_gl Requires: %{name}-device-display-virtio-vga-gl = %{evr}
%else
%define requires_device_display_vhost_user_gpu %{nil}
%define requires_device_display_virtio_gpu_gl %{nil}
%define requires_device_display_virtio_gpu_pci_gl %{nil}
%define requires_device_display_virtio_vga_gl %{nil}
%endif
%if %{have_rutabaga_gfx}
@ -349,6 +353,8 @@ Obsoletes: %{name}-system-lm32 <= %{epoch}:%{version}-%{release} \
Obsoletes: %{name}-system-lm32-core <= %{epoch}:%{version}-%{release} \
Obsoletes: %{name}-system-moxie <= %{epoch}:%{version}-%{release} \
Obsoletes: %{name}-system-moxie-core <= %{epoch}:%{version}-%{release} \
Obsoletes: %{name}-system-nios2 <= %{epoch}:%{version}-%{release} \
Obsoletes: %{name}-system-nios2-core <= %{epoch}:%{version}-%{release} \
Obsoletes: %{name}-system-unicore32 <= %{epoch}:%{version}-%{release} \
Obsoletes: %{name}-system-unicore32-core <= %{epoch}:%{version}-%{release} \
Obsoletes: sgabios-bin <= 1:0.20180715git-10.fc38
@ -361,11 +367,11 @@ Obsoletes: sgabios-bin <= 1:0.20180715git-10.fc38
%endif
# To prevent rpmdev-bumpspec breakage
%global baserelease 2
%global baserelease 1
Summary: QEMU is a FAST! processor emulator
Name: qemu
Version: 9.0.0
Version: 9.1.0
Release: %{baserelease}%{?rcrel}.0.riscv64%{?dist}
Epoch: 2
License: Apache-2.0 AND BSD-2-Clause AND BSD-3-Clause AND FSFAP AND GPL-1.0-or-later AND GPL-2.0-only AND GPL-2.0-or-later AND GPL-2.0-or-later WITH GCC-exception-2.0 AND LGPL-2.0-only AND LGPL-2.0-or-later AND LGPL-2.1-only AND LGPL-2.1-or-later AND MIT AND LicenseRef-Fedora-Public-Domain AND CC-BY-3.0
@ -395,6 +401,10 @@ Source30: kvm-s390x.conf
Source31: kvm-x86.conf
Source36: README.tests
# Skip failing test in copr
# https://gitlab.com/qemu-project/qemu/-/issues/2541
Patch: 0001-Disable-9p-local-tests-that-fail-on-copr-aarch64.patch
BuildRequires: gnupg2
BuildRequires: meson >= %{meson_version}
BuildRequires: bison
@ -424,6 +434,7 @@ BuildRequires: librbd-devel
# We need both because the 'stap' binary is probed for by configure
BuildRequires: systemtap
BuildRequires: systemtap-sdt-devel
BuildRequires: /usr/bin/dtrace
# For VNC PNG support
BuildRequires: libpng-devel
# For virtiofs
@ -559,14 +570,17 @@ BuildRequires: libxdp-devel
%if %{have_rutabaga_gfx}
BuildRequires: rutabaga-gfx-ffi-devel
%endif
%if 0%{?rhel} <= 9
# Builds on centos-stream 9 require python-tomli
BuildRequires: python-tomli
%endif
%if %{user_static}
BuildRequires: glibc-static glib2-static zlib-static
%if 0%{?fedora} >= 37
BuildRequires: pcre2-static
%else
BuildRequires: pcre-static
%endif
BuildRequires: glibc-static
BuildRequires: glib2-static
BuildRequires: zlib-static
# -latomic added by GLib 2.81.0, 2024-06-28
BuildRequires: libatomic-static
%endif
@ -581,7 +595,6 @@ Requires: %{name}-system-loongarch64 = %{epoch}:%{version}-%{release}
Requires: %{name}-system-m68k = %{epoch}:%{version}-%{release}
Requires: %{name}-system-microblaze = %{epoch}:%{version}-%{release}
Requires: %{name}-system-mips = %{epoch}:%{version}-%{release}
Requires: %{name}-system-nios2 = %{epoch}:%{version}-%{release}
Requires: %{name}-system-or1k = %{epoch}:%{version}-%{release}
Requires: %{name}-system-ppc = %{epoch}:%{version}-%{release}
Requires: %{name}-system-riscv = %{epoch}:%{version}-%{release}
@ -926,12 +939,14 @@ Requires: %{name}-device-display-virtio-gpu%{?_isa} = %{epoch}:%{version}-%{rele
%description device-display-virtio-vga
This package provides the virtio-vga display device for QEMU.
%if %{have_virgl}
%package device-display-virtio-vga-gl
Summary: QEMU virtio-vga-gl display device
Requires: %{name}-common%{?_isa} = %{epoch}:%{version}-%{release}
Requires: %{name}-device-display-virtio-vga%{?_isa} = %{epoch}:%{version}-%{release}
%description device-display-virtio-vga-gl
This package provides the virtio-vga-gl display device for QEMU.
%endif
%if %{have_rutabaga_gfx}
%package device-display-virtio-vga-rutabaga
@ -1071,7 +1086,6 @@ Requires: qemu-user-static-loongarch64
Requires: qemu-user-static-m68k
Requires: qemu-user-static-microblaze
Requires: qemu-user-static-mips
Requires: qemu-user-static-nios2
Requires: qemu-user-static-or1k
Requires: qemu-user-static-ppc
Requires: qemu-user-static-riscv
@ -1080,6 +1094,8 @@ Requires: qemu-user-static-sh4
Requires: qemu-user-static-sparc
Requires: qemu-user-static-x86
Requires: qemu-user-static-xtensa
Obsoletes: qemu-user-static-nios2 <= %{epoch}:%{version}-%{release}
%description user-static
This package provides the user mode emulation of qemu targets built as
@ -1145,12 +1161,6 @@ Summary: QEMU user mode emulation of mips qemu targets static build
This package provides the mips user mode emulation of qemu targets built as
static binaries
%package user-static-nios2
Summary: QEMU user mode emulation of nios2 qemu targets static build
%description user-static-nios2
This package provides the nios2 user mode emulation of qemu targets built as
static binaries
%package user-static-or1k
Summary: QEMU user mode emulation of or1k qemu targets static build
%description user-static-or1k
@ -1347,20 +1357,6 @@ Requires: %{name}-common = %{epoch}:%{version}-%{release}
This package provides the QEMU system emulator for MIPS systems.
%package system-nios2
Summary: QEMU system emulator for nios2
Requires: %{name}-system-nios2-core = %{epoch}:%{version}-%{release}
%{requires_all_modules}
%description system-nios2
This package provides the QEMU system emulator for NIOS2.
%package system-nios2-core
Summary: QEMU system emulator for nios2
Requires: %{name}-common = %{epoch}:%{version}-%{release}
%description system-nios2-core
This package provides the QEMU system emulator for NIOS2.
%package system-or1k
Summary: QEMU system emulator for OpenRisc32
Requires: %{name}-system-or1k-core = %{epoch}:%{version}-%{release}
@ -1537,7 +1533,6 @@ mkdir -p %{static_builddir}
--disable-attr \\\
--disable-auth-pam \\\
--disable-avx2 \\\
--disable-avx512f \\\
--disable-avx512bw \\\
--disable-blkio \\\
--disable-block-drv-whitelist-in-tools \\\
@ -1562,6 +1557,7 @@ mkdir -p %{static_builddir}
--disable-debug-graph-lock \\\
--disable-debug-info \\\
--disable-debug-mutex \\\
--disable-debug-remap \\\
--disable-debug-tcg \\\
--disable-dmg \\\
--disable-docs \\\
@ -1597,7 +1593,6 @@ mkdir -p %{static_builddir}
--disable-linux-aio \\\
--disable-linux-io-uring \\\
--disable-linux-user \\\
--disable-live-block-migration \\\
--disable-lto \\\
--disable-lzfse \\\
--disable-lzo \\\
@ -1619,10 +1614,10 @@ mkdir -p %{static_builddir}
--disable-pipewire \\\
--disable-pixman \\\
--disable-plugins \\\
--disable-pvrdma \\\
--disable-qcow1 \\\
--disable-qed \\\
--disable-qom-cast-debug \\\
--disable-qpl \\\
--disable-rbd \\\
--disable-rdma \\\
--disable-relocatable \\\
@ -1649,6 +1644,7 @@ mkdir -p %{static_builddir}
--disable-tools \\\
--disable-tpm \\\
--disable-tsan \\\
--disable-uadk \\\
--disable-u2f \\\
--disable-usb-redir \\\
--disable-user \\\
@ -1731,7 +1727,6 @@ run_configure \
--enable-attr \
%ifarch %{ix86} x86_64
--enable-avx2 \
--enable-avx512f \
--enable-avx512bw \
%endif
%if %{have_libblkio}
@ -1845,12 +1840,8 @@ run_configure \
--enable-linux-io-uring \
%endif
--enable-linux-user \
--enable-live-block-migration \
--enable-multiprocess \
--enable-parallels \
%if %{have_librdma}
--enable-pvrdma \
%endif
--enable-qcow1 \
--enable-qed \
--enable-qom-cast-debug \
@ -1977,6 +1968,12 @@ install -D -m 0644 %{_sourcedir}/bridge.conf %{buildroot}%{_sysconfdir}/%{name}/
install -m 0644 contrib/systemd/qemu-pr-helper.service %{buildroot}%{_unitdir}
install -m 0644 contrib/systemd/qemu-pr-helper.socket %{buildroot}%{_unitdir}
%if %{have_vmsr_helper}
# Install qemu-vmsr-helper service
install -m 0644 contrib/systemd/qemu-vmsr-helper.service %{buildroot}%{_unitdir}
install -m 0644 contrib/systemd/qemu-vmsr-helper.socket %{buildroot}%{_unitdir}
%endif
%if %{have_memlock_limits}
install -D -p -m 644 %{_sourcedir}/95-kvm-memlock.conf %{buildroot}%{_sysconfdir}/security/limits.d/95-kvm-memlock.conf
%endif
@ -2226,11 +2223,6 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%postun user-static-mips
/bin/systemctl --system try-restart systemd-binfmt.service &>/dev/null || :
%post user-static-nios2
/bin/systemctl --system try-restart systemd-binfmt.service &>/dev/null || :
%postun user-static-nios2
/bin/systemctl --system try-restart systemd-binfmt.service &>/dev/null || :
%post user-static-or1k
/bin/systemctl --system try-restart systemd-binfmt.service &>/dev/null || :
%postun user-static-or1k
@ -2330,8 +2322,11 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_bindir}/qemu-edid
%{_bindir}/qemu-trace-stap
%{_datadir}/%{name}/simpletrace.py*
%dir %{_datadir}/%{name}/tracetool/
%{_datadir}/%{name}/tracetool/*.py*
%dir %{_datadir}/%{name}/tracetool/backend/
%{_datadir}/%{name}/tracetool/backend/*.py*
%dir %{_datadir}/%{name}/tracetool/format/
%{_datadir}/%{name}/tracetool/format/*.py*
%{_datadir}/%{name}/dump-guest-memory.py*
%{_datadir}/%{name}/trace-events-all
@ -2352,6 +2347,7 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_datadir}/%{name}/keymaps/
%{_datadir}/%{name}/linuxboot_dma.bin
%attr(4755, -, -) %{_libexecdir}/qemu-bridge-helper
%dir %{_libdir}/%{name}/
%{_mandir}/man1/%{name}.1*
%{_mandir}/man7/qemu-block-drivers.7*
%{_mandir}/man7/qemu-cpu-models.7*
@ -2470,8 +2466,10 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_libdir}/%{name}/hw-s390x-virtio-gpu-ccw.so
%files device-display-virtio-vga
%{_libdir}/%{name}/hw-display-virtio-vga.so
%if %{have_virgl}
%files device-display-virtio-vga-gl
%{_libdir}/%{name}/hw-display-virtio-vga-gl.so
%endif
%if %{have_rutabaga_gfx}
%files device-display-virtio-vga-rutabaga
%{_libdir}/%{name}/hw-display-virtio-vga-rutabaga.so
@ -2536,7 +2534,6 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_bindir}/qemu-mips64el
%{_bindir}/qemu-mipsn32
%{_bindir}/qemu-mipsn32el
%{_bindir}/qemu-nios2
%{_bindir}/qemu-or1k
%{_bindir}/qemu-ppc
%{_bindir}/qemu-ppc64
@ -2609,9 +2606,6 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_datadir}/systemtap/tapset/qemu-mipsn32el.stp
%{_datadir}/systemtap/tapset/qemu-mipsn32el-log.stp
%{_datadir}/systemtap/tapset/qemu-mipsn32el-simpletrace.stp
%{_datadir}/systemtap/tapset/qemu-nios2.stp
%{_datadir}/systemtap/tapset/qemu-nios2-log.stp
%{_datadir}/systemtap/tapset/qemu-nios2-simpletrace.stp
%{_datadir}/systemtap/tapset/qemu-or1k.stp
%{_datadir}/systemtap/tapset/qemu-or1k-log.stp
%{_datadir}/systemtap/tapset/qemu-or1k-simpletrace.stp
@ -2779,12 +2773,6 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_exec_prefix}/lib/binfmt.d/qemu-mipsn32-static.conf
%{_exec_prefix}/lib/binfmt.d/qemu-mipsn32el-static.conf
%files user-static-nios2
%{_bindir}/qemu-nios2-static
%{_datadir}/systemtap/tapset/qemu-nios2-log-static.stp
%{_datadir}/systemtap/tapset/qemu-nios2-simpletrace-static.stp
%{_datadir}/systemtap/tapset/qemu-nios2-static.stp
%files user-static-or1k
%{_bindir}/qemu-or1k-static
%{_datadir}/systemtap/tapset/qemu-or1k-log-static.stp
@ -3008,15 +2996,6 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_mandir}/man1/qemu-system-mips64.1*
%files system-nios2
%files system-nios2-core
%{_bindir}/qemu-system-nios2
%{_datadir}/systemtap/tapset/qemu-system-nios2.stp
%{_datadir}/systemtap/tapset/qemu-system-nios2-log.stp
%{_datadir}/systemtap/tapset/qemu-system-nios2-simpletrace.stp
%{_mandir}/man1/qemu-system-nios2.1*
%files system-or1k
%files system-or1k-core
%{_bindir}/qemu-system-or1k
@ -3147,6 +3126,11 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%{_bindir}/qemu-kvm
%{_mandir}/man1/qemu-kvm.1*
%endif
%if %{have_vmsr_helper}
%{_bindir}/qemu-vmsr-helper
%{_unitdir}/qemu-vmsr-helper.service
%{_unitdir}/qemu-vmsr-helper.socket
%endif
%files system-xtensa
@ -3166,9 +3150,31 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
%changelog
* Sun Jul 21 2024 David Abdurachmanov <davidlt@rivosinc.com> - 2:9.0.0-2.0.riscv64
* Thu Sep 12 2024 David Abdurachmanov <davidlt@rivosinc.com> - 9.1.0-1.0.riscv64
- Fix riscv64 files
* Thu Sep 05 2024 Cole Robinson <crobinso@redhat.com> - 9.1.0-1
- New release qemu 9.1.0 GA
* Thu Aug 29 2024 Cole Robinson <crobinso@redhat.com> - 9.1.0-0.3.rc4
- New release qemu-9.1.0-rc4
* Mon Aug 26 2024 Cole Robinson <crobinso@redhat.com> - 9.1.0-0.2.rc3
- New release qemu-9.1.0-rc3
* Tue Aug 20 2024 Cole Robinson <crobinso@redhat.com> - 9.1.0-0.1.rc2
- New release qemu-9.1.0-rc2
* Mon Aug 05 2024 Cole Robinson <crobinso@redhat.com> - 2:9.0.0-5
- Fix static builds with new glib2
- Add libdir/qemu to qemu-common (bz 2283996)
* Mon Aug 05 2024 Richard W.M. Jones <rjones@redhat.com> - 2:9.0.0-4
- Rebuild for Xen 4.19.0
* Mon Jul 22 2024 Lumír Balhar <lbalhar@redhat.com> - 2:9.0.0-3
- Add new systemtap-sdt-dtrace to build deps
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2:9.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

View File

@ -1,2 +1,2 @@
SHA512 (qemu-9.0.0.tar.xz) = 1603517cd4c93632ba60ad7261eb67374f12a744bf58f10b0e8686e46d3a02d8b6bf58a0c617f23a1868084aaba6386c24341894f75539e0b816091718721427
SHA512 (qemu-9.0.0.tar.xz.sig) = b94259f56d7da92dd8df60bb9a328f7a275cdf2f7128c1e85039d894da8663d2b058ea4d275442ec80ac9c49fe91f30d489b3f3fc1f97bf845b9fe6851cf9191
SHA512 (qemu-9.1.0.tar.xz) = bf61d65e37945fa8ee8640712c719ace05164d86e6df700b98bdc5f79e0a8d5e8f85bd48e726edb62b2419db20673f63ec8b63a60393a914b09cb365621b35e2
SHA512 (qemu-9.1.0.tar.xz.sig) = d63144ef6d666f9e107cefadebcf89ede67027303d8cc43217e8454133adb6e9740fcc5f8a29cc7e24f052d9e685c7fe361b6e094dd0d607a1ce9161f6ed3b59