New upstream version 1.1.5.

- Adds --accel option to select qemu acceleration mode.
- Remove upstream patch.
This commit is contained in:
Richard W.M. Jones 2014-07-02 19:26:32 +01:00
parent d0c76e3b93
commit f5f00372c0
3 changed files with 8 additions and 38 deletions

View File

@ -1,31 +0,0 @@
From 50675ac8547c6865fe9476f07783a3bd21666aac Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 28 Aug 2013 17:00:29 +0100
Subject: [PATCH] Better search for debug etc. kernels (RHBZ#1002189).
This code now matches the same code in the original febootstrap
(pre-rewrite in C) shell script. Except that we don't look for kernel
names that don't contain $arch, since that would only apply on really
ancient RHEL.
This updates commit e15822c82b3888420187eb32db82554266a6f350.
---
qemu-sanity-check.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qemu-sanity-check.in b/qemu-sanity-check.in
index dc99786..848c62f 100644
--- a/qemu-sanity-check.in
+++ b/qemu-sanity-check.in
@@ -99,7 +99,7 @@ fi
# Locate kernel if not specified.
if [ -z "$kernel" ]; then
- kernel="$(ls -vr /boot/vmlinuz-*.$arch{,+debug} 2>/dev/null | head -1)"
+ kernel="$(ls -1dvr /boot/vmlinuz-*.$arch* 2>/dev/null | grep -v xen | head -1)"
if [ -z "$kernel" ]; then
echo "$0: cannot find a Linux kernel in /boot"
echo "Choose a kernel to test using --kernel=/path/to/vmlinuz"
--
1.8.3.1

View File

@ -1,17 +1,14 @@
%global debug_package %{nil}
Name: qemu-sanity-check
Version: 1.1.4
Release: 3%{?dist}
Version: 1.1.5
Release: 1%{?dist}
Summary: Simple qemu and Linux kernel sanity checker
License: GPLv2+
URL: http://people.redhat.com/~rjones/qemu-sanity-check
Source0: http://people.redhat.com/~rjones/qemu-sanity-check/files/%{name}-%{version}.tar.gz
# Upstream patch included in >= 1.1.5.
Patch1: 0001-Better-search-for-debug-etc.-kernels-RHBZ-1002189.patch
# Non-upstream patch to disable test which fails on broken kernels
# which don't respond to panic=1 option properly.
Patch4: 0004-Disable-bad-userspace-test-Fedora-only.patch
@ -73,7 +70,6 @@ as %{name} except that this package does not depend on qemu or kernel.
%prep
%setup -q
%patch1 -p1
%patch4 -p1
# Rerun autotools because the patches touch configure.ac and Makefile.am.
@ -112,6 +108,11 @@ make DESTDIR=$RPM_BUILD_ROOT install
%changelog
* Wed Jul 02 2014 Richard W.M. Jones <rjones@redhat.com> - 1.1.5-1
- New upstream version 1.1.5.
- Adds --accel option to select qemu acceleration mode.
- Remove upstream patch.
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

View File

@ -1 +1 @@
5fb1842dfbbe2ce1841a76e96d8cb93f qemu-sanity-check-1.1.4.tar.gz
cceb7bb200adee4136e25b77e3c12cb0 qemu-sanity-check-1.1.5.tar.gz