New upstream version 1.1.4.

- Remove 3 x patches which are now upstream.
- This version can handle debug kernels (RHBZ#1002189).
This commit is contained in:
Richard W.M. Jones 2013-08-28 17:03:56 +01:00
parent 3702e20324
commit 35bc9132fa
2 changed files with 37 additions and 2 deletions

View File

@ -0,0 +1,31 @@
From 50675ac8547c6865fe9476f07783a3bd21666aac Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 28 Aug 2013 17:00:29 +0100
Subject: [PATCH] Better search for debug etc. kernels (RHBZ#1002189).
This code now matches the same code in the original febootstrap
(pre-rewrite in C) shell script. Except that we don't look for kernel
names that don't contain $arch, since that would only apply on really
ancient RHEL.
This updates commit e15822c82b3888420187eb32db82554266a6f350.
---
qemu-sanity-check.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qemu-sanity-check.in b/qemu-sanity-check.in
index dc99786..848c62f 100644
--- a/qemu-sanity-check.in
+++ b/qemu-sanity-check.in
@@ -99,7 +99,7 @@ fi
# Locate kernel if not specified.
if [ -z "$kernel" ]; then
- kernel="$(ls -vr /boot/vmlinuz-*.$arch{,+debug} 2>/dev/null | head -1)"
+ kernel="$(ls -1dvr /boot/vmlinuz-*.$arch* 2>/dev/null | grep -v xen | head -1)"
if [ -z "$kernel" ]; then
echo "$0: cannot find a Linux kernel in /boot"
echo "Choose a kernel to test using --kernel=/path/to/vmlinuz"
--
1.8.3.1

View File

@ -2,13 +2,16 @@
Name: qemu-sanity-check
Version: 1.1.4
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Simple qemu and Linux kernel sanity checker
License: GPLv2+
URL: http://people.redhat.com/~rjones/qemu-sanity-check
Source0: http://people.redhat.com/~rjones/qemu-sanity-check/files/%{name}-%{version}.tar.gz
# Upstream patch included in >= 1.1.5.
Patch1: 0001-Better-search-for-debug-etc.-kernels-RHBZ-1002189.patch
# Non-upstream patch to disable test which fails on broken kernels
# which don't respond to panic=1 option properly.
Patch4: 0004-Disable-bad-userspace-test-Fedora-only.patch
@ -70,6 +73,7 @@ as %{name} except that this package does not depend on qemu or kernel.
%prep
%setup -q
%patch1 -p1
%patch4 -p1
# Rerun autotools because the patches touch configure.ac and Makefile.am.
@ -108,7 +112,7 @@ make DESTDIR=$RPM_BUILD_ROOT install
%changelog
* Wed Aug 28 2013 Richard W.M. Jones <rjones@redhat.com> - 1.1.4-1
* Wed Aug 28 2013 Richard W.M. Jones <rjones@redhat.com> - 1.1.4-2
- New upstream version 1.1.4.
- Remove 3 x patches which are now upstream.
- This version can handle debug kernels (RHBZ#1002189).