Fix test_gdb failure on ppc64le (rhbz#1095355)
This commit is contained in:
parent
8ab4c2d31f
commit
da5702456f
30
00196-test-gdb-match-addr-before-builtin.patch
Normal file
30
00196-test-gdb-match-addr-before-builtin.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
Subject: python3.test gdb match addr before builtin
|
||||||
|
From: Michel Normand <normand@linux.vnet.ibm.com>
|
||||||
|
|
||||||
|
For ppc64le archi and python3... and gdb... versions
|
||||||
|
the test_gdb.py need a change of re.match to handle address before the builtin_id word.
|
||||||
|
Of course there is no error if this substring is not present.
|
||||||
|
===
|
||||||
|
...
|
||||||
|
#0 0x00003fffb7dd0898 in builtin_id (self=<module at remote 0x3fffb7901440>, v=<unknown at remote 0x3fffb7f68910>) at /builddir/build/BUILD/Python-3.3.2/Python/bltinmodule.c:966
|
||||||
|
....xxxxxxxxxxxxxxxxxxxxxx <= added regexp
|
||||||
|
===
|
||||||
|
|
||||||
|
Signed-off-by: Michel Normand <normand@linux.vnet.ibm.com>
|
||||||
|
---
|
||||||
|
Lib/test/test_gdb.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
Index: Python-3.3.2/Lib/test/test_gdb.py
|
||||||
|
===================================================================
|
||||||
|
--- Python-3.3.2.orig/Lib/test/test_gdb.py
|
||||||
|
+++ Python-3.3.2/Lib/test/test_gdb.py
|
||||||
|
@@ -230,7 +230,7 @@ class DebuggerTests(unittest.TestCase):
|
||||||
|
# gdb can insert additional '\n' and space characters in various places
|
||||||
|
# in its output, depending on the width of the terminal it's connected
|
||||||
|
# to (using its "wrap_here" function)
|
||||||
|
- m = re.match('.*#0\s+builtin_id\s+\(self\=.*,\s+v=\s*(.*?)\)\s+at\s+\S*Python/bltinmodule.c.*',
|
||||||
|
+ m = re.match('.*#0\s+(?: 0x[0-9a-f]+\s+in\s+)?builtin_id\s+\(self\=.*,\s+v=\s*(.*?)\)\s+at\s+\S*Python/bltinmodule.c.*',
|
||||||
|
gdb_output, re.DOTALL)
|
||||||
|
if not m:
|
||||||
|
self.fail('Unexpected gdb output: %r\n%s' % (gdb_output, gdb_output))
|
12
python3.spec
12
python3.spec
@ -128,7 +128,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.0
|
Version: %{pybasever}.0
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
|
|
||||||
@ -670,6 +670,11 @@ Patch194: temporarily-disable-tests-requiring-SIGHUP.patch
|
|||||||
# http://bugs.python.org/issue21121
|
# http://bugs.python.org/issue21121
|
||||||
Patch195: 00195-dont-add-Werror-declaration-after-statement.patch
|
Patch195: 00195-dont-add-Werror-declaration-after-statement.patch
|
||||||
|
|
||||||
|
# 00196
|
||||||
|
#
|
||||||
|
# Fix test_gdb failure on ppc64le
|
||||||
|
Patch196: 00196-test-gdb-match-addr-before-builtin.patch
|
||||||
|
|
||||||
# (New patches go here ^^^)
|
# (New patches go here ^^^)
|
||||||
#
|
#
|
||||||
# When adding new patches to "python" and "python3" in Fedora 17 onwards,
|
# When adding new patches to "python" and "python3" in Fedora 17 onwards,
|
||||||
@ -945,6 +950,7 @@ done
|
|||||||
%patch193 -p1
|
%patch193 -p1
|
||||||
%patch194 -p1
|
%patch194 -p1
|
||||||
%patch195 -p1
|
%patch195 -p1
|
||||||
|
%patch196 -p1
|
||||||
|
|
||||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||||
# are many differences between 2.6 and the Python 3 library.
|
# are many differences between 2.6 and the Python 3 library.
|
||||||
@ -1820,6 +1826,10 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun May 25 2014 Matej Stuchlik <mstuchli@redhat.com> - 3.4.0-8
|
||||||
|
- Fix test_gdb failure on ppc64le
|
||||||
|
Resolves: rhbz#1095355
|
||||||
|
|
||||||
* Thu May 22 2014 Miro Hrončok <mhroncok@redhat.com> - 3.4.0-7
|
* Thu May 22 2014 Miro Hrončok <mhroncok@redhat.com> - 3.4.0-7
|
||||||
- Add macro %%python3_version_nodots
|
- Add macro %%python3_version_nodots
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user