- add flags for statvfs.f_flag to the constant list in posixmodule (i.e.
"os") (patch 105)
This commit is contained in:
parent
021b2bcd4a
commit
d73e38d70d
62
python-2.6.5-statvfs-f_flag-constants.patch
Normal file
62
python-2.6.5-statvfs-f_flag-constants.patch
Normal file
@ -0,0 +1,62 @@
|
|||||||
|
From 21fda4c78000d78cb1824fdf0373031d07f5325a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Jones <pjones@redhat.com>
|
||||||
|
Date: Wed, 6 Jan 2010 15:22:38 -0500
|
||||||
|
Subject: [PATCH] Add flags for statvfs.f_flag to constant list.
|
||||||
|
|
||||||
|
You really need these to figure out what statvfs is trying to say to
|
||||||
|
you, so add them here.
|
||||||
|
---
|
||||||
|
Modules/posixmodule.c | 37 +++++++++++++++++++++++++++++++++++++
|
||||||
|
1 files changed, 37 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Modules/posixmodule.c b/Modules/posixmodule.c
|
||||||
|
index ebdbc8d..d79013b 100644
|
||||||
|
--- a/Modules/posixmodule.c
|
||||||
|
+++ b/Modules/posixmodule.c
|
||||||
|
@@ -8990,6 +8990,43 @@ all_ins(PyObject *d)
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+ /* These came from statvfs.h */
|
||||||
|
+#ifdef ST_RDONLY
|
||||||
|
+ if (ins(d, "ST_RDONLY", (long)ST_RDONLY)) return -1;
|
||||||
|
+#endif /* ST_RDONLY */
|
||||||
|
+#ifdef ST_NOSUID
|
||||||
|
+ if (ins(d, "ST_NOSUID", (long)ST_NOSUID)) return -1;
|
||||||
|
+#endif /* ST_NOSUID */
|
||||||
|
+
|
||||||
|
+ /* GNU extensions */
|
||||||
|
+#ifdef ST_NODEV
|
||||||
|
+ if (ins(d, "ST_NODEV", (long)ST_NODEV)) return -1;
|
||||||
|
+#endif /* ST_NODEV */
|
||||||
|
+#ifdef ST_NOEXEC
|
||||||
|
+ if (ins(d, "ST_NOEXEC", (long)ST_NOEXEC)) return -1;
|
||||||
|
+#endif /* ST_NOEXEC */
|
||||||
|
+#ifdef ST_SYNCHRONOUS
|
||||||
|
+ if (ins(d, "ST_SYNCHRONOUS", (long)ST_SYNCHRONOUS)) return -1;
|
||||||
|
+#endif /* ST_SYNCHRONOUS */
|
||||||
|
+#ifdef ST_MANDLOCK
|
||||||
|
+ if (ins(d, "ST_MANDLOCK", (long)ST_MANDLOCK)) return -1;
|
||||||
|
+#endif /* ST_MANDLOCK */
|
||||||
|
+#ifdef ST_WRITE
|
||||||
|
+ if (ins(d, "ST_WRITE", (long)ST_WRITE)) return -1;
|
||||||
|
+#endif /* ST_WRITE */
|
||||||
|
+#ifdef ST_APPEND
|
||||||
|
+ if (ins(d, "ST_APPEND", (long)ST_APPEND)) return -1;
|
||||||
|
+#endif /* ST_APPEND */
|
||||||
|
+#ifdef ST_NOATIME
|
||||||
|
+ if (ins(d, "ST_NOATIME", (long)ST_NOATIME)) return -1;
|
||||||
|
+#endif /* ST_NOATIME */
|
||||||
|
+#ifdef ST_NODIRATIME
|
||||||
|
+ if (ins(d, "ST_NODIRATIME", (long)ST_NODIRATIME)) return -1;
|
||||||
|
+#endif /* ST_NODIRATIME */
|
||||||
|
+#ifdef ST_RELATIME
|
||||||
|
+ if (ins(d, "ST_RELATIME", (long)ST_RELATIME)) return -1;
|
||||||
|
+#endif /* ST_RELATIME */
|
||||||
|
+
|
||||||
|
#if defined(PYOS_OS2)
|
||||||
|
if (insertvalues(d)) return -1;
|
||||||
|
#endif
|
||||||
|
--
|
||||||
|
1.6.6
|
||||||
|
|
10
python3.spec
10
python3.spec
@ -40,7 +40,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.2
|
Version: %{pybasever}.2
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
||||||
@ -200,6 +200,9 @@ Patch103: python-3.1.2-debug-build.patch
|
|||||||
# extension modules will reliably use them
|
# extension modules will reliably use them
|
||||||
Patch104: python-3.1.2-more-configuration-flags.patch
|
Patch104: python-3.1.2-more-configuration-flags.patch
|
||||||
|
|
||||||
|
# Add flags for statvfs.f_flag to the constant list in posixmodule (i.e. "os")
|
||||||
|
# (rhbz:553020); partially upstream as http://bugs.python.org/issue7647
|
||||||
|
Patch105: python-2.6.5-statvfs-f_flag-constants.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildRequires: readline-devel, openssl-devel, gmp-devel
|
BuildRequires: readline-devel, openssl-devel, gmp-devel
|
||||||
@ -352,6 +355,7 @@ rm -r Modules/zlib || exit 1
|
|||||||
%patch103 -p1 -b .debug-build
|
%patch103 -p1 -b .debug-build
|
||||||
%patch104 -p1 -b .more-configuration-flags
|
%patch104 -p1 -b .more-configuration-flags
|
||||||
|
|
||||||
|
%patch105 -p1 -b .statvfs-f-flag-constants
|
||||||
|
|
||||||
|
|
||||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||||
@ -1030,6 +1034,10 @@ rm -fr %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 26 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-8
|
||||||
|
- add flags for statvfs.f_flag to the constant list in posixmodule (i.e. "os")
|
||||||
|
(patch 105)
|
||||||
|
|
||||||
* Tue May 25 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-7
|
* Tue May 25 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-7
|
||||||
- add configure-time support for COUNT_ALLOCS and CALL_PROFILE debug options
|
- add configure-time support for COUNT_ALLOCS and CALL_PROFILE debug options
|
||||||
(patch 104); enable them and the WITH_TSC option within the debug build
|
(patch 104); enable them and the WITH_TSC option within the debug build
|
||||||
|
Loading…
Reference in New Issue
Block a user