34c15c7789
* Mon Jan 17 2011 David Malcolm <dmalcolm@redhat.com> - 3.2-0.9.rc1 - 3.2rc1 - rework patch 6 (static lib removal) - remove upstreamed patch 130 (ppc debug build) - regenerate patch 300 (autotool intermediates) - updated packaging to reflect upstream rewrite of "Demo" (issue 7962) - added libpython3.so and 2to3-3.2
175 lines
4.9 KiB
Diff
175 lines
4.9 KiB
Diff
diff -up ./configure.autotool-intermediates ./configure
|
|
--- ./configure.autotool-intermediates 2011-01-17 13:09:50.836697224 -0500
|
|
+++ ./configure 2011-01-17 13:09:56.662690482 -0500
|
|
@@ -1,5 +1,5 @@
|
|
#! /bin/sh
|
|
-# From configure.in Revision: 87646 .
|
|
+# From configure.in Revision: 87698 .
|
|
# Guess values for system-dependent variables and create Makefiles.
|
|
# Generated by GNU Autoconf 2.65 for python 3.2.
|
|
#
|
|
@@ -611,6 +611,8 @@ TRUE
|
|
MACHDEP_OBJS
|
|
DYNLOADFILE
|
|
DLINCLDIR
|
|
+DTRACEHDRS
|
|
+DTRACEOBJS
|
|
THREADOBJ
|
|
LDLAST
|
|
USE_THREAD_MODULE
|
|
@@ -749,8 +751,11 @@ with_thread
|
|
enable_ipv6
|
|
with_doc_strings
|
|
with_tsc
|
|
+with_count_allocs
|
|
+with_call_profile
|
|
with_pymalloc
|
|
with_valgrind
|
|
+with_dtrace
|
|
with_fpectl
|
|
with_libm
|
|
with_libc
|
|
@@ -1421,8 +1426,11 @@ Optional Packages:
|
|
deprecated; use --with(out)-threads
|
|
--with(out)-doc-strings disable/enable documentation strings
|
|
--with(out)-tsc enable/disable timestamp counter profile
|
|
+ --with(out)count-allocs enable/disable per-type instance accounting
|
|
+ --with(out)-call-profile enable/disable statistics on function call invocation
|
|
--with(out)-pymalloc disable/enable specialized mallocs
|
|
--with-valgrind Enable Valgrind support
|
|
+ --with(out)-dtrace disable/enable dtrace support
|
|
--with-fpectl enable SIGFPE catching
|
|
--with-libm=STRING math library
|
|
--with-libc=STRING C library
|
|
@@ -9138,6 +9146,50 @@ $as_echo "no" >&6; }
|
|
fi
|
|
|
|
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-count-allocs" >&5
|
|
+$as_echo_n "checking for --with-count-allocs... " >&6; }
|
|
+
|
|
+# Check whether --with-count-allocs was given.
|
|
+if test "${with_count_allocs+set}" = set; then :
|
|
+ withval=$with_count_allocs;
|
|
+if test "$withval" != no
|
|
+then
|
|
+
|
|
+$as_echo "#define COUNT_ALLOCS 1" >>confdefs.h
|
|
+
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
+$as_echo "yes" >&6; }
|
|
+else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+
|
|
+
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-call-profile" >&5
|
|
+$as_echo_n "checking for --with-call-profile... " >&6; }
|
|
+
|
|
+# Check whether --with-call-profile was given.
|
|
+if test "${with_call_profile+set}" = set; then :
|
|
+ withval=$with_call_profile;
|
|
+if test "$withval" != no
|
|
+then
|
|
+
|
|
+$as_echo "#define CALL_PROFILE 1" >>confdefs.h
|
|
+
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
+$as_echo "yes" >&6; }
|
|
+else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+
|
|
+
|
|
# Check for Python-specific malloc support
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-pymalloc" >&5
|
|
$as_echo_n "checking for --with-pymalloc... " >&6; }
|
|
@@ -9190,6 +9242,46 @@ fi
|
|
OPT="-DDYNAMIC_ANNOTATIONS_ENABLED=1 $OPT"
|
|
fi
|
|
|
|
+# Check for dtrace support
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-dtrace" >&5
|
|
+$as_echo_n "checking for --with-dtrace... " >&6; }
|
|
+
|
|
+# Check whether --with-dtrace was given.
|
|
+if test "${with_dtrace+set}" = set; then :
|
|
+ withval=$with_dtrace;
|
|
+fi
|
|
+
|
|
+
|
|
+if test ! -z "$with_dtrace"
|
|
+then
|
|
+ if dtrace -G -o /dev/null -s $srcdir/Include/pydtrace.d 2>/dev/null
|
|
+ then
|
|
+
|
|
+$as_echo "#define WITH_DTRACE 1" >>confdefs.h
|
|
+
|
|
+ with_dtrace="Sun"
|
|
+ DTRACEOBJS="Python/dtrace.o"
|
|
+ DTRADEHDRS=""
|
|
+ elif dtrace -h -o /dev/null -s $srcdir/Include/pydtrace.d
|
|
+ then
|
|
+
|
|
+$as_echo "#define WITH_DTRACE 1" >>confdefs.h
|
|
+
|
|
+ with_dtrace="Apple"
|
|
+ DTRACEOBJS=""
|
|
+ DTRADEHDRS="pydtrace.h"
|
|
+ else
|
|
+ with_dtrace="no"
|
|
+ fi
|
|
+else
|
|
+ with_dtrace="no"
|
|
+fi
|
|
+
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_dtrace" >&5
|
|
+$as_echo "$with_dtrace" >&6; }
|
|
+
|
|
+
|
|
+
|
|
# -I${DLINCLDIR} is added to the compile rule for importdl.o
|
|
|
|
DLINCLDIR=.
|
|
@@ -14304,8 +14396,8 @@ esac
|
|
|
|
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
|
|
# Files that config.status was made for.
|
|
-config_files="`echo $ac_config_files`"
|
|
-config_headers="`echo $ac_config_headers`"
|
|
+config_files="$ac_config_files"
|
|
+config_headers="$ac_config_headers"
|
|
|
|
_ACEOF
|
|
|
|
diff -up ./pyconfig.h.in.autotool-intermediates ./pyconfig.h.in
|
|
--- ./pyconfig.h.in.autotool-intermediates 2011-01-17 13:09:50.827696887 -0500
|
|
+++ ./pyconfig.h.in 2011-01-17 13:09:56.963611199 -0500
|
|
@@ -12,15 +12,15 @@
|
|
support for AIX C++ shared extension modules. */
|
|
#undef AIX_GENUINE_CPLUSPLUS
|
|
|
|
-/* Define if you have the Mach cthreads package */
|
|
-#undef C_THREADS
|
|
-
|
|
/* Define to keep records on function call invocation */
|
|
#undef CALL_PROFILE
|
|
|
|
/* Define to keep records of the number of instances of each type */
|
|
#undef COUNT_ALLOCS
|
|
|
|
+/* Define if you have the Mach cthreads package */
|
|
+#undef C_THREADS
|
|
+
|
|
/* Define if C doubles are 64-bit IEEE 754 binary format, stored in ARM
|
|
mixed-endian order (byte order 45670123) */
|
|
#undef DOUBLE_IS_ARM_MIXED_ENDIAN_IEEE754
|