Add support for RISC-V (riscv64)

Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
David Abdurachmanov 2018-11-23 09:09:19 +01:00
parent 54d40fa62a
commit 83c3317774
Signed by: davidlt
GPG Key ID: 7108702C938B13C1
2 changed files with 28 additions and 1 deletions

View File

@ -0,0 +1,19 @@
diff --git a/configure.ac b/configure.ac
index 94b0db0..0da9814 100644
--- a/configure.ac
+++ b/configure.ac
@@ -846,6 +846,14 @@ cat >> conftest.c <<EOF
sparc64-linux-gnu
# elif defined(__sparc__)
sparc-linux-gnu
+# elif defined(__riscv)
+# if __riscv_xlen == 32
+ riscv32-linux-gnu
+# elif __riscv_xlen == 64
+ riscv64-linux-gnu
+# else
+# error unknown platform triplet
+# endif
# else
# error unknown platform triplet
# endif

View File

@ -14,7 +14,7 @@ URL: https://www.python.org/
# WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well
Version: %{pybasever}.7
Release: 1%{?dist}
Release: 1.0.riscv64%{?dist}
License: Python
@ -351,6 +351,9 @@ Patch292: 00292-restore-PyExc_RecursionErrorInst-symbol.patch
# See also: https://bugzilla.redhat.com/show_bug.cgi?id=1489816
Patch294: 00294-define-TLS-cipher-suite-on-build-time.patch
# Add riscv64-linux-gnu to the triplet detection
Patch400: Python-3.6.7-riscv-triplets.patch
# (New patches go here ^^^)
#
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
@ -677,6 +680,8 @@ rm Lib/ensurepip/_bundled/*.whl
%patch292 -p1
%patch294 -p1
# riscv64
%patch400 -p1
# Remove files that should be generated by the build
# (This is after patching, so that we can use patches directly from upstream)
@ -1557,6 +1562,9 @@ CheckPython optimized
# ======================================================
%changelog
* Fri Nov 23 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 3.6.7-1.0.riscv64
- Add support for RISC-V (riscv64)
* Mon Oct 22 2018 Miro Hrončok <mhroncok@redhat.com> - 3.6.7-1
- Update to 3.6.7