Revert "Add --executable option to install.py command"
This enhancement is currently not needed and it can possibly
collide with `pip --editable`option
Reverts commit ef5c6fe479
.
This commit is contained in:
parent
2c3b2229eb
commit
58f92d897b
@ -1,45 +0,0 @@
|
||||
diff --git a/Lib/distutils/cmd.py b/Lib/distutils/cmd.py
|
||||
index c89d5ef..dd61621 100644
|
||||
--- a/Lib/distutils/cmd.py
|
||||
+++ b/Lib/distutils/cmd.py
|
||||
@@ -296,7 +296,8 @@ class Command:
|
||||
finalized command object.
|
||||
"""
|
||||
cmd_obj = self.distribution.get_command_obj(command, create)
|
||||
- cmd_obj.ensure_finalized()
|
||||
+ if cmd_obj is not None:
|
||||
+ cmd_obj.ensure_finalized()
|
||||
return cmd_obj
|
||||
|
||||
# XXX rename to 'get_reinitialized_command()'? (should do the
|
||||
diff --git a/Lib/distutils/command/install.py b/Lib/distutils/command/install.py
|
||||
index 8174192..30ca739 100644
|
||||
--- a/Lib/distutils/command/install.py
|
||||
+++ b/Lib/distutils/command/install.py
|
||||
@@ -122,6 +122,8 @@ class install(Command):
|
||||
"force installation (overwrite any existing files)"),
|
||||
('skip-build', None,
|
||||
"skip rebuilding everything (for testing/debugging)"),
|
||||
+ ('executable=', 'e',
|
||||
+ "specify final destination interpreter path (install.py)"),
|
||||
|
||||
# Where to install documentation (eventually!)
|
||||
#('doc-format=', None, "format of documentation to generate"),
|
||||
@@ -194,6 +196,7 @@ class install(Command):
|
||||
# directory not in sys.path.
|
||||
self.force = 0
|
||||
self.skip_build = 0
|
||||
+ self.executable = None
|
||||
self.warn_dir = 1
|
||||
|
||||
# These are only here as a conduit from the 'build' command to the
|
||||
@@ -365,6 +368,9 @@ class install(Command):
|
||||
('build_base', 'build_base'),
|
||||
('build_lib', 'build_lib'))
|
||||
|
||||
+ if self.executable is None:
|
||||
+ self.executable = os.path.normpath(sys.executable)
|
||||
+
|
||||
# Punt on doc directories for now -- after all, we're punting on
|
||||
# documentation completely!
|
||||
|
14
python3.spec
14
python3.spec
@ -133,7 +133,7 @@
|
||||
Summary: Version 3 of the Python programming language aka Python 3000
|
||||
Name: python3
|
||||
Version: %{pybasever}.2
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: Python
|
||||
Group: Development/Languages
|
||||
|
||||
@ -417,12 +417,6 @@ Patch243: 00243-fix-mips64-triplet.patch
|
||||
# Fedora Change: https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
|
||||
Patch251: 00251-change-user-install-location.patch
|
||||
|
||||
# 00252
|
||||
# Add executable option to install.py command to make it work for
|
||||
# scripts specified as an entry_points
|
||||
# Reported upstream: https://bugs.python.org/issue29411
|
||||
Patch252: 00252-add-executable-option.patch
|
||||
|
||||
# 00262 #
|
||||
# Backport of PEP 538: Coercing the legacy C locale to a UTF-8 based locale
|
||||
# https://www.python.org/dev/peps/pep-0538/
|
||||
@ -721,7 +715,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
%patch206 -p1
|
||||
%patch243 -p1
|
||||
%patch251 -p1
|
||||
%patch252 -p1
|
||||
%patch262 -p1
|
||||
|
||||
%ifarch aarch64
|
||||
@ -1696,6 +1689,11 @@ fi
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Fri Aug 11 2017 Michal Cyprian <mcyprian@redhat.com> - 3.6.2-7
|
||||
- Revert "Add --executable option to install.py command"
|
||||
This enhancement is currently not needed and it can possibly
|
||||
collide with `pip --editable`option
|
||||
|
||||
* Mon Aug 07 2017 Iryna Shcherbina <ishcherb@redhat.com> - 3.6.2-6
|
||||
- Fix the "urllib FTP protocol stream injection" vulnerability
|
||||
Resolves: rhbz#1478916
|
||||
|
Loading…
Reference in New Issue
Block a user