disable rAssertAlmostEqual in test_cmath on PPC (#750811)
This commit is contained in:
parent
8c9e381740
commit
1af13838fd
11
00150-disable-rAssertAlmostEqual-cmath-on-ppc.patch
Normal file
11
00150-disable-rAssertAlmostEqual-cmath-on-ppc.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -up Python-3.2.2/Lib/test/test_cmath.py.ppc Python-3.2.2/Lib/test/test_cmath.py
|
||||
--- Python-3.2.2/Lib/test/test_cmath.py.ppc 2011-12-07 23:43:55.000000000 +0100
|
||||
+++ Python-3.2.2/Lib/test/test_cmath.py 2011-12-07 23:49:44.000000000 +0100
|
||||
@@ -95,6 +95,7 @@ class CMathTests(unittest.TestCase):
|
||||
self.assertFloatIdentical(x.real, y.real)
|
||||
self.assertFloatIdentical(x.imag, y.imag)
|
||||
|
||||
+ @unittest.skip('Known failure on PPC: glibc bug https://bugzilla.redhat.com/show_bug.cgi?id=750811')
|
||||
def rAssertAlmostEqual(self, a, b, rel_err = 2e-15, abs_err = 5e-323,
|
||||
msg=None):
|
||||
"""Fail if the two floating-point numbers are not almost equal.
|
14
python3.spec
14
python3.spec
@ -122,7 +122,7 @@
|
||||
Summary: Version 3 of the Python programming language aka Python 3000
|
||||
Name: python3
|
||||
Version: %{pybasever}.2
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
License: Python
|
||||
Group: Development/Languages
|
||||
|
||||
@ -367,6 +367,12 @@ Patch148: 00148-gdbm-1.9-magic-values.patch
|
||||
# (upstream commits 27a36b05caed and 651e84363001):
|
||||
Patch149: 00149-backport-issue11254-pycache-bytecompilation-fix.patch
|
||||
|
||||
# temporarily disable rAssertAlmostEqual in test_cmath on PPC (bz #750811)
|
||||
# caused by a glibc bug. This patch can be removed when we have a glibc with
|
||||
# the patch mentioned here:
|
||||
# http://sourceware.org/bugzilla/show_bug.cgi?id=13472
|
||||
Patch150: 00150-disable-rAssertAlmostEqual-cmath-on-ppc.patch
|
||||
|
||||
# (New patches go here ^^^)
|
||||
#
|
||||
# When adding new patches to "python" and "python3" in Fedora 17 onwards,
|
||||
@ -579,6 +585,9 @@ done
|
||||
%patch147 -p1
|
||||
%patch148 -p1
|
||||
%patch149 -p1
|
||||
%ifarch ppc ppc64
|
||||
%patch150 -p1
|
||||
%endif
|
||||
|
||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||
# are many differences between 2.6 and the Python 3 library.
|
||||
@ -1391,6 +1400,9 @@ rm -fr %{buildroot}
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Wed Dec 07 2011 Karsten Hopp <karsten@redhat.com> 3.2.2-10
|
||||
- disable rAssertAlmostEqual in test_cmath on PPC (#750811)
|
||||
|
||||
* Mon Oct 17 2011 Rex Dieter <rdieter@fedoraproject.org> - 3.2.2-9
|
||||
- python3-devel missing autogenerated pkgconfig() provides (#746751)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user