29 lines
771 B
Diff
29 lines
771 B
Diff
diff --git a/Include/Python.h b/Include/Python.h
|
|
index dd595ea5e4c..1feb1531cc9 100644
|
|
--- a/Include/Python.h
|
|
+++ b/Include/Python.h
|
|
@@ -35,6 +35,9 @@
|
|
#ifdef HAVE_UNISTD_H
|
|
#include <unistd.h>
|
|
#endif
|
|
+#ifdef HAVE_CRYPT_H
|
|
+#include <crypt.h>
|
|
+#endif
|
|
|
|
/* For size_t? */
|
|
#ifdef HAVE_STDDEF_H
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 03b0f501aff..15ef872a53a 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2041,7 +2041,7 @@ dnl AC_MSG_RESULT($cpp_type)
|
|
|
|
# checks for header files
|
|
AC_HEADER_STDC
|
|
-AC_CHECK_HEADERS(asm/types.h conio.h direct.h dlfcn.h errno.h \
|
|
+AC_CHECK_HEADERS(asm/types.h crypt.h conio.h direct.h dlfcn.h errno.h \
|
|
fcntl.h grp.h \
|
|
ieeefp.h io.h langinfo.h libintl.h process.h pthread.h \
|
|
sched.h shadow.h signal.h stropts.h termios.h \
|
|
|