python3/python-3.1.2-fix-expat-issue9054.patch
Toshio Kuratomi 05a8f80b75 - Fix an incompatibility between pyexpat and the system expat-2.0.1 that
led to a segfault running test_pyexpat.py (patch 110; upstream issue
    9054; rhbz#610312)

Conflicts:

	python3.spec
2010-08-22 23:19:21 -04:00

15 lines
371 B
Diff

Index: Modules/pyexpat.c
===================================================================
--- Modules/pyexpat.c (revision 81539)
+++ Modules/pyexpat.c (working copy)
@@ -415,6 +415,9 @@
PyObject *args;
PyObject *temp;
+ if (!have_handler(self, CharacterData))
+ return -1;
+
args = PyTuple_New(1);
if (args == NULL)
return -1;