Add dashes to platform-python

This commit is contained in:
Petr Viktorin 2017-08-03 16:32:20 +02:00
parent f1a8d261ca
commit deb805687a
2 changed files with 37 additions and 36 deletions

View File

@ -106,7 +106,7 @@ index 7f1a991..8ca765f 100644
self.assertEqual(dirs[0], wanted)
else:
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 4f8c042..2207596 100644
index 4f8c042..3d44cf4 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -137,10 +137,10 @@ SCRIPTDIR= $(prefix)/lib64
@ -129,7 +129,7 @@ index 4f8c042..2207596 100644
-libpython$(LDVERSION).so: $(LIBRARY_OBJS)
+libplatformpython$(LDVERSION).so: $(LIBRARY_OBJS)
+libplatform-python$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
$(LN) -f $(INSTSONAME) $@; \
@ -138,18 +138,29 @@ index 4f8c042..2207596 100644
fi
-libpython3.so: libpython$(LDVERSION).so
+libplatformpython3.so: libplatformpython$(LDVERSION).so
+libplatform-python3.so: libplatform-python$(LDVERSION).so
$(BLDSHARED) $(NO_AS_NEEDED) -o $@ -Wl,-h$@ $^
libpython$(LDVERSION).dylib: $(LIBRARY_OBJS)
$(CC) -dynamiclib -Wl,-single_module $(PY_LDFLAGS) -undefined dynamic_lookup -Wl,-install_name,$(prefix)/lib/libpython$(LDVERSION).dylib -Wl,-compatibility_version,$(VERSION) -Wl,-current_version,$(VERSION) -o $@ $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-libpython$(LDVERSION).dylib: $(LIBRARY_OBJS)
- $(CC) -dynamiclib -Wl,-single_module $(PY_LDFLAGS) -undefined dynamic_lookup -Wl,-install_name,$(prefix)/lib/libpython$(LDVERSION).dylib -Wl,-compatibility_version,$(VERSION) -Wl,-current_version,$(VERSION) -o $@ $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
+libplatform-python$(LDVERSION).dylib: $(LIBRARY_OBJS)
+ $(CC) -dynamiclib -Wl,-single_module $(PY_LDFLAGS) -undefined dynamic_lookup -Wl,-install_name,$(prefix)/lib/libplatform-python$(LDVERSION).dylib -Wl,-compatibility_version,$(VERSION) -Wl,-current_version,$(VERSION) -o $@ $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-libpython$(VERSION).sl: $(LIBRARY_OBJS)
+libplatformpython$(VERSION).sl: $(LIBRARY_OBJS)
+libplatform-python$(VERSION).sl: $(LIBRARY_OBJS)
$(LDSHARED) -o $@ $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST)
# Copy up the gdb python hooks into a position where they can be automatically
@@ -1095,7 +1095,7 @@ altbininstall: $(BUILDPYTHON) @FRAMEWORKPYTHONW@
fi; \
done
if test "$(PYTHONFRAMEWORKDIR)" = "no-framework" ; then \
- $(INSTALL_PROGRAM) $(BUILDPYTHON) $(DESTDIR)$(BINDIR)/python$(LDVERSION)$(EXE); \
+ $(INSTALL_PROGRAM) $(BUILDPYTHON) $(DESTDIR)$(BINDIR)/platform-python$(LDVERSION)$(EXE); \
else \
$(INSTALL_PROGRAM) $(STRIPFLAG) Mac/pythonw $(DESTDIR)$(BINDIR)/python$(LDVERSION)$(EXE); \
fi
@@ -1139,13 +1139,13 @@ bininstall: altbininstall
-if test "$(VERSION)" != "$(LDVERSION)"; then \
rm -f $(DESTDIR)$(BINDIR)/python$(VERSION)-config; \
@ -167,6 +178,15 @@ index 4f8c042..2207596 100644
-rm -f $(DESTDIR)$(BINDIR)/idle3
(cd $(DESTDIR)$(BINDIR); $(LN) -s idle$(VERSION) idle3)
-rm -f $(DESTDIR)$(BINDIR)/pydoc3
@@ -1334,7 +1334,7 @@ libinstall: build_all $(srcdir)/Modules/xxmodule.c
python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
- sed -e "s,@EXENAME@,$(BINDIR)/python$(LDVERSION)$(EXE)," < $(srcdir)/Misc/python-config.in >python-config.py
+ sed -e "s,@EXENAME@,$(BINDIR)/platform-python$(LDVERSION)$(EXE)," < $(srcdir)/Misc/python-config.in >python-config.py
# Replace makefile compat. variable references with shell script compat. ones; $(VAR) -> ${VAR}
LC_ALL=C sed -e 's,\$$(\([A-Za-z0-9_]*\)),\$$\{\1\},g' < Misc/python-config.sh >python-config
# On Darwin, always use the python version of the script, the shell
@@ -1386,7 +1386,7 @@ libainstall: @DEF_MAKE_RULE@ python-config
$(INSTALL_DATA) Modules/Setup $(DESTDIR)$(LIBPL)/Setup
$(INSTALL_DATA) Modules/Setup.local $(DESTDIR)$(LIBPL)/Setup.local
@ -190,7 +210,7 @@ index c4055be..248d654 100644
if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
Py_FatalError(
diff --git a/configure b/configure
index eea17a4..8dfd827 100755
index eea17a4..7f9777e 100755
--- a/configure
+++ b/configure
@@ -5741,7 +5741,7 @@ esac
@ -198,7 +218,7 @@ index eea17a4..8dfd827 100755
if test -z "$LIBRARY"
then
- LIBRARY='libpython$(VERSION)$(ABIFLAGS).a'
+ LIBRARY='libplatformpython$(VERSION)$(ABIFLAGS).a'
+ LIBRARY='libplatform-python$(VERSION)$(ABIFLAGS).a'
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $LIBRARY" >&5
$as_echo "$LIBRARY" >&6; }
@ -208,28 +228,19 @@ index eea17a4..8dfd827 100755
Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*)
- LDLIBRARY='libpython$(LDVERSION).so'
- BLDLIBRARY='-L. -lpython$(LDVERSION)'
+ LDLIBRARY='libplatformpython$(LDVERSION).so'
+ BLDLIBRARY='-L. -lplatform-python-$(LDVERSION)'
+ LDLIBRARY='libplatform-python$(LDVERSION).so'
+ BLDLIBRARY='-L. -lplatform-python$(LDVERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
INSTSONAME="$LDLIBRARY".$SOVERSION
if test "$with_pydebug" != yes
then
- PY3LIBRARY=libpython3.so
+ PY3LIBRARY=libplatformpython3.so
+ PY3LIBRARY=libplatform-python3.so
fi
;;
hp*|HP*)
@@ -5994,7 +5994,7 @@ $as_echo "#define Py_ENABLE_SHARED 1" >>confdefs.h
;;
Darwin*)
LDLIBRARY='libpython$(LDVERSION).dylib'
- BLDLIBRARY='-L. -lpython$(LDVERSION)'
+ BLDLIBRARY='-L. -lplatform-python-$(LDVERSION)'
RUNSHARED=DYLD_LIBRARY_PATH=`pwd`${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
;;
AIX*)
diff --git a/configure.ac b/configure.ac
index 74b0e57..56d3c33 100644
index 74b0e57..d130b2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -987,7 +987,7 @@ AC_SUBST(LIBRARY)
@ -237,7 +248,7 @@ index 74b0e57..56d3c33 100644
if test -z "$LIBRARY"
then
- LIBRARY='libpython$(VERSION)$(ABIFLAGS).a'
+ LIBRARY='libplatformpython$(VERSION)$(ABIFLAGS).a'
+ LIBRARY='libplatform-python$(VERSION)$(ABIFLAGS).a'
fi
AC_MSG_RESULT($LIBRARY)
@ -246,24 +257,14 @@ index 74b0e57..56d3c33 100644
;;
Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*)
- LDLIBRARY='libpython$(LDVERSION).so'
- BLDLIBRARY='-L. -lpython$(LDVERSION)'
+ LDLIBRARY='libplatformpython$(LDVERSION).so'
+ BLDLIBRARY='-L. -lplatform-python-$(LDVERSION)'
+ LDLIBRARY='libplatform-python$(LDVERSION).so'
BLDLIBRARY='-L. -lpython$(LDVERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
INSTSONAME="$LDLIBRARY".$SOVERSION
if test "$with_pydebug" != yes
then
- PY3LIBRARY=libpython3.so
+ PY3LIBRARY=libplatformpython3.so
+ PY3LIBRARY=libplatform-python3.so
fi
;;
hp*|HP*)
@@ -1171,7 +1171,7 @@ if test $enable_shared = "yes"; then
;;
Darwin*)
LDLIBRARY='libpython$(LDVERSION).dylib'
- BLDLIBRARY='-L. -lpython$(LDVERSION)'
+ BLDLIBRARY='-L. -lplatform-python-$(LDVERSION)'
RUNSHARED=DYLD_LIBRARY_PATH=`pwd`${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
;;
AIX*)

View File

@ -82,7 +82,7 @@
# (if these get out of sync, the payload of the libs subpackage will fail
# and halt the build)
%global py_SOVERSION 1.0
%global py_INSTSONAME_optimized libplatformpython%{LDVERSION_optimized}.so.%{py_SOVERSION}
%global py_INSTSONAME_optimized libplatform-python%{LDVERSION_optimized}.so.%{py_SOVERSION}
%global with_gdb_hooks 1