Rebased to Python 3.8.1rc1

All patches applied cleanly.

Among other things, this contains the necessary fix for gcc 10 support:
 https://bugs.python.org/issue38965
This commit is contained in:
Miro Hrončok 2019-12-10 13:11:56 +01:00
parent 141731d4d0
commit 8d46a842b6
9 changed files with 26 additions and 23 deletions

View File

@ -1,4 +1,4 @@
From 8ecb6d320c03242ca94bf2e99d9d80510d5011e1 Mon Sep 17 00:00:00 2001
From 4158d4a8af6aa11c3391d5357f1d3365821a7ab7 Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Wed, 13 Jan 2010 21:25:18 +0000
Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
@ -29,5 +29,5 @@ index d10a78da31..4df4b67810 100644
include_dirs=None, extra_preargs=None, extra_postargs=None):
fixed_args = self._fix_compile_args(None, macros, include_dirs)
--
2.21.0
2.23.0

View File

@ -1,4 +1,4 @@
From b9f1dd6be195cc3b11a80e6f0dde2096dd8b9855 Mon Sep 17 00:00:00 2001
From 80579acb7e92e5d7e8bbf4d86743e9f01d89671b Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Wed, 13 Jan 2010 21:25:18 +0000
Subject: [PATCH] 00102: Change the various install paths to use /usr/lib64/
@ -198,10 +198,10 @@ index b727f66953..a0c5fb6139 100644
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
}
diff --git a/configure b/configure
index 2a933cdbeb..bec365124e 100755
index 0914e24704..889d6b6a7f 100755
--- a/configure
+++ b/configure
@@ -15182,9 +15182,9 @@ fi
@@ -15170,9 +15170,9 @@ fi
if test x$PLATFORM_TRIPLET = x; then
@ -214,7 +214,7 @@ index 2a933cdbeb..bec365124e 100755
diff --git a/configure.ac b/configure.ac
index a189d42c2c..154a0aa5cc 100644
index 7051dc109a..a13be153fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4668,9 +4668,9 @@ fi
@ -257,5 +257,5 @@ index 20d7f35652..024a1035c0 100644
libraries=readline_libs))
else:
--
2.21.0
2.23.0

View File

@ -1,4 +1,4 @@
From f6df02cde47874f10e183ead483c90941bb8076f Mon Sep 17 00:00:00 2001
From 475090485d5f49770453d17148c64fd04bc2c664 Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Mon, 18 Jan 2010 17:59:07 +0000
Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
@ -74,5 +74,5 @@ index 4ad3df1122..72d202d71b 100644
$(INSTALL_DATA) Programs/python.o $(DESTDIR)$(LIBPL)/python.o
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
--
2.21.0
2.23.0

View File

@ -1,4 +1,4 @@
From e5c11f104e1d2543ac3ba4b3f0a7989821e57947 Mon Sep 17 00:00:00 2001
From ad327eccb60870839c10a83294fad3d3157efd77 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Wed, 15 Aug 2018 15:36:29 +0200
Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
@ -60,5 +60,5 @@ index fc0edec6e3..4d17e413db 100644
additional_paths.append(os.path.join(tmpdir, wheel_name))
--
2.21.0
2.23.0

View File

@ -1,4 +1,4 @@
From 76330e0a8798b3b03160edc7e8d42d3dbee756fd Mon Sep 17 00:00:00 2001
From 1dc87eaf903f7130f5f754e62b93f59758188ede Mon Sep 17 00:00:00 2001
From: Michal Cyprian <m.cyprian@gmail.com>
Date: Mon, 26 Jun 2017 16:32:56 +0200
Subject: [PATCH] 00251: Change user install location
@ -60,5 +60,5 @@ index 22d53fa562..9513526109 100644
if os.path.isdir(sitedir):
addsitedir(sitedir, known_paths)
--
2.21.0
2.23.0

View File

@ -1,4 +1,4 @@
From 64c67dbfa789f242e8ffd1ac88bafb4df2842401 Mon Sep 17 00:00:00 2001
From a826769233384c722d5ddd5baea7a989bd184673 Mon Sep 17 00:00:00 2001
From: Petr Viktorin <pviktori@redhat.com>
Date: Mon, 28 Aug 2017 17:16:46 +0200
Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
@ -29,7 +29,7 @@ index ba37cf99e2..52a9ec6662 100755
ppc64le | powerpc64little)
basic_machine=powerpc64le-unknown
diff --git a/configure.ac b/configure.ac
index 154a0aa5cc..273954f461 100644
index a13be153fa..edf17032b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -741,9 +741,9 @@ cat >> conftest.c <<EOF
@ -82,5 +82,5 @@ index 154a0aa5cc..273954f461 100644
s390x-linux-gnu
# elif defined(__s390__)
--
2.21.0
2.23.0

View File

@ -1,4 +1,4 @@
From c706770ce2d951d9357ffc872b7e3f70ad36c264 Mon Sep 17 00:00:00 2001
From 7b57d383647be4883632b3e13436c458018b17a0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Thu, 11 Jul 2019 13:44:13 +0200
Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default
@ -51,5 +51,5 @@ index d6677ab45f..88059b127e 100644
return wrapper
--
2.21.0
2.23.0

View File

@ -13,11 +13,11 @@ URL: https://www.python.org/
# WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well
%global general_version %{pybasever}.0
#global prerel ...
%global general_version %{pybasever}.1
%global prerel rc1
%global upstream_version %{general_version}%{?prerel}
Version: %{general_version}%{?prerel:~%{prerel}}
Release: 3%{?dist}
Release: 1%{?dist}
License: Python
@ -1569,6 +1569,9 @@ CheckPython optimized
# ======================================================
%changelog
* Tue Dec 10 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.1~rc1-1
- Rebased to Python 3.8.1rc1
* Tue Dec 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0-3
- Build Python with -fno-semantic-interposition for better performance
- https://fedoraproject.org/wiki/Changes/PythonNoSemanticInterpositionSpeedup

View File

@ -1,2 +1,2 @@
SHA512 (Python-3.8.0.tar.xz) = 5f9bfcb3acdf592770a9d5abd2c32c68c55a49b92f958ded069e3ef31cf2d415e67112b4f6738fab237dc29e5c622298719946d2e9471e7e78e3a6bdf2fac1d1
SHA512 (Python-3.8.0.tar.xz.asc) = 4741bcb9b79019f190fded565dd9851158911f1b0ba71f5972906c267ca6576ebfae7c1e649f8bd9fee6ce2cabb325ef1d85a28ab5962fc9275072d35229d06d
SHA512 (Python-3.8.1rc1.tar.xz) = 67c9dd794ed5fabe0c9b7434d9331d694709d7c71bd4a963f285d8d406f1a7c851812e50601415900e1d894c71da140c30aaca947e14ba28b00845c23a550d9b
SHA512 (Python-3.8.1rc1.tar.xz.asc) = 5afe7816510f13bbae3c87bab46751adde25f2f3c029d31becd9bd802f60fd96b43222550fa6eee9c2aa0fd9114fe7385901ae6daea5c6e834b1f5111fd248b7