Disable gdb / gdb_hooks; add riscv64 triplet detection

Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
David Abdurachmanov 2018-05-07 18:41:01 +02:00
parent e324bf2dbb
commit 8bab70c1f7
2 changed files with 30 additions and 1 deletions

View File

@ -0,0 +1,13 @@
diff --git a/configure.ac b/configure.ac
index 4b42393..2394669 100644
--- a/configure.ac
+++ b/configure.ac
@@ -846,6 +846,8 @@ cat >> conftest.c <<EOF
sparc64-linux-gnu
# elif defined(__sparc__)
sparc-linux-gnu
+# elif defined(__riscv) && defined(__riscv_xlen) && __riscv_xlen == 64
+ riscv64-linux-gnu
# else
# error unknown platform triplet
# endif

View File

@ -14,7 +14,7 @@ URL: https://www.python.org/
# WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well
Version: %{pybasever}.5
Release: 4%{?dist}
Release: 4.0.riscv64%{?dist}
License: Python
@ -61,7 +61,11 @@ License: Python
%endif
# Support for the GDB debugger
%ifnarch riscv64
%bcond_without gdb_hooks
%else
%bcond_with gdb_hooks
%endif
# The dbm.gnu module (key-value database)
%bcond_without gdbm
@ -205,7 +209,9 @@ BuildRequires: openssl-devel
BuildRequires: pkgconfig
BuildRequires: readline-devel
BuildRequires: sqlite-devel
%ifnarch riscv64
BuildRequires: gdb
%endif
BuildRequires: tar
BuildRequires: tcl-devel
@ -380,6 +386,10 @@ Patch301: 00301-pathfix-add-n-option-for-no-backup.patch
# and: https://bugs.python.org/issue33329
Patch302: 00302-fix-multiprocessing-regression-on-newer-glibcs.patch
# Add riscv64-linux-gnu to the triplet detection based on
# pre-processor arch defines
Patch400: python-3.6.4-add-riscv64-linux-gnu.patch
# (New patches go here ^^^)
#
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
@ -699,6 +709,8 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
%patch301 -p1
%patch302 -p1
# riscv64
%patch400 -p1
# Remove files that should be generated by the build
# (This is after patching, so that we can use patches directly from upstream)
@ -1586,6 +1598,10 @@ CheckPython optimized
# ======================================================
%changelog
* Mon May 07 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 3.6.5-4.0.riscv64
- Disable gdb / gdb_hooks for riscv64
- Add riscv64 triplet patch
* Mon Apr 23 2018 Miro Hrončok <mhroncok@redhat.com> - 3.6.5-4
- Fix multiprocessing regression on newer glibcs
- Enable test_multiprocessing_fork(server) and _spawn again