- Fix an incompatibility between pyexpat and the system expat-2.0.1 that

led to a segfault running test_pyexpat.py (patch 110; upstream issue
    9054; rhbz#610312)

Conflicts:

	python3.spec
This commit is contained in:
Toshio Kuratomi 2010-08-22 23:19:21 -04:00
parent 211f42f6b6
commit 05a8f80b75
1 changed files with 14 additions and 0 deletions

View File

@ -0,0 +1,14 @@
Index: Modules/pyexpat.c
===================================================================
--- Modules/pyexpat.c (revision 81539)
+++ Modules/pyexpat.c (working copy)
@@ -415,6 +415,9 @@
PyObject *args;
PyObject *temp;
+ if (!have_handler(self, CharacterData))
+ return -1;
+
args = PyTuple_New(1);
if (args == NULL)
return -1;