Add riscv triplet detection

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2020-06-02 06:41:13 +03:00
parent 754b5f85f4
commit 5c9e6f94cb
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
2 changed files with 23 additions and 0 deletions

View File

@ -0,0 +1,19 @@
diff --git a/configure.ac b/configure.ac
index c071ec3..53ed6cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -846,6 +846,14 @@ cat >> conftest.c <<EOF
sparc64-linux-gnu
# elif defined(__sparc__)
sparc-linux-gnu
+# elif defined(__riscv)
+# if __riscv_xlen == 32
+ riscv32-linux-gnu
+# elif __riscv_xlen == 64
+ riscv64-linux-gnu
+# else
+# error unknown platform triplet
+# endif
# else
# error unknown platform triplet
# endif

View File

@ -365,6 +365,9 @@ Patch294: 00294-define-TLS-cipher-suite-on-build-time.patch
# https://github.com/python/cpython/commit/ac827edc493d3ac3f5b9b0cc353df1d4b418a9aa
Patch343: 00343-faulthandler-gcc10.patch
# Add riscv64-linux-gnu to the triplet detection
Patch500: Python-3.6.10-riscv-triplets.patch
# (New patches go here ^^^)
#
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
@ -653,6 +656,7 @@ rm Lib/ensurepip/_bundled/*.whl
%patch294 -p1
%patch343 -p1
%patch500 -p1
# Remove files that should be generated by the build
# (This is after patching, so that we can use patches directly from upstream)