55 lines
1.5 KiB
Diff
55 lines
1.5 KiB
Diff
diff --git a/Include/Python.h b/Include/Python.h
|
|
index 858dbd1..2845742 100644
|
|
--- a/Include/Python.h
|
|
+++ b/Include/Python.h
|
|
@@ -35,6 +35,9 @@
|
|
#ifdef HAVE_UNISTD_H
|
|
#include <unistd.h>
|
|
#endif
|
|
+#ifdef HAVE_CRYPT_H
|
|
+#include <crypt.h>
|
|
+#endif
|
|
|
|
/* For size_t? */
|
|
#ifdef HAVE_STDDEF_H
|
|
diff --git a/configure b/configure
|
|
index 93f332f..ed37d5d 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -7709,7 +7709,7 @@ $as_echo "#define STDC_HEADERS 1" >>confdefs.h
|
|
|
|
fi
|
|
|
|
-for ac_header in asm/types.h conio.h direct.h dlfcn.h errno.h \
|
|
+for ac_header in asm/types.h crypt.h conio.h direct.h dlfcn.h errno.h \
|
|
fcntl.h grp.h \
|
|
ieeefp.h io.h langinfo.h libintl.h process.h pthread.h \
|
|
sched.h shadow.h signal.h stdint.h stropts.h termios.h \
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d071dde..937bb65 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1949,7 +1949,7 @@ dnl AC_MSG_RESULT($cpp_type)
|
|
|
|
# checks for header files
|
|
AC_HEADER_STDC
|
|
-AC_CHECK_HEADERS(asm/types.h conio.h direct.h dlfcn.h errno.h \
|
|
+AC_CHECK_HEADERS(asm/types.h crypt.h conio.h direct.h dlfcn.h errno.h \
|
|
fcntl.h grp.h \
|
|
ieeefp.h io.h langinfo.h libintl.h process.h pthread.h \
|
|
sched.h shadow.h signal.h stdint.h stropts.h termios.h \
|
|
diff --git a/pyconfig.h.in b/pyconfig.h.in
|
|
index 9052dbc..7d1f125 100644
|
|
--- a/pyconfig.h.in
|
|
+++ b/pyconfig.h.in
|
|
@@ -137,6 +137,9 @@
|
|
/* Define to 1 if you have the `copysign' function. */
|
|
#undef HAVE_COPYSIGN
|
|
|
|
+/* Define to 1 if you have the <crypt.h> header file. */
|
|
+#undef HAVE_CRYPT_H
|
|
+
|
|
/* Define to 1 if you have the `ctermid' function. */
|
|
#undef HAVE_CTERMID
|
|
|