Rebased to version 3.5.5

This commit is contained in:
Miro Hrončok 2018-03-27 13:59:13 +02:00 committed by Charalampos Stratakis
parent 2a2170c98d
commit 97e3884814
5 changed files with 32 additions and 43 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@ Python-3.5.1.tar.xz
/Python-3.5.2.tar.xz
/Python-3.5.3.tar.xz
/Python-3.5.4.tar.xz
/Python-3.5.5.tar.xz

View File

@ -1,7 +1,24 @@
diff -up Python-3.5.0/configure.ac.eabi Python-3.5.0/configure.ac
--- Python-3.5.0/configure.eabi 2015-09-23 13:52:20.756909744 +0200
+++ Python-3.5.0/configure 2015-09-23 13:52:46.859163629 +0200
@@ -762,9 +762,9 @@ cat >> conftest.c <<EOF
diff --git a/configure b/configure
index 708cc78..93f332f 100755
--- a/configure
+++ b/configure
@@ -5295,9 +5295,9 @@ cat >> conftest.c <<EOF
alpha-linux-gnu
# elif defined(__ARM_EABI__) && defined(__ARM_PCS_VFP)
# if defined(__ARMEL__)
- arm-linux-gnueabihf
+ arm-linux-gnueabi
# else
- armeb-linux-gnueabihf
+ armeb-linux-gnueabi
# endif
# elif defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)
# if defined(__ARMEL__)
diff --git a/configure.ac b/configure.ac
index 82eb1e3..d071dde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -782,9 +782,9 @@ cat >> conftest.c <<EOF
alpha-linux-gnu
# elif defined(__ARM_EABI__) && defined(__ARM_PCS_VFP)
# if defined(__ARMEL__)

View File

@ -1,25 +0,0 @@
From c3c9db89273fabc62ea1b48389d9a3000c1c03ae Mon Sep 17 00:00:00 2001
From: Jay Bosamiya <jaybosamiya@gmail.com>
Date: Sun, 18 Jun 2017 22:11:03 +0530
Subject: [PATCH] [2.7] bpo-30657: Check & prevent integer overflow in
PyString_DecodeEscape (#2174)
diff --git a/Objects/bytesobject.c b/Objects/bytesobject.c
index 77dd45e..9b29dc3 100644
--- a/Objects/bytesobject.c
+++ b/Objects/bytesobject.c
@@ -970,7 +970,13 @@ PyObject *PyBytes_DecodeEscape(const char *s,
char *p, *buf;
const char *end;
PyObject *v;
- Py_ssize_t newlen = recode_encoding ? 4*len:len;
+ Py_ssize_t newlen;
+ /* Check for integer overflow */
+ if (recode_encoding && (len > PY_SSIZE_T_MAX / 4)) {
+ PyErr_SetString(PyExc_OverflowError, "string is too large");
+ return NULL;
+ }
+ newlen = recode_encoding ? 4*len:len;
v = PyBytes_FromStringAndSize((char *)NULL, newlen);
if (v == NULL)
return NULL;

View File

@ -97,8 +97,8 @@
# ==================
Summary: Version 3.5 of the Python programming language
Name: python%{pyshortver}
Version: %{pybasever}.4
Release: 4%{?dist}
Version: %{pybasever}.5
Release: 1%{?dist}
License: Python
Group: Development/Languages
@ -205,7 +205,7 @@ Patch55: 00055-systemtap.patch
Patch102: 00102-lib64.patch
# 00104 #
# Only used when "%{_lib}" == "lib64"
# Only used when "%%{_lib}" == "lib64"
# Another lib64 fix, for distutils/tests/test_install.py; not upstream:
Patch104: 00104-lib64-fix-for-test_install.patch
@ -386,12 +386,6 @@ Patch270: 00270-fix-ssl-alpn-hook-test.patch
# Reported upstream: https://bugs.python.org/issue31900
Patch273: 00273-skip-float-test.patch
# 00286 #
# CVE-2017-1000158
# Check & prevent integer overflow in PyString_DecodeEscape
# Fixed upstream: https://bugs.python.org/issue30657
Patch286: 00286-pystring-decodeescape-integer-overflow.patch
# (New patches go here ^^^)
#
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
@ -415,13 +409,13 @@ URL: http://www.python.org/
# We'll not provide this, on purpose
# No package in Fedora shall ever depend on this
# Provides: python(abi) = %{pybasever}
# Provides: python(abi) = %%{pybasever}
%global __requires_exclude ^python\\(abi\\) = 3\\..$
%global __provides_exclude ^python\\(abi\\) = 3\\..$
# We keep those inside on purpose
Provides: bundled(python3-pip) = 8.1.1
Provides: bundled(python3-setuptools) = 20.10.1
Provides: bundled(python3-pip) = 9.0.1
Provides: bundled(python3-setuptools) = 28.8.0
%description
Python %{pybasever} package for developers.
@ -505,7 +499,6 @@ rm -r Modules/zlib || exit 1
%patch264 -p1
%patch270 -p1
%patch273 -p1
%patch286 -p1
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
# are many differences between 2.6 and the Python 3 library.
@ -1040,6 +1033,9 @@ CheckPython optimized
# ======================================================
%changelog
* Tue Mar 27 2018 Miro Hrončok <mhroncok@redhat.com> - 3.5.5-1
- Rebased to version 3.5.5
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.4-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (Python-3.5.4.tar.xz) = dbbe2740ee1cce5404b7b6436a9b3887e15f415a1006efa22014ec7e5b1e48c43eed0ff98f6f5b365c527b8d2525be4ce72bbe404ce71c0835529fcd6f0267ff
SHA512 (Python-3.5.5.tar.xz) = c9056baee6a2d1fe7f14b1f310db95b78e8972766d086f8ae10954f38f8182956171580bde01ddadebe897f2545a6fbe47669ca3e4887026ac1fae5ee9197f22