b180b3028c
Actually rebased patches: 102, 189 New patches at https://github.com/fedora-python/cpython/tree/fedora-3.9
262 lines
11 KiB
Diff
262 lines
11 KiB
Diff
From 25fcefdafb47ee30f4dc802742f49e501d7b2f37 Mon Sep 17 00:00:00 2001
|
|
From: David Malcolm <dmalcolm@redhat.com>
|
|
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
|
Subject: [PATCH] 00102: Change the various install paths to use /usr/lib64/
|
|
instead or /usr/lib/
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Only used when "%{_lib}" == "lib64".
|
|
|
|
Co-authored-by: David Malcolm <dmalcolm@redhat.com>
|
|
Co-authored-by: Thomas Spura <tomspur@fedoraproject.org>
|
|
Co-authored-by: Slavek Kabrda <bkabrda@redhat.com>
|
|
Co-authored-by: Matej Stuchlik <mstuchli@redhat.com>
|
|
Co-authored-by: Tomas Orsava <torsava@redhat.com>
|
|
Co-authored-by: Charalampos Stratakis <cstratak@redhat.com>
|
|
Co-authored-by: Petr Viktorin <pviktori@redhat.com>
|
|
Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
|
Co-authored-by: Iryna Shcherbina <shcherbina.iryna@gmail.com>
|
|
---
|
|
Lib/distutils/command/install.py | 4 ++--
|
|
Lib/distutils/sysconfig.py | 6 +++++-
|
|
Lib/distutils/tests/test_install.py | 3 ++-
|
|
Lib/site.py | 4 ++++
|
|
Lib/sysconfig.py | 12 ++++++------
|
|
Lib/test/test_site.py | 4 ++--
|
|
Makefile.pre.in | 2 +-
|
|
Modules/getpath.c | 6 +++---
|
|
configure | 4 ++--
|
|
configure.ac | 4 ++--
|
|
setup.py | 6 +++---
|
|
11 files changed, 32 insertions(+), 23 deletions(-)
|
|
|
|
diff --git a/Lib/distutils/command/install.py b/Lib/distutils/command/install.py
|
|
index c625c95bf7..ae4f915669 100644
|
|
--- a/Lib/distutils/command/install.py
|
|
+++ b/Lib/distutils/command/install.py
|
|
@@ -30,14 +30,14 @@ WINDOWS_SCHEME = {
|
|
INSTALL_SCHEMES = {
|
|
'unix_prefix': {
|
|
'purelib': '$base/lib/python$py_version_short/site-packages',
|
|
- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
|
|
+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
|
|
'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
},
|
|
'unix_home': {
|
|
'purelib': '$base/lib/python',
|
|
- 'platlib': '$base/lib/python',
|
|
+ 'platlib': '$base/lib64/python',
|
|
'headers': '$base/include/python/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
diff --git a/Lib/distutils/sysconfig.py b/Lib/distutils/sysconfig.py
|
|
index b51629eb94..9a4892a737 100644
|
|
--- a/Lib/distutils/sysconfig.py
|
|
+++ b/Lib/distutils/sysconfig.py
|
|
@@ -146,8 +146,12 @@ def get_python_lib(plat_specific=0, standard_lib=0, prefix=None):
|
|
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
|
|
|
if os.name == "posix":
|
|
+ if plat_specific or standard_lib:
|
|
+ lib = "lib64"
|
|
+ else:
|
|
+ lib = "lib"
|
|
libpython = os.path.join(prefix,
|
|
- "lib", "python" + get_python_version())
|
|
+ lib, "python" + get_python_version())
|
|
if standard_lib:
|
|
return libpython
|
|
else:
|
|
diff --git a/Lib/distutils/tests/test_install.py b/Lib/distutils/tests/test_install.py
|
|
index 287ab1989e..d4c05e0ab1 100644
|
|
--- a/Lib/distutils/tests/test_install.py
|
|
+++ b/Lib/distutils/tests/test_install.py
|
|
@@ -57,8 +57,9 @@ class InstallTestCase(support.TempdirManager,
|
|
self.assertEqual(got, expected)
|
|
|
|
libdir = os.path.join(destination, "lib", "python")
|
|
+ platlibdir = os.path.join(destination, "lib64", "python")
|
|
check_path(cmd.install_lib, libdir)
|
|
- check_path(cmd.install_platlib, libdir)
|
|
+ check_path(cmd.install_platlib, platlibdir)
|
|
check_path(cmd.install_purelib, libdir)
|
|
check_path(cmd.install_headers,
|
|
os.path.join(destination, "include", "python", "foopkg"))
|
|
diff --git a/Lib/site.py b/Lib/site.py
|
|
index a065ab0b5d..22d53fa562 100644
|
|
--- a/Lib/site.py
|
|
+++ b/Lib/site.py
|
|
@@ -335,11 +335,15 @@ def getsitepackages(prefixes=None):
|
|
seen.add(prefix)
|
|
|
|
if os.sep == '/':
|
|
+ sitepackages.append(os.path.join(prefix, "lib64",
|
|
+ "python" + sys.version[:3],
|
|
+ "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib",
|
|
"python%d.%d" % sys.version_info[:2],
|
|
"site-packages"))
|
|
else:
|
|
sitepackages.append(prefix)
|
|
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
|
return sitepackages
|
|
|
|
diff --git a/Lib/sysconfig.py b/Lib/sysconfig.py
|
|
index b9e2fafbc0..0ae6d35b69 100644
|
|
--- a/Lib/sysconfig.py
|
|
+++ b/Lib/sysconfig.py
|
|
@@ -20,10 +20,10 @@ __all__ = [
|
|
|
|
_INSTALL_SCHEMES = {
|
|
'posix_prefix': {
|
|
- 'stdlib': '{installed_base}/lib/python{py_version_short}',
|
|
- 'platstdlib': '{platbase}/lib/python{py_version_short}',
|
|
+ 'stdlib': '{installed_base}/lib64/python{py_version_short}',
|
|
+ 'platstdlib': '{platbase}/lib64/python{py_version_short}',
|
|
'purelib': '{base}/lib/python{py_version_short}/site-packages',
|
|
- 'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
|
|
+ 'platlib': '{platbase}/lib64/python{py_version_short}/site-packages',
|
|
'include':
|
|
'{installed_base}/include/python{py_version_short}{abiflags}',
|
|
'platinclude':
|
|
@@ -62,10 +62,10 @@ _INSTALL_SCHEMES = {
|
|
'data': '{userbase}',
|
|
},
|
|
'posix_user': {
|
|
- 'stdlib': '{userbase}/lib/python{py_version_short}',
|
|
- 'platstdlib': '{userbase}/lib/python{py_version_short}',
|
|
+ 'stdlib': '{userbase}/lib64/python{py_version_short}',
|
|
+ 'platstdlib': '{userbase}/lib64/python{py_version_short}',
|
|
'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
|
|
- 'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
|
|
+ 'platlib': '{userbase}/lib64/python{py_version_short}/site-packages',
|
|
'include': '{userbase}/include/python{py_version_short}',
|
|
'scripts': '{userbase}/bin',
|
|
'data': '{userbase}',
|
|
diff --git a/Lib/test/test_site.py b/Lib/test/test_site.py
|
|
index 41c4229919..543c88432a 100644
|
|
--- a/Lib/test/test_site.py
|
|
+++ b/Lib/test/test_site.py
|
|
@@ -266,8 +266,8 @@ class HelperFunctionsTests(unittest.TestCase):
|
|
dirs = site.getsitepackages()
|
|
if os.sep == '/':
|
|
# OS X, Linux, FreeBSD, etc
|
|
- self.assertEqual(len(dirs), 1)
|
|
- wanted = os.path.join('xoxo', 'lib',
|
|
+ self.assertEqual(len(dirs), 2)
|
|
+ wanted = os.path.join('xoxo', 'lib64',
|
|
'python%d.%d' % sys.version_info[:2],
|
|
'site-packages')
|
|
self.assertEqual(dirs[0], wanted)
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index d08c78df39..4d2f68447d 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -143,7 +143,7 @@ LIBDIR= @libdir@
|
|
MANDIR= @mandir@
|
|
INCLUDEDIR= @includedir@
|
|
CONFINCLUDEDIR= $(exec_prefix)/include
|
|
-SCRIPTDIR= $(prefix)/lib
|
|
+SCRIPTDIR= $(prefix)/lib64
|
|
ABIFLAGS= @ABIFLAGS@
|
|
|
|
# Detailed destination directories
|
|
diff --git a/Modules/getpath.c b/Modules/getpath.c
|
|
index 8632d1fe6d..09a818609e 100644
|
|
--- a/Modules/getpath.c
|
|
+++ b/Modules/getpath.c
|
|
@@ -810,7 +810,7 @@ calculate_exec_prefix(PyCalculatePath *calculate, _PyPathConfig *pathconfig)
|
|
}
|
|
|
|
calculate->exec_prefix = joinpath2(calculate->exec_prefix_macro,
|
|
- L"lib/lib-dynload");
|
|
+ L"lib64/lib-dynload");
|
|
if (calculate->exec_prefix == NULL) {
|
|
return _PyStatus_NO_MEMORY();
|
|
}
|
|
@@ -1284,7 +1284,7 @@ calculate_read_pyenv(PyCalculatePath *calculate)
|
|
static PyStatus
|
|
calculate_zip_path(PyCalculatePath *calculate)
|
|
{
|
|
- const wchar_t *lib_python = L"lib/python00.zip";
|
|
+ const wchar_t *lib_python = L"lib64/python00.zip";
|
|
|
|
if (calculate->prefix_found > 0) {
|
|
/* Use the reduced prefix returned by Py_GetPrefix()
|
|
@@ -1435,7 +1435,7 @@ calculate_init(PyCalculatePath *calculate, const PyConfig *config)
|
|
return DECODE_LOCALE_ERR("VPATH macro", len);
|
|
}
|
|
|
|
- calculate->lib_python = Py_DecodeLocale("lib/python" VERSION, &len);
|
|
+ calculate->lib_python = Py_DecodeLocale("lib64/python" VERSION, &len);
|
|
if (!calculate->lib_python) {
|
|
return DECODE_LOCALE_ERR("EXEC_PREFIX macro", len);
|
|
}
|
|
diff --git a/configure b/configure
|
|
index 44f14c3c2c..020531594c 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -15192,9 +15192,9 @@ fi
|
|
|
|
|
|
if test x$PLATFORM_TRIPLET = x; then
|
|
- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|
|
+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|
|
fi
|
|
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 0b28dda44c..4fca719c71 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4679,9 +4679,9 @@ fi
|
|
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
|
AC_SUBST(PY_ENABLE_SHARED)
|
|
if test x$PLATFORM_TRIPLET = x; then
|
|
- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|
|
+ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|
|
fi
|
|
AC_SUBST(LIBPL)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 02f523c42d..559498d14b 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -649,7 +649,7 @@ class PyBuildExt(build_ext):
|
|
# directories (i.e. '.' and 'Include') must be first. See issue
|
|
# 10520.
|
|
if not CROSS_COMPILING:
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if CROSS_COMPILING:
|
|
@@ -953,11 +953,11 @@ class PyBuildExt(build_ext):
|
|
elif curses_library:
|
|
readline_libs.append(curses_library)
|
|
elif self.compiler.find_library_file(self.lib_dirs +
|
|
- ['/usr/lib/termcap'],
|
|
+ ['/usr/lib64/termcap'],
|
|
'termcap'):
|
|
readline_libs.append('termcap')
|
|
self.add(Extension('readline', ['readline.c'],
|
|
- library_dirs=['/usr/lib/termcap'],
|
|
+ library_dirs=['/usr/lib64/termcap'],
|
|
extra_link_args=readline_extra_link_args,
|
|
libraries=readline_libs))
|
|
else:
|
|
--
|
|
2.23.0
|
|
|