Consolidate architecture-naming patches in one
Patches 180, 206, 243 and 5001 all changed architecture names from Debian style (which upstream uses) to what Fedora uses. Consolidate them into a single patch, 274. Delete changes to `configure` from patch 243 without replacement; that file is generated from `configure.ac`.
This commit is contained in:
parent
ac06deac65
commit
9423d36fb4
@ -1,13 +0,0 @@
|
||||
diff --git a/config.sub b/config.sub
|
||||
index 40ea5df..932128b 100755
|
||||
--- a/config.sub
|
||||
+++ b/config.sub
|
||||
@@ -1045,7 +1045,7 @@ case $basic_machine in
|
||||
;;
|
||||
ppc64) basic_machine=powerpc64-unknown
|
||||
;;
|
||||
- ppc64-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
||||
+ ppc64-* | ppc64p7-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
||||
;;
|
||||
ppc64le | powerpc64little)
|
||||
basic_machine=powerpc64le-unknown
|
@ -1,15 +0,0 @@
|
||||
diff -up Python-3.5.0/configure.ac.eabi Python-3.5.0/configure.ac
|
||||
--- Python-3.5.0/configure.eabi 2015-09-23 13:52:20.756909744 +0200
|
||||
+++ Python-3.5.0/configure 2015-09-23 13:52:46.859163629 +0200
|
||||
@@ -762,9 +762,9 @@ cat >> conftest.c <<EOF
|
||||
alpha-linux-gnu
|
||||
# elif defined(__ARM_EABI__) && defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
||||
- arm-linux-gnueabihf
|
||||
+ arm-linux-gnueabi
|
||||
# else
|
||||
- armeb-linux-gnueabihf
|
||||
+ armeb-linux-gnueabi
|
||||
# endif
|
||||
# elif defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
@ -1,42 +0,0 @@
|
||||
diff -urp Python-3.5.0/configure p/configure
|
||||
--- Python-3.5.0/configure 2016-02-25 16:12:12.615184011 +0000
|
||||
+++ p/configure 2016-02-25 16:13:01.293412517 +0000
|
||||
@@ -5133,7 +5133,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64el-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
- mips64el-linux-gnuabi64
|
||||
+ mips64el-linux-gnu
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
||||
@@ -5143,7 +5143,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
- mips64-linux-gnuabi64
|
||||
+ mips64-linux-gnu
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
||||
diff -urp Python-3.5.0/configure.ac p/configure.ac
|
||||
--- Python-3.5.0/configure.ac 2016-02-25 16:12:11.663159985 +0000
|
||||
+++ p/configure.ac 2016-02-25 16:13:18.814854710 +0000
|
||||
@@ -784,7 +784,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64el-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
- mips64el-linux-gnuabi64
|
||||
+ mips64el-linux-gnu
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
||||
@@ -794,7 +794,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
- mips64-linux-gnuabi64
|
||||
+ mips64-linux-gnu
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
58
00274-fix-arch-names.patch
Normal file
58
00274-fix-arch-names.patch
Normal file
@ -0,0 +1,58 @@
|
||||
diff -up Python-3.5.0/configure.ac.than Python-3.5.0/configure.ac
|
||||
--- Python-3.5.0/configure.ac.than 2015-11-13 11:51:32.039560172 -0500
|
||||
+++ Python-3.5.0/configure.ac 2015-11-13 11:52:11.670168157 -0500
|
||||
@@ -788,9 +788,9 @@ cat >> conftest.c <<EOF
|
||||
alpha-linux-gnu
|
||||
# elif defined(__ARM_EABI__) && defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
||||
- arm-linux-gnueabihf
|
||||
+ arm-linux-gnueabi
|
||||
# else
|
||||
- armeb-linux-gnueabihf
|
||||
+ armeb-linux-gnueabi
|
||||
# endif
|
||||
# elif defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
||||
@@ -810,7 +810,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64el-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
- mips64el-linux-gnuabi64
|
||||
+ mips64el-linux-gnu
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
||||
@@ -820,7 +820,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
- mips64-linux-gnuabi64
|
||||
+ mips64-linux-gnu
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
||||
@@ -830,9 +830,9 @@ cat >> conftest.c <<EOF
|
||||
powerpc-linux-gnuspe
|
||||
# elif defined(__powerpc64__)
|
||||
# if defined(__LITTLE_ENDIAN__)
|
||||
- powerpc64le-linux-gnu
|
||||
+ ppc64le-linux-gnu
|
||||
# else
|
||||
- powerpc64-linux-gnu
|
||||
+ ppc64-linux-gnu
|
||||
# endif
|
||||
# elif defined(__powerpc__)
|
||||
powerpc-linux-gnu
|
||||
diff --git a/config.sub b/config.sub
|
||||
index 40ea5df..932128b 100755
|
||||
--- a/config.sub
|
||||
+++ b/config.sub
|
||||
@@ -1045,7 +1045,7 @@ case $basic_machine in
|
||||
;;
|
||||
ppc64) basic_machine=powerpc64-unknown
|
||||
;;
|
||||
- ppc64-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
||||
+ ppc64-* | ppc64p7-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
||||
;;
|
||||
ppc64le | powerpc64little)
|
||||
basic_machine=powerpc64le-unknown
|
@ -1,30 +0,0 @@
|
||||
diff -up Python-3.5.0/configure.ac.than Python-3.5.0/configure.ac
|
||||
--- Python-3.5.0/configure.ac.than 2015-11-13 11:51:32.039560172 -0500
|
||||
+++ Python-3.5.0/configure.ac 2015-11-13 11:52:11.670168157 -0500
|
||||
@@ -804,9 +804,9 @@ cat >> conftest.c <<EOF
|
||||
powerpc-linux-gnuspe
|
||||
# elif defined(__powerpc64__)
|
||||
# if defined(__LITTLE_ENDIAN__)
|
||||
- powerpc64le-linux-gnu
|
||||
+ ppc64le-linux-gnu
|
||||
# else
|
||||
- powerpc64-linux-gnu
|
||||
+ ppc64-linux-gnu
|
||||
# endif
|
||||
# elif defined(__powerpc__)
|
||||
powerpc-linux-gnu
|
||||
diff -up Python-3.5.0/configure.than Python-3.5.0/configure
|
||||
--- Python-3.5.0/configure.than 2015-11-13 12:13:19.039658399 -0500
|
||||
+++ Python-3.5.0/configure 2015-11-13 12:13:35.199906857 -0500
|
||||
@@ -5153,9 +5153,9 @@ cat >> conftest.c <<EOF
|
||||
powerpc-linux-gnuspe
|
||||
# elif defined(__powerpc64__)
|
||||
# if defined(__LITTLE_ENDIAN__)
|
||||
- powerpc64le-linux-gnu
|
||||
+ ppc64le-linux-gnu
|
||||
# else
|
||||
- powerpc64-linux-gnu
|
||||
+ ppc64-linux-gnu
|
||||
# endif
|
||||
# elif defined(__powerpc__)
|
||||
powerpc-linux-gnu
|
32
python3.spec
32
python3.spec
@ -323,11 +323,6 @@ Patch170: 00170-gc-assertions.patch
|
||||
# Does not affect python2 AFAICS (different sysconfig values initialization)
|
||||
Patch178: 00178-dont-duplicate-flags-in-sysconfig.patch
|
||||
|
||||
# 00180 #
|
||||
# Enable building on ppc64p7
|
||||
# Not appropriate for upstream, Fedora-specific naming
|
||||
Patch180: 00180-python-add-support-for-ppc64p7.patch
|
||||
|
||||
# 00189 #
|
||||
# Add the rewheel module, allowing to recreate wheels from already installed
|
||||
# ones
|
||||
@ -339,18 +334,6 @@ Patch189: 00189-add-rewheel-module.patch
|
||||
# but the LIBPL variable defined there doesn't respect libdir macro
|
||||
Patch205: 00205-make-libpl-respect-lib64.patch
|
||||
|
||||
# 00206 #
|
||||
# Remove hf flag from arm triplet which is used
|
||||
# by debian but fedora infra uses only eabi without hf
|
||||
Patch206: 00206-remove-hf-from-arm-triplet.patch
|
||||
|
||||
# 00243 #
|
||||
# Fix the triplet used on 64-bit MIPS
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=1322526
|
||||
# Upstream uses Debian-like style mips64-linux-gnuabi64
|
||||
# Fedora needs the default mips64-linux-gnu
|
||||
Patch243: 00243-fix-mips64-triplet.patch
|
||||
|
||||
# 00251
|
||||
# Set values of prefix and exec_prefix in distutils install command
|
||||
# to /usr/local if executable is /usr/bin/python* and RPM build
|
||||
@ -396,6 +379,10 @@ Patch272: 00272-fix-ftplib-to-reject-newlines.patch
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=1484497
|
||||
Patch273: 00273-skip-float-test.patch
|
||||
|
||||
# 00274 #
|
||||
# Upstream uses Debian-style architecture naming. Change to match Fedora.
|
||||
Patch274: 00274-fix-arch-names.patch
|
||||
|
||||
# (New patches go here ^^^)
|
||||
#
|
||||
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
|
||||
@ -405,11 +392,6 @@ Patch273: 00273-skip-float-test.patch
|
||||
#
|
||||
# https://fedoraproject.org/wiki/SIGs/Python/PythonPatches
|
||||
|
||||
# 05001 #
|
||||
# add correct arch for ppc64/ppc64le
|
||||
# it should be ppc64le-linux-gnu/ppc64-linux-gnu instead powerpc64le-linux-gnu/powerpc64-linux-gnu
|
||||
Patch5001: 05001-powerppc-arch.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
|
||||
@ -651,15 +633,12 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
%patch163 -p1
|
||||
%patch170 -p1
|
||||
%patch178 -p1
|
||||
%patch180 -p1
|
||||
|
||||
%if %{with rewheel}
|
||||
%patch189 -p1
|
||||
%endif
|
||||
|
||||
%patch205 -p1
|
||||
%patch206 -p1
|
||||
%patch243 -p1
|
||||
%patch251 -p1
|
||||
%patch262 -p1
|
||||
|
||||
@ -671,6 +650,7 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
%patch271 -p1
|
||||
%patch272 -p1
|
||||
%patch273 -p1
|
||||
%patch274 -p1
|
||||
|
||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||
# are many differences between 2.6 and the Python 3 library.
|
||||
@ -682,7 +662,6 @@ sed --in-place \
|
||||
--expression="s|http://docs.python.org/library|http://docs.python.org/%{pybasever}/library|g" \
|
||||
Lib/pydoc.py || exit 1
|
||||
|
||||
%patch5001 -p1
|
||||
|
||||
# Remove files that should be generated by the build
|
||||
# (This is after patching, so that we can use patches directly from upstream)
|
||||
@ -1638,6 +1617,7 @@ fi
|
||||
- Skip test_bdist_rpm using test config rather than a patch (removes patch 137)
|
||||
- Remove patches 157 and 186, which had test changes left over after upstreaming
|
||||
- Remove patch 188, a temporary workaround for hashlib tests
|
||||
- Merge patches 180, 206, 243, 5001 (architecture naming) into new patch 274.
|
||||
|
||||
* Mon Aug 28 2017 Michal Cyprian <mcyprian@redhat.com> - 3.6.2-12
|
||||
- Use python3 style of calling super() without arguments in rpath
|
||||
|
Loading…
Reference in New Issue
Block a user