Update to 3.8.0b2
This commit is contained in:
parent
b6a6e97b8f
commit
13257b57b3
@ -1,4 +1,4 @@
|
||||
From 068ae6b9d422e5deeb950d1354a003025642413a Mon Sep 17 00:00:00 2001
|
||||
From 8738c39204297788bcb07940a99608f80592829f Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||
Subject: [PATCH 1/7] 00001: Fixup distutils/unixccompiler.py to remove
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 1b28c83def441be0e9377058b9a29a1ea3558ae0 Mon Sep 17 00:00:00 2001
|
||||
From 6a503d0ad4512af57ef8a784f12bc439701d8cc7 Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||
Subject: [PATCH 2/7] 00102: Change the various install paths to use
|
||||
@ -87,10 +87,10 @@ index 287ab1989e..d4c05e0ab1 100644
|
||||
check_path(cmd.install_headers,
|
||||
os.path.join(destination, "include", "python", "foopkg"))
|
||||
diff --git a/Lib/site.py b/Lib/site.py
|
||||
index ad1146332b..99149a564f 100644
|
||||
index a065ab0b5d..22d53fa562 100644
|
||||
--- a/Lib/site.py
|
||||
+++ b/Lib/site.py
|
||||
@@ -334,11 +334,15 @@ def getsitepackages(prefixes=None):
|
||||
@@ -335,11 +335,15 @@ def getsitepackages(prefixes=None):
|
||||
seen.add(prefix)
|
||||
|
||||
if os.sep == '/':
|
||||
@ -107,7 +107,7 @@ index ad1146332b..99149a564f 100644
|
||||
return sitepackages
|
||||
|
||||
diff --git a/Lib/sysconfig.py b/Lib/sysconfig.py
|
||||
index 8446c8deb2..cf64d79c4d 100644
|
||||
index e76e6927cb..0cfbea54b9 100644
|
||||
--- a/Lib/sysconfig.py
|
||||
+++ b/Lib/sysconfig.py
|
||||
@@ -20,10 +20,10 @@ __all__ = [
|
||||
@ -154,7 +154,7 @@ index 41c4229919..543c88432a 100644
|
||||
'site-packages')
|
||||
self.assertEqual(dirs[0], wanted)
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index a0bc9c1f1c..780118c410 100644
|
||||
index 88abb56360..6c2edf32f7 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -143,7 +143,7 @@ LIBDIR= @libdir@
|
||||
@ -198,10 +198,10 @@ index 5f80738188..73d7913441 100644
|
||||
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
|
||||
}
|
||||
diff --git a/configure b/configure
|
||||
index b606fc808c..50b578a551 100755
|
||||
index 6e7f277bac..6cd8344c21 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15175,9 +15175,9 @@ fi
|
||||
@@ -15181,9 +15181,9 @@ fi
|
||||
|
||||
|
||||
if test x$PLATFORM_TRIPLET = x; then
|
||||
@ -214,10 +214,10 @@ index b606fc808c..50b578a551 100755
|
||||
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3d589ac258..3bb44e6993 100644
|
||||
index 324ce0bd99..9a587f3c3f 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4649,9 +4649,9 @@ fi
|
||||
@@ -4655,9 +4655,9 @@ fi
|
||||
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
||||
AC_SUBST(PY_ENABLE_SHARED)
|
||||
if test x$PLATFORM_TRIPLET = x; then
|
||||
@ -230,7 +230,7 @@ index 3d589ac258..3bb44e6993 100644
|
||||
AC_SUBST(LIBPL)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 598f5819f8..0685620484 100644
|
||||
index edc3434242..59cfc01a2a 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -648,7 +648,7 @@ class PyBuildExt(build_ext):
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 79544450450248e4967a8b41aa6d08d32d5cd41a Mon Sep 17 00:00:00 2001
|
||||
From efbafc6328f45da6d38a1848933a37497206fb3f Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Mon, 18 Jan 2010 17:59:07 +0000
|
||||
Subject: [PATCH 3/7] 00111: Don't try to build a libpythonMAJOR.MINOR.a
|
||||
@ -21,7 +21,7 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index 780118c410..3431ca815e 100644
|
||||
index 6c2edf32f7..28c0cead24 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -560,7 +560,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
@ -55,7 +55,7 @@ index 780118c410..3431ca815e 100644
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||
|
||||
############################################################################
|
||||
@@ -1546,17 +1540,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@@ -1551,17 +1545,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
else true; \
|
||||
fi; \
|
||||
done
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 56d0cce46e634840578af18492f3dffea55774a5 Mon Sep 17 00:00:00 2001
|
||||
From 2edaa31dec042fb8720add80814ca4a3cc4f788f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Wed, 15 Aug 2018 15:36:29 +0200
|
||||
Subject: [PATCH 4/7] 00189: Instead of bundled wheels, use our RPM packaged
|
||||
@ -10,7 +10,7 @@ We keep them in /usr/share/python-wheels
|
||||
1 file changed, 17 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/Lib/ensurepip/__init__.py b/Lib/ensurepip/__init__.py
|
||||
index 526dfd004a..fc02255feb 100644
|
||||
index 6f2569da81..4d17e413db 100644
|
||||
--- a/Lib/ensurepip/__init__.py
|
||||
+++ b/Lib/ensurepip/__init__.py
|
||||
@@ -1,16 +1,27 @@
|
||||
@ -44,7 +44,7 @@ index 526dfd004a..fc02255feb 100644
|
||||
|
||||
_PROJECTS = [
|
||||
("setuptools", _SETUPTOOLS_VERSION),
|
||||
@@ -94,12 +105,9 @@ def _bootstrap(*, root=None, upgrade=False, user=False,
|
||||
@@ -96,12 +107,9 @@ def _bootstrap(*, root=None, upgrade=False, user=False,
|
||||
additional_paths = []
|
||||
for project, version in _PROJECTS:
|
||||
wheel_name = "{}-{}-py2.py3-none-any.whl".format(project, version)
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 31460771d57aa535ed4672547d268c38f9eed755 Mon Sep 17 00:00:00 2001
|
||||
From 3e26b01573488b015065139689be3aa47dac17cf Mon Sep 17 00:00:00 2001
|
||||
From: Michal Cyprian <m.cyprian@gmail.com>
|
||||
Date: Mon, 26 Jun 2017 16:32:56 +0200
|
||||
Subject: [PATCH 5/7] 00251: Change user install location
|
||||
@ -40,10 +40,10 @@ index ae4f915669..0e4fd5b74a 100644
|
||||
else:
|
||||
if self.exec_prefix is None:
|
||||
diff --git a/Lib/site.py b/Lib/site.py
|
||||
index 99149a564f..1107324848 100644
|
||||
index 22d53fa562..9513526109 100644
|
||||
--- a/Lib/site.py
|
||||
+++ b/Lib/site.py
|
||||
@@ -347,7 +347,14 @@ def getsitepackages(prefixes=None):
|
||||
@@ -348,7 +348,14 @@ def getsitepackages(prefixes=None):
|
||||
return sitepackages
|
||||
|
||||
def addsitepackages(known_paths, prefixes=None):
|
||||
|
@ -1,4 +1,4 @@
|
||||
From d63983e350f673cf9a5f4267e73475535432ebe7 Mon Sep 17 00:00:00 2001
|
||||
From b92e29a8cc17f9c02a08b7a005e5ece71a409a0b Mon Sep 17 00:00:00 2001
|
||||
From: Petr Viktorin <pviktori@redhat.com>
|
||||
Date: Mon, 28 Aug 2017 17:16:46 +0200
|
||||
Subject: [PATCH 6/7] 00274: Upstream uses Debian-style architecture naming,
|
||||
@ -29,7 +29,7 @@ index ba37cf99e2..52a9ec6662 100755
|
||||
ppc64le | powerpc64little)
|
||||
basic_machine=powerpc64le-unknown
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3bb44e6993..98b5e32ad9 100644
|
||||
index 9a587f3c3f..695ff85e4b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -741,9 +741,9 @@ cat >> conftest.c <<EOF
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 736a0ca9fd2ee3f74ebdef187c5616288cc70351 Mon Sep 17 00:00:00 2001
|
||||
From b4bb0385ffcfafb2a203b0863777b135d37feb3a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Thu, 20 Dec 2018 12:46:25 +0100
|
||||
Subject: [PATCH 7/7] 00316: Mark bdist_wininst unsupported
|
||||
@ -10,7 +10,7 @@ So we mark the command as unsupported - and the tests are skipped.
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/Lib/distutils/command/bdist_wininst.py b/Lib/distutils/command/bdist_wininst.py
|
||||
index 3a616883be..ba299a4028 100644
|
||||
index acaa184b5f..6b458cb364 100644
|
||||
--- a/Lib/distutils/command/bdist_wininst.py
|
||||
+++ b/Lib/distutils/command/bdist_wininst.py
|
||||
@@ -12,6 +12,8 @@ from distutils.sysconfig import get_python_version
|
||||
|
@ -14,7 +14,7 @@ URL: https://www.python.org/
|
||||
# WARNING When rebasing to a new Python version,
|
||||
# remember to update the python3-docs package as well
|
||||
%global general_version %{pybasever}.0
|
||||
%global prerel b1
|
||||
%global prerel b2
|
||||
%global upstream_version %{general_version}%{?prerel}
|
||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||
Release: 1%{?dist}
|
||||
@ -1477,6 +1477,9 @@ CheckPython optimized
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Fri Jul 05 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~b2-1
|
||||
- Update to 3.8.0b2
|
||||
|
||||
* Wed Jun 05 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~b1-1
|
||||
- Update to 3.8.0b1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Python-3.8.0b1.tar.xz) = 0e2547691fde3a88408211146cd3be0de8e3e79c11485aec1062c17fabccefbcf2c1b188c96e570387f86b2e1b6a2fcbbb7329b241ff978974ca43e01ef014ca
|
||||
SHA512 (Python-3.8.0b2.tar.xz) = 5d4fdabad098b5273d34ecd939e7f7c104f4f9fc1460e5abaf4a8d1ad1c5d2ff26d579de03106f000672e0a20fcd6e4e1e44ce03be4bb4a734f937f3cc81cb3e
|
||||
|
Loading…
Reference in New Issue
Block a user