0c8875f3f6
* Sat Sep 10 2011 David Malcolm <dmalcolm@redhat.com> - 3.2.2-2 - rewrite of "check", introducing downstream-only hooks for skipping specific cases in an rpmbuild (patch 132), and fixing/skipping failing tests in a more fine-grained manner than before; (patches 106, 133-142 sparsely, moving patches for consistency with python.spec: 128 to 134, 126 to 135, 127 to 141)
23 lines
907 B
Diff
23 lines
907 B
Diff
diff -up Python-3.2b2/Lib/test/test_gc.py.fix-test-gc-COUNT_ALLOCS Python-3.2b2/Lib/test/test_gc.py
|
|
--- Python-3.2b2/Lib/test/test_gc.py.fix-test-gc-COUNT_ALLOCS 2010-12-28 20:39:40.779059772 -0500
|
|
+++ Python-3.2b2/Lib/test/test_gc.py 2010-12-28 20:41:15.890940017 -0500
|
|
@@ -102,10 +102,16 @@ class GCTests(unittest.TestCase):
|
|
del a
|
|
self.assertNotEqual(gc.collect(), 0)
|
|
del B, C
|
|
- self.assertNotEqual(gc.collect(), 0)
|
|
+ if hasattr(sys, 'getcounts'):
|
|
+ self.assertEqual(gc.collect(), 0)
|
|
+ else:
|
|
+ self.assertNotEqual(gc.collect(), 0)
|
|
A.a = A()
|
|
del A
|
|
- self.assertNotEqual(gc.collect(), 0)
|
|
+ if hasattr(sys, 'getcounts'):
|
|
+ self.assertEqual(gc.collect(), 0)
|
|
+ else:
|
|
+ self.assertNotEqual(gc.collect(), 0)
|
|
self.assertEqual(gc.collect(), 0)
|
|
|
|
def test_method(self):
|