c923b51771
* Mon Sep 12 2011 David Malcolm <dmalcolm@redhat.com> - 3.2.2-3 - renumber and rename patches for consistency with python.spec (8 to 55, 106 to 104, 6 to 111, 104 to 113, 105 to 114, 125, 131, 130 to 143)
51 lines
1.8 KiB
Diff
51 lines
1.8 KiB
Diff
diff -up Python-3.1.2/configure.in.more-configuration-flags Python-3.1.2/configure.in
|
|
--- Python-3.1.2/configure.in.more-configuration-flags 2010-05-25 12:16:48.602875960 -0400
|
|
+++ Python-3.1.2/configure.in 2010-05-25 12:16:48.609879553 -0400
|
|
@@ -2443,6 +2443,30 @@ else AC_MSG_RESULT(no)
|
|
fi],
|
|
[AC_MSG_RESULT(no)])
|
|
|
|
+AC_MSG_CHECKING(for --with-count-allocs)
|
|
+AC_ARG_WITH(count-allocs,
|
|
+[ --with(out)count-allocs enable/disable per-type instance accounting], [
|
|
+if test "$withval" != no
|
|
+then
|
|
+ AC_DEFINE(COUNT_ALLOCS, 1,
|
|
+ [Define to keep records of the number of instances of each type])
|
|
+ AC_MSG_RESULT(yes)
|
|
+else AC_MSG_RESULT(no)
|
|
+fi],
|
|
+[AC_MSG_RESULT(no)])
|
|
+
|
|
+AC_MSG_CHECKING(for --with-call-profile)
|
|
+AC_ARG_WITH(call-profile,
|
|
+[ --with(out)-call-profile enable/disable statistics on function call invocation], [
|
|
+if test "$withval" != no
|
|
+then
|
|
+ AC_DEFINE(CALL_PROFILE, 1,
|
|
+ [Define to keep records on function call invocation])
|
|
+ AC_MSG_RESULT(yes)
|
|
+else AC_MSG_RESULT(no)
|
|
+fi],
|
|
+[AC_MSG_RESULT(no)])
|
|
+
|
|
# Check for Python-specific malloc support
|
|
AC_MSG_CHECKING(for --with-pymalloc)
|
|
AC_ARG_WITH(pymalloc,
|
|
diff -up Python-3.1.2/pyconfig.h.in.more-configuration-flags Python-3.1.2/pyconfig.h.in
|
|
--- Python-3.1.2/pyconfig.h.in.more-configuration-flags 2010-05-25 12:16:48.000000000 -0400
|
|
+++ Python-3.1.2/pyconfig.h.in 2010-05-25 12:17:54.428126399 -0400
|
|
@@ -18,6 +18,12 @@
|
|
/* Define if you have the Mach cthreads package */
|
|
#undef C_THREADS
|
|
|
|
+/* Define to keep records on function call invocation */
|
|
+#undef CALL_PROFILE
|
|
+
|
|
+/* Define to keep records of the number of instances of each type */
|
|
+#undef COUNT_ALLOCS
|
|
+
|
|
/* Define if C doubles are 64-bit IEEE 754 binary format, stored in ARM
|
|
mixed-endian order (byte order 45670123) */
|
|
#undef DOUBLE_IS_ARM_MIXED_ENDIAN_IEEE754
|