7eb10c8dbe
* Sat Aug 21 2010 David Malcolm <dmalcolm@redhat.com> - 3.2-0.0.a1 - 3.2a1; add alphatag - rework %%files in the light of PEP 3147 (__pycache__) - drop our configuration patch to Setup.dist (patch 0): setup.py should do a better job of things, and the %%files explicitly lists our modules (r82746 appears to break the old way of doing things). This leads to various modules changing from "foomodule.so" to "foo.so". It also leads to the optimized build dropping the _sha1, _sha256 and _sha512 modules, but these are provided by _hashlib; _weakref becomes a builtin module; xxsubtype goes away (it's only for testing/devel purposes) - fixup patches 3, 4, 6, 8, 102, 103, 105, 111 for the rebase - remove upstream patches: 7 (system expat), 106, 107, 108 (audioop reformat plus CVE-2010-1634 and CVE-2010-2089), 109 (CVE-2008-5983) - add machinery for rebuilding "configure" and friends, using the correct version of autoconf (patch 300) - patch the debug build's usage of COUNT_ALLOCS to be less verbose (patch 125) - "modulator" was removed upstream - drop "-b" from patch applications affecting .py files to avoid littering the installation tree
58 lines
2.5 KiB
Diff
58 lines
2.5 KiB
Diff
diff -up Python-3.2a1/Lib/email/test/test_email.py.remove-mimeaudio-tests Python-3.2a1/Lib/email/test/test_email.py
|
||
--- Python-3.2a1/Lib/email/test/test_email.py.remove-mimeaudio-tests 2010-08-02 15:52:12.397002172 -0400
|
||
+++ Python-3.2a1/Lib/email/test/test_email.py 2010-08-02 15:52:38.132999850 -0400
|
||
@@ -952,53 +952,6 @@ Blah blah blah
|
||
|
||
|
||
|
||
-# Test the basic MIMEAudio class
|
||
-class TestMIMEAudio(unittest.TestCase):
|
||
- def setUp(self):
|
||
- # Make sure we pick up the audiotest.au that lives in email/test/data.
|
||
- # In Python, there's an audiotest.au living in Lib/test but that isn't
|
||
- # included in some binary distros that don't include the test
|
||
- # package. The trailing empty string on the .join() is significant
|
||
- # since findfile() will do a dirname().
|
||
- datadir = os.path.join(os.path.dirname(landmark), 'data', '')
|
||
- with open(findfile('audiotest.au', datadir), 'rb') as fp:
|
||
- self._audiodata = fp.read()
|
||
- self._au = MIMEAudio(self._audiodata)
|
||
-
|
||
- def test_guess_minor_type(self):
|
||
- self.assertEqual(self._au.get_content_type(), 'audio/basic')
|
||
-
|
||
- def test_encoding(self):
|
||
- payload = self._au.get_payload()
|
||
- self.assertEqual(base64.decodebytes(bytes(payload, 'ascii')),
|
||
- self._audiodata)
|
||
-
|
||
- def test_checkSetMinor(self):
|
||
- au = MIMEAudio(self._audiodata, 'fish')
|
||
- self.assertEqual(au.get_content_type(), 'audio/fish')
|
||
-
|
||
- def test_add_header(self):
|
||
- eq = self.assertEqual
|
||
- unless = self.assertTrue
|
||
- self._au.add_header('Content-Disposition', 'attachment',
|
||
- filename='audiotest.au')
|
||
- eq(self._au['content-disposition'],
|
||
- 'attachment; filename="audiotest.au"')
|
||
- eq(self._au.get_params(header='content-disposition'),
|
||
- [('attachment', ''), ('filename', 'audiotest.au')])
|
||
- eq(self._au.get_param('filename', header='content-disposition'),
|
||
- 'audiotest.au')
|
||
- missing = []
|
||
- eq(self._au.get_param('attachment', header='content-disposition'), '')
|
||
- unless(self._au.get_param('foo', failobj=missing,
|
||
- header='content-disposition') is missing)
|
||
- # Try some missing stuff
|
||
- unless(self._au.get_param('foobar', missing) is missing)
|
||
- unless(self._au.get_param('attachment', missing,
|
||
- header='foobar') is missing)
|
||
-
|
||
-
|
||
-
|
||
# Test the basic MIMEImage class
|
||
class TestMIMEImage(unittest.TestCase):
|
||
def setUp(self):
|