9423d36fb4
Patches 180, 206, 243 and 5001 all changed architecture names from Debian style (which upstream uses) to what Fedora uses. Consolidate them into a single patch, 274. Delete changes to `configure` from patch 243 without replacement; that file is generated from `configure.ac`.
59 lines
1.8 KiB
Diff
59 lines
1.8 KiB
Diff
diff -up Python-3.5.0/configure.ac.than Python-3.5.0/configure.ac
|
|
--- Python-3.5.0/configure.ac.than 2015-11-13 11:51:32.039560172 -0500
|
|
+++ Python-3.5.0/configure.ac 2015-11-13 11:52:11.670168157 -0500
|
|
@@ -788,9 +788,9 @@ cat >> conftest.c <<EOF
|
|
alpha-linux-gnu
|
|
# elif defined(__ARM_EABI__) && defined(__ARM_PCS_VFP)
|
|
# if defined(__ARMEL__)
|
|
- arm-linux-gnueabihf
|
|
+ arm-linux-gnueabi
|
|
# else
|
|
- armeb-linux-gnueabihf
|
|
+ armeb-linux-gnueabi
|
|
# endif
|
|
# elif defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)
|
|
# if defined(__ARMEL__)
|
|
@@ -810,7 +810,7 @@ cat >> conftest.c <<EOF
|
|
# elif _MIPS_SIM == _ABIN32
|
|
mips64el-linux-gnuabin32
|
|
# elif _MIPS_SIM == _ABI64
|
|
- mips64el-linux-gnuabi64
|
|
+ mips64el-linux-gnu
|
|
# else
|
|
# error unknown platform triplet
|
|
# endif
|
|
@@ -820,7 +820,7 @@ cat >> conftest.c <<EOF
|
|
# elif _MIPS_SIM == _ABIN32
|
|
mips64-linux-gnuabin32
|
|
# elif _MIPS_SIM == _ABI64
|
|
- mips64-linux-gnuabi64
|
|
+ mips64-linux-gnu
|
|
# else
|
|
# error unknown platform triplet
|
|
# endif
|
|
@@ -830,9 +830,9 @@ cat >> conftest.c <<EOF
|
|
powerpc-linux-gnuspe
|
|
# elif defined(__powerpc64__)
|
|
# if defined(__LITTLE_ENDIAN__)
|
|
- powerpc64le-linux-gnu
|
|
+ ppc64le-linux-gnu
|
|
# else
|
|
- powerpc64-linux-gnu
|
|
+ ppc64-linux-gnu
|
|
# endif
|
|
# elif defined(__powerpc__)
|
|
powerpc-linux-gnu
|
|
diff --git a/config.sub b/config.sub
|
|
index 40ea5df..932128b 100755
|
|
--- a/config.sub
|
|
+++ b/config.sub
|
|
@@ -1045,7 +1045,7 @@ case $basic_machine in
|
|
;;
|
|
ppc64) basic_machine=powerpc64-unknown
|
|
;;
|
|
- ppc64-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
|
+ ppc64-* | ppc64p7-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
|
;;
|
|
ppc64le | powerpc64little)
|
|
basic_machine=powerpc64le-unknown
|