28856627bf
* Wed Apr 11 2012 David Malcolm <dmalcolm@redhat.com> - 3.2.3-1 - 3.2.3; refresh patch 102 (lib64); drop upstream patches 148 (gdbm magic values), 149 (__pycache__ fix); add patch 152 (test_gdb regex)
201 lines
9.7 KiB
Diff
201 lines
9.7 KiB
Diff
diff -up Python-3.2.3/Lib/distutils/command/install.py.lib64 Python-3.2.3/Lib/distutils/command/install.py
|
|
--- Python-3.2.3/Lib/distutils/command/install.py.lib64 2012-04-11 02:54:02.000000000 -0400
|
|
+++ Python-3.2.3/Lib/distutils/command/install.py 2012-04-11 19:01:19.727107020 -0400
|
|
@@ -45,14 +45,14 @@ else:
|
|
INSTALL_SCHEMES = {
|
|
'unix_prefix': {
|
|
'purelib': '$base/lib/python$py_version_short/site-packages',
|
|
- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
|
|
+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
|
|
'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
},
|
|
'unix_home': {
|
|
'purelib': '$base/lib/python',
|
|
- 'platlib': '$base/lib/python',
|
|
+ 'platlib': '$base/lib64/python',
|
|
'headers': '$base/include/python/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
diff -up Python-3.2.3/Lib/distutils/sysconfig.py.lib64 Python-3.2.3/Lib/distutils/sysconfig.py
|
|
--- Python-3.2.3/Lib/distutils/sysconfig.py.lib64 2012-04-11 02:54:02.000000000 -0400
|
|
+++ Python-3.2.3/Lib/distutils/sysconfig.py 2012-04-11 19:01:19.727107020 -0400
|
|
@@ -122,8 +122,12 @@ def get_python_lib(plat_specific=0, stan
|
|
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
|
|
|
if os.name == "posix":
|
|
+ if plat_specific or standard_lib:
|
|
+ lib = "lib64"
|
|
+ else:
|
|
+ lib = "lib"
|
|
libpython = os.path.join(prefix,
|
|
- "lib", "python" + get_python_version())
|
|
+ lib, "python" + get_python_version())
|
|
if standard_lib:
|
|
return libpython
|
|
else:
|
|
diff -up Python-3.2.3/Lib/site.py.lib64 Python-3.2.3/Lib/site.py
|
|
--- Python-3.2.3/Lib/site.py.lib64 2012-04-11 02:54:03.000000000 -0400
|
|
+++ Python-3.2.3/Lib/site.py 2012-04-11 19:01:19.728107008 -0400
|
|
@@ -285,12 +285,16 @@ def getsitepackages():
|
|
if sys.platform in ('os2emx', 'riscos'):
|
|
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
|
elif os.sep == '/':
|
|
+ sitepackages.append(os.path.join(prefix, "lib64",
|
|
+ "python" + sys.version[:3],
|
|
+ "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib",
|
|
"python" + sys.version[:3],
|
|
"site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib", "site-python"))
|
|
else:
|
|
sitepackages.append(prefix)
|
|
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
|
if sys.platform == "darwin":
|
|
# for framework builds *only* we add the standard Apple
|
|
diff -up Python-3.2.3/Lib/sysconfig.py.lib64 Python-3.2.3/Lib/sysconfig.py
|
|
--- Python-3.2.3/Lib/sysconfig.py.lib64 2012-04-11 02:54:03.000000000 -0400
|
|
+++ Python-3.2.3/Lib/sysconfig.py 2012-04-11 19:01:19.728107008 -0400
|
|
@@ -21,10 +21,10 @@ __all__ = [
|
|
|
|
_INSTALL_SCHEMES = {
|
|
'posix_prefix': {
|
|
- 'stdlib': '{base}/lib/python{py_version_short}',
|
|
- 'platstdlib': '{platbase}/lib/python{py_version_short}',
|
|
+ 'stdlib': '{base}/lib64/python{py_version_short}',
|
|
+ 'platstdlib': '{platbase}/lib64/python{py_version_short}',
|
|
'purelib': '{base}/lib/python{py_version_short}/site-packages',
|
|
- 'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
|
|
+ 'platlib': '{platbase}/lib64/python{py_version_short}/site-packages',
|
|
'include':
|
|
'{base}/include/python{py_version_short}{abiflags}',
|
|
'platinclude':
|
|
@@ -81,10 +81,10 @@ _INSTALL_SCHEMES = {
|
|
'data' : '{userbase}',
|
|
},
|
|
'posix_user': {
|
|
- 'stdlib': '{userbase}/lib/python{py_version_short}',
|
|
- 'platstdlib': '{userbase}/lib/python{py_version_short}',
|
|
+ 'stdlib': '{userbase}/lib64/python{py_version_short}',
|
|
+ 'platstdlib': '{userbase}/lib64/python{py_version_short}',
|
|
'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
|
|
- 'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
|
|
+ 'platlib': '{userbase}/lib64/python{py_version_short}/site-packages',
|
|
'include': '{userbase}/include/python{py_version_short}',
|
|
'scripts': '{userbase}/bin',
|
|
'data' : '{userbase}',
|
|
diff -up Python-3.2.3/Lib/test/test_site.py.lib64 Python-3.2.3/Lib/test/test_site.py
|
|
--- Python-3.2.3/Lib/test/test_site.py.lib64 2012-04-11 02:54:05.000000000 -0400
|
|
+++ Python-3.2.3/Lib/test/test_site.py 2012-04-11 19:02:01.413585869 -0400
|
|
@@ -236,12 +236,15 @@ class HelperFunctionsTests(unittest.Test
|
|
self.assertEqual(dirs[2], wanted)
|
|
elif os.sep == '/':
|
|
# OS X non-framwework builds, Linux, FreeBSD, etc
|
|
- self.assertEqual(len(dirs), 2)
|
|
- wanted = os.path.join('xoxo', 'lib', 'python' + sys.version[:3],
|
|
+ self.assertEqual(len(dirs), 3)
|
|
+ wanted = os.path.join('xoxo', 'lib64', 'python' + sys.version[:3],
|
|
'site-packages')
|
|
self.assertEqual(dirs[0], wanted)
|
|
- wanted = os.path.join('xoxo', 'lib', 'site-python')
|
|
+ wanted = os.path.join('xoxo', 'lib', 'python' + sys.version[:3],
|
|
+ 'site-packages')
|
|
self.assertEqual(dirs[1], wanted)
|
|
+ wanted = os.path.join('xoxo', 'lib', 'site-python')
|
|
+ self.assertEqual(dirs[2], wanted)
|
|
else:
|
|
# other platforms
|
|
self.assertEqual(len(dirs), 2)
|
|
diff -up Python-3.2.3/Makefile.pre.in.lib64 Python-3.2.3/Makefile.pre.in
|
|
--- Python-3.2.3/Makefile.pre.in.lib64 2012-04-11 19:01:19.722107084 -0400
|
|
+++ Python-3.2.3/Makefile.pre.in 2012-04-11 19:01:19.729106996 -0400
|
|
@@ -106,7 +106,7 @@ LIBDIR= @libdir@
|
|
MANDIR= @mandir@
|
|
INCLUDEDIR= @includedir@
|
|
CONFINCLUDEDIR= $(exec_prefix)/include
|
|
-SCRIPTDIR= $(prefix)/lib
|
|
+SCRIPTDIR= $(prefix)/lib64
|
|
ABIFLAGS= @ABIFLAGS@
|
|
|
|
# Detailed destination directories
|
|
diff -up Python-3.2.3/Modules/getpath.c.lib64 Python-3.2.3/Modules/getpath.c
|
|
--- Python-3.2.3/Modules/getpath.c.lib64 2012-04-11 02:54:07.000000000 -0400
|
|
+++ Python-3.2.3/Modules/getpath.c 2012-04-11 19:01:19.729106996 -0400
|
|
@@ -122,8 +122,8 @@
|
|
#endif
|
|
|
|
#ifndef PYTHONPATH
|
|
-#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
|
|
- EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
|
|
+#define PYTHONPATH PREFIX "/lib64/python" VERSION ":" \
|
|
+ EXEC_PREFIX "/lib64/python" VERSION "/lib-dynload"
|
|
#endif
|
|
|
|
#ifndef LANDMARK
|
|
@@ -135,7 +135,7 @@ static wchar_t exec_prefix[MAXPATHLEN+1]
|
|
static wchar_t progpath[MAXPATHLEN+1];
|
|
static wchar_t *module_search_path = NULL;
|
|
static int module_search_path_malloced = 0;
|
|
-static wchar_t *lib_python = L"lib/python" VERSION;
|
|
+static wchar_t *lib_python = L"lib64/python" VERSION;
|
|
|
|
static void
|
|
reduce(wchar_t *dir)
|
|
@@ -583,7 +583,7 @@ calculate_path(void)
|
|
}
|
|
else
|
|
wcsncpy(zip_path, _prefix, MAXPATHLEN);
|
|
- joinpath(zip_path, L"lib/python00.zip");
|
|
+ joinpath(zip_path, L"lib64/python00.zip");
|
|
bufsz = wcslen(zip_path); /* Replace "00" with version */
|
|
zip_path[bufsz - 6] = VERSION[0];
|
|
zip_path[bufsz - 5] = VERSION[2];
|
|
@@ -593,7 +593,7 @@ calculate_path(void)
|
|
fprintf(stderr,
|
|
"Could not find platform dependent libraries <exec_prefix>\n");
|
|
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
|
|
- joinpath(exec_prefix, L"lib/lib-dynload");
|
|
+ joinpath(exec_prefix, L"lib64/lib-dynload");
|
|
}
|
|
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
|
|
|
diff -up Python-3.2.3/setup.py.lib64 Python-3.2.3/setup.py
|
|
--- Python-3.2.3/setup.py.lib64 2012-04-11 02:54:08.000000000 -0400
|
|
+++ Python-3.2.3/setup.py 2012-04-11 19:01:19.730106984 -0400
|
|
@@ -396,7 +396,7 @@ class PyBuildExt(build_ext):
|
|
# Ensure that /usr/local is always used, but the local build
|
|
# directories (i.e. '.' and 'Include') must be first. See issue
|
|
# 10520.
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
self.add_multiarch_paths()
|
|
|
|
@@ -643,11 +643,11 @@ class PyBuildExt(build_ext):
|
|
elif curses_library:
|
|
readline_libs.append(curses_library)
|
|
elif self.compiler.find_library_file(lib_dirs +
|
|
- ['/usr/lib/termcap'],
|
|
+ ['/usr/lib64/termcap'],
|
|
'termcap'):
|
|
readline_libs.append('termcap')
|
|
exts.append( Extension('readline', ['readline.c'],
|
|
- library_dirs=['/usr/lib/termcap'],
|
|
+ library_dirs=['/usr/lib64/termcap'],
|
|
extra_link_args=readline_extra_link_args,
|
|
libraries=readline_libs) )
|
|
else:
|
|
@@ -684,8 +684,8 @@ class PyBuildExt(build_ext):
|
|
if krb5_h:
|
|
ssl_incs += krb5_h
|
|
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
|
- ['/usr/local/ssl/lib',
|
|
- '/usr/contrib/ssl/lib/'
|
|
+ ['/usr/local/ssl/lib64',
|
|
+ '/usr/contrib/ssl/lib64/'
|
|
] )
|
|
|
|
if (ssl_incs is not None and
|