c923b51771
* Mon Sep 12 2011 David Malcolm <dmalcolm@redhat.com> - 3.2.2-3 - renumber and rename patches for consistency with python.spec (8 to 55, 106 to 104, 6 to 111, 104 to 113, 105 to 114, 125, 131, 130 to 143)
48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
diff -up Python-3.2a1/Modules/posixmodule.c.statvfs-f-flag-constants Python-3.2a1/Modules/posixmodule.c
|
|
--- Python-3.2a1/Modules/posixmodule.c.statvfs-f-flag-constants 2010-07-23 09:53:51.000000000 -0400
|
|
+++ Python-3.2a1/Modules/posixmodule.c 2010-08-02 16:39:38.756000423 -0400
|
|
@@ -8173,6 +8173,43 @@ all_ins(PyObject *d)
|
|
#endif
|
|
#endif
|
|
|
|
+ /* These came from statvfs.h */
|
|
+#ifdef ST_RDONLY
|
|
+ if (ins(d, "ST_RDONLY", (long)ST_RDONLY)) return -1;
|
|
+#endif /* ST_RDONLY */
|
|
+#ifdef ST_NOSUID
|
|
+ if (ins(d, "ST_NOSUID", (long)ST_NOSUID)) return -1;
|
|
+#endif /* ST_NOSUID */
|
|
+
|
|
+ /* GNU extensions */
|
|
+#ifdef ST_NODEV
|
|
+ if (ins(d, "ST_NODEV", (long)ST_NODEV)) return -1;
|
|
+#endif /* ST_NODEV */
|
|
+#ifdef ST_NOEXEC
|
|
+ if (ins(d, "ST_NOEXEC", (long)ST_NOEXEC)) return -1;
|
|
+#endif /* ST_NOEXEC */
|
|
+#ifdef ST_SYNCHRONOUS
|
|
+ if (ins(d, "ST_SYNCHRONOUS", (long)ST_SYNCHRONOUS)) return -1;
|
|
+#endif /* ST_SYNCHRONOUS */
|
|
+#ifdef ST_MANDLOCK
|
|
+ if (ins(d, "ST_MANDLOCK", (long)ST_MANDLOCK)) return -1;
|
|
+#endif /* ST_MANDLOCK */
|
|
+#ifdef ST_WRITE
|
|
+ if (ins(d, "ST_WRITE", (long)ST_WRITE)) return -1;
|
|
+#endif /* ST_WRITE */
|
|
+#ifdef ST_APPEND
|
|
+ if (ins(d, "ST_APPEND", (long)ST_APPEND)) return -1;
|
|
+#endif /* ST_APPEND */
|
|
+#ifdef ST_NOATIME
|
|
+ if (ins(d, "ST_NOATIME", (long)ST_NOATIME)) return -1;
|
|
+#endif /* ST_NOATIME */
|
|
+#ifdef ST_NODIRATIME
|
|
+ if (ins(d, "ST_NODIRATIME", (long)ST_NODIRATIME)) return -1;
|
|
+#endif /* ST_NODIRATIME */
|
|
+#ifdef ST_RELATIME
|
|
+ if (ins(d, "ST_RELATIME", (long)ST_RELATIME)) return -1;
|
|
+#endif /* ST_RELATIME */
|
|
+
|
|
#if defined(PYOS_OS2)
|
|
if (insertvalues(d)) return -1;
|
|
#endif
|