7eb10c8dbe
* Sat Aug 21 2010 David Malcolm <dmalcolm@redhat.com> - 3.2-0.0.a1 - 3.2a1; add alphatag - rework %%files in the light of PEP 3147 (__pycache__) - drop our configuration patch to Setup.dist (patch 0): setup.py should do a better job of things, and the %%files explicitly lists our modules (r82746 appears to break the old way of doing things). This leads to various modules changing from "foomodule.so" to "foo.so". It also leads to the optimized build dropping the _sha1, _sha256 and _sha512 modules, but these are provided by _hashlib; _weakref becomes a builtin module; xxsubtype goes away (it's only for testing/devel purposes) - fixup patches 3, 4, 6, 8, 102, 103, 105, 111 for the rebase - remove upstream patches: 7 (system expat), 106, 107, 108 (audioop reformat plus CVE-2010-1634 and CVE-2010-2089), 109 (CVE-2008-5983) - add machinery for rebuilding "configure" and friends, using the correct version of autoconf (patch 300) - patch the debug build's usage of COUNT_ALLOCS to be less verbose (patch 125) - "modulator" was removed upstream - drop "-b" from patch applications affecting .py files to avoid littering the installation tree
244 lines
6.9 KiB
Diff
244 lines
6.9 KiB
Diff
diff -up ./configure.autotool-intermediates ./configure
|
|
--- ./configure.autotool-intermediates 2010-08-02 17:58:12.238002650 -0400
|
|
+++ ./configure 2010-08-02 17:58:20.151000507 -0400
|
|
@@ -1,5 +1,5 @@
|
|
#! /bin/sh
|
|
-# From configure.in Revision: 82090 .
|
|
+# From configure.in Revision: 82962 .
|
|
# Guess values for system-dependent variables and create Makefiles.
|
|
# Generated by GNU Autoconf 2.65 for python 3.2.
|
|
#
|
|
@@ -610,6 +610,8 @@ TRUE
|
|
MACHDEP_OBJS
|
|
DYNLOADFILE
|
|
DLINCLDIR
|
|
+DTRACEHDRS
|
|
+DTRACEOBJS
|
|
THREADOBJ
|
|
LDLAST
|
|
USE_THREAD_MODULE
|
|
@@ -630,6 +632,8 @@ OTHER_LIBTOOL_OPT
|
|
UNIVERSAL_ARCH_FLAGS
|
|
BASECFLAGS
|
|
OPT
|
|
+DEBUG_SUFFIX
|
|
+DEBUG_EXT
|
|
LN
|
|
INSTALL_DATA
|
|
INSTALL_SCRIPT
|
|
@@ -743,8 +747,11 @@ with_thread
|
|
enable_ipv6
|
|
with_doc_strings
|
|
with_tsc
|
|
+with_count_allocs
|
|
+with_call_profile
|
|
with_pymalloc
|
|
with_valgrind
|
|
+with_dtrace
|
|
with_wctype_functions
|
|
with_fpectl
|
|
with_libm
|
|
@@ -1414,8 +1421,11 @@ Optional Packages:
|
|
deprecated; use --with(out)-threads
|
|
--with(out)-doc-strings disable/enable documentation strings
|
|
--with(out)-tsc enable/disable timestamp counter profile
|
|
+ --with(out)count-allocs enable/disable per-type instance accounting
|
|
+ --with(out)-call-profile enable/disable statistics on function call invocation
|
|
--with(out)-pymalloc disable/enable specialized mallocs
|
|
--with-valgrind Enable Valgrind support
|
|
+ --with(out)-dtrace disable/enable dtrace support
|
|
--with-wctype-functions use wctype.h functions
|
|
--with-fpectl enable SIGFPE catching
|
|
--with-libm=STRING math library
|
|
@@ -1929,11 +1939,11 @@ else
|
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
/* end confdefs.h. */
|
|
$ac_includes_default
|
|
- enum { N = $2 / 2 - 1 };
|
|
int
|
|
main ()
|
|
{
|
|
-static int test_array [1 - 2 * !(0 < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1))];
|
|
+static int test_array [1 - 2 * !(enum { N = $2 / 2 - 1 };
|
|
+ 0 < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1))];
|
|
test_array [0] = 0
|
|
|
|
;
|
|
@@ -1944,11 +1954,11 @@ if ac_fn_c_try_compile "$LINENO"; then :
|
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
/* end confdefs.h. */
|
|
$ac_includes_default
|
|
- enum { N = $2 / 2 - 1 };
|
|
int
|
|
main ()
|
|
{
|
|
-static int test_array [1 - 2 * !(($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)
|
|
+static int test_array [1 - 2 * !(enum { N = $2 / 2 - 1 };
|
|
+ ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)
|
|
< ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 2))];
|
|
test_array [0] = 0
|
|
|
|
@@ -4672,7 +4682,7 @@ esac
|
|
$as_echo_n "checking LIBRARY... " >&6; }
|
|
if test -z "$LIBRARY"
|
|
then
|
|
- LIBRARY='libpython$(VERSION).a'
|
|
+ LIBRARY='libpython$(VERSION)$(DEBUG_EXT).a'
|
|
fi
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $LIBRARY" >&5
|
|
$as_echo "$LIBRARY" >&6; }
|
|
@@ -4843,8 +4853,8 @@ $as_echo "#define Py_ENABLE_SHARED 1" >>
|
|
INSTSONAME="$LDLIBRARY".$SOVERSION
|
|
;;
|
|
Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*)
|
|
- LDLIBRARY='libpython$(VERSION).so'
|
|
- BLDLIBRARY='-L. -lpython$(VERSION)'
|
|
+ LDLIBRARY='libpython$(VERSION)$(DEBUG_EXT).so'
|
|
+ BLDLIBRARY='-L. -lpython$(VERSION)$(DEBUG_EXT)'
|
|
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
|
|
case $ac_sys_system in
|
|
FreeBSD*)
|
|
@@ -5237,6 +5247,14 @@ $as_echo "no" >&6; }
|
|
fi
|
|
|
|
|
|
+if test "$Py_DEBUG" = 'true'
|
|
+then
|
|
+ DEBUG_EXT=_d
|
|
+ DEBUG_SUFFIX=-debug
|
|
+fi
|
|
+
|
|
+
|
|
+
|
|
# XXX Shouldn't the code above that fiddles with BASECFLAGS and OPT be
|
|
# merged with this chunk of code?
|
|
|
|
@@ -8160,6 +8178,7 @@ fi
|
|
$as_echo "$with_system_expat" >&6; }
|
|
|
|
# Check for use of the system libffi library
|
|
+
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-system-ffi" >&5
|
|
$as_echo_n "checking for --with-system-ffi... " >&6; }
|
|
|
|
@@ -9144,6 +9163,50 @@ $as_echo "no" >&6; }
|
|
fi
|
|
|
|
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-count-allocs" >&5
|
|
+$as_echo_n "checking for --with-count-allocs... " >&6; }
|
|
+
|
|
+# Check whether --with-count-allocs was given.
|
|
+if test "${with_count_allocs+set}" = set; then :
|
|
+ withval=$with_count_allocs;
|
|
+if test "$withval" != no
|
|
+then
|
|
+
|
|
+$as_echo "#define COUNT_ALLOCS 1" >>confdefs.h
|
|
+
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
+$as_echo "yes" >&6; }
|
|
+else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+
|
|
+
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-call-profile" >&5
|
|
+$as_echo_n "checking for --with-call-profile... " >&6; }
|
|
+
|
|
+# Check whether --with-call-profile was given.
|
|
+if test "${with_call_profile+set}" = set; then :
|
|
+ withval=$with_call_profile;
|
|
+if test "$withval" != no
|
|
+then
|
|
+
|
|
+$as_echo "#define CALL_PROFILE 1" >>confdefs.h
|
|
+
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
+$as_echo "yes" >&6; }
|
|
+else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+
|
|
+
|
|
# Check for Python-specific malloc support
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-pymalloc" >&5
|
|
$as_echo_n "checking for --with-pymalloc... " >&6; }
|
|
@@ -9194,6 +9257,46 @@ fi
|
|
OPT="-DDYNAMIC_ANNOTATIONS_ENABLED=1 $OPT"
|
|
fi
|
|
|
|
+# Check for dtrace support
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-dtrace" >&5
|
|
+$as_echo_n "checking for --with-dtrace... " >&6; }
|
|
+
|
|
+# Check whether --with-dtrace was given.
|
|
+if test "${with_dtrace+set}" = set; then :
|
|
+ withval=$with_dtrace;
|
|
+fi
|
|
+
|
|
+
|
|
+if test ! -z "$with_dtrace"
|
|
+then
|
|
+ if dtrace -G -o /dev/null -s $srcdir/Include/pydtrace.d 2>/dev/null
|
|
+ then
|
|
+
|
|
+$as_echo "#define WITH_DTRACE 1" >>confdefs.h
|
|
+
|
|
+ with_dtrace="Sun"
|
|
+ DTRACEOBJS="Python/dtrace.o"
|
|
+ DTRADEHDRS=""
|
|
+ elif dtrace -h -o /dev/null -s $srcdir/Include/pydtrace.d
|
|
+ then
|
|
+
|
|
+$as_echo "#define WITH_DTRACE 1" >>confdefs.h
|
|
+
|
|
+ with_dtrace="Apple"
|
|
+ DTRACEOBJS=""
|
|
+ DTRADEHDRS="pydtrace.h"
|
|
+ else
|
|
+ with_dtrace="no"
|
|
+ fi
|
|
+else
|
|
+ with_dtrace="no"
|
|
+fi
|
|
+
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_dtrace" >&5
|
|
+$as_echo "$with_dtrace" >&6; }
|
|
+
|
|
+
|
|
+
|
|
# Check for --with-wctype-functions
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-wctype-functions" >&5
|
|
$as_echo_n "checking for --with-wctype-functions... " >&6; }
|
|
diff -up ./pyconfig.h.in.autotool-intermediates ./pyconfig.h.in
|
|
--- ./pyconfig.h.in.autotool-intermediates 2010-08-02 17:58:12.236001348 -0400
|
|
+++ ./pyconfig.h.in 2010-08-02 17:58:20.000000000 -0400
|
|
@@ -12,15 +12,15 @@
|
|
support for AIX C++ shared extension modules. */
|
|
#undef AIX_GENUINE_CPLUSPLUS
|
|
|
|
-/* Define if you have the Mach cthreads package */
|
|
-#undef C_THREADS
|
|
-
|
|
/* Define to keep records on function call invocation */
|
|
#undef CALL_PROFILE
|
|
|
|
/* Define to keep records of the number of instances of each type */
|
|
#undef COUNT_ALLOCS
|
|
|
|
+/* Define if you have the Mach cthreads package */
|
|
+#undef C_THREADS
|
|
+
|
|
/* Define if C doubles are 64-bit IEEE 754 binary format, stored in ARM
|
|
mixed-endian order (byte order 45670123) */
|
|
#undef DOUBLE_IS_ARM_MIXED_ENDIAN_IEEE754
|