Update to 3.7.0b2

This commit is contained in:
Miro Hrončok 2018-02-28 10:30:29 +01:00
parent 6a6a8d45dd
commit ef18b4528a
4 changed files with 32 additions and 29 deletions

View File

@ -1,9 +1,9 @@
diff --git a/Makefile.pre.in b/Makefile.pre.in
index a5a9d5e..51e8132 100644
index 0eddd13..7ed4f3c 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -530,7 +530,7 @@ clinic: $(BUILDPYTHON) $(srcdir)/Modules/_blake2/blake2s_impl.c
$(RUNSHARED) $(PYTHON_FOR_BUILD) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
@@ -565,7 +565,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
# Build the interpreter
-$(BUILDPYTHON): Programs/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
@ -11,7 +11,7 @@ index a5a9d5e..51e8132 100644
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
@@ -574,12 +574,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
@@ -609,12 +609,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@ -24,7 +24,7 @@ index a5a9d5e..51e8132 100644
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
@@ -667,7 +661,7 @@ Modules/Setup: $(srcdir)/Modules/Setup.dist
@@ -702,7 +696,7 @@ Modules/Setup: $(srcdir)/Modules/Setup.dist
echo "-----------------------------------------------"; \
fi
@ -33,7 +33,7 @@ index a5a9d5e..51e8132 100644
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
@@ -1408,17 +1402,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
@@ -1460,17 +1454,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
else true; \
fi; \
done

View File

@ -1,8 +1,8 @@
diff --git a/Include/object.h b/Include/object.h
index cb57359..f928f97 100644
index c772dea..5729797 100644
--- a/Include/object.h
+++ b/Include/object.h
@@ -1069,6 +1069,49 @@ PyAPI_FUNC(void)
@@ -1098,6 +1098,49 @@ PyAPI_FUNC(void)
_PyObject_DebugTypeStats(FILE *out);
#endif /* ifndef Py_LIMITED_API */
@ -53,15 +53,15 @@ index cb57359..f928f97 100644
}
#endif
diff --git a/Lib/test/test_gc.py b/Lib/test/test_gc.py
index 904fc7d..5676007 100644
index 904fc7d..288e242 100644
--- a/Lib/test/test_gc.py
+++ b/Lib/test/test_gc.py
@@ -1,10 +1,11 @@
import unittest
from test.support import (verbose, refcount_test, run_unittest,
strip_python_stderr, cpython_only, start_threads,
- temp_dir, requires_type_collecting,reap_threads)
+ temp_dir,reap_threads, import_module, requires_type_collecting)
- temp_dir, requires_type_collecting)
+ temp_dir, import_module, requires_type_collecting)
from test.support.script_helper import assert_python_ok, make_script
import sys
@ -130,10 +130,10 @@ index 904fc7d..5676007 100644
def setUp(self):
gc.enable()
diff --git a/Modules/gcmodule.c b/Modules/gcmodule.c
index 6e26c7a..8410206 100644
index 8ba1093..e795308 100644
--- a/Modules/gcmodule.c
+++ b/Modules/gcmodule.c
@@ -238,7 +238,8 @@ update_refs(PyGC_Head *containers)
@@ -239,7 +239,8 @@ update_refs(PyGC_Head *containers)
{
PyGC_Head *gc = containers->gc.gc_next;
for (; gc != containers; gc = gc->gc.gc_next) {
@ -143,7 +143,7 @@ index 6e26c7a..8410206 100644
_PyGCHead_SET_REFS(gc, Py_REFCNT(FROM_GC(gc)));
/* Python's cyclic gc should never see an incoming refcount
* of 0: if something decref'ed to 0, it should have been
@@ -258,7 +259,8 @@ update_refs(PyGC_Head *containers)
@@ -259,7 +260,8 @@ update_refs(PyGC_Head *containers)
* so serious that maybe this should be a release-build
* check instead of an assert?
*/
@ -153,7 +153,7 @@ index 6e26c7a..8410206 100644
}
}
@@ -273,7 +275,9 @@ visit_decref(PyObject *op, void *data)
@@ -274,7 +276,9 @@ visit_decref(PyObject *op, void *data)
* generation being collected, which can be recognized
* because only they have positive gc_refs.
*/
@ -164,7 +164,7 @@ index 6e26c7a..8410206 100644
if (_PyGCHead_REFS(gc) > 0)
_PyGCHead_DECREF(gc);
}
@@ -333,9 +337,10 @@ visit_reachable(PyObject *op, PyGC_Head *reachable)
@@ -334,9 +338,10 @@ visit_reachable(PyObject *op, PyGC_Head *reachable)
* If gc_refs == GC_UNTRACKED, it must be ignored.
*/
else {
@ -178,7 +178,7 @@ index 6e26c7a..8410206 100644
}
}
return 0;
@@ -377,7 +382,7 @@ move_unreachable(PyGC_Head *young, PyGC_Head *unreachable)
@@ -378,7 +383,7 @@ move_unreachable(PyGC_Head *young, PyGC_Head *unreachable)
*/
PyObject *op = FROM_GC(gc);
traverseproc traverse = Py_TYPE(op)->tp_traverse;
@ -187,7 +187,7 @@ index 6e26c7a..8410206 100644
_PyGCHead_SET_REFS(gc, GC_REACHABLE);
(void) traverse(op,
(visitproc)visit_reachable,
@@ -440,7 +445,7 @@ move_legacy_finalizers(PyGC_Head *unreachable, PyGC_Head *finalizers)
@@ -441,7 +446,7 @@ move_legacy_finalizers(PyGC_Head *unreachable, PyGC_Head *finalizers)
for (gc = unreachable->gc.gc_next; gc != unreachable; gc = next) {
PyObject *op = FROM_GC(gc);
@ -196,7 +196,7 @@ index 6e26c7a..8410206 100644
next = gc->gc.gc_next;
if (has_legacy_finalizer(op)) {
@@ -516,7 +521,7 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
@@ -517,7 +522,7 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
PyWeakReference **wrlist;
op = FROM_GC(gc);
@ -205,7 +205,7 @@ index 6e26c7a..8410206 100644
next = gc->gc.gc_next;
if (! PyType_SUPPORTS_WEAKREFS(Py_TYPE(op)))
@@ -537,9 +542,9 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
@@ -538,9 +543,9 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
* the callback pointer intact. Obscure: it also
* changes *wrlist.
*/
@ -217,7 +217,7 @@ index 6e26c7a..8410206 100644
if (wr->wr_callback == NULL)
continue; /* no callback */
@@ -573,7 +578,7 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
@@ -574,7 +579,7 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
*/
if (IS_TENTATIVELY_UNREACHABLE(wr))
continue;
@ -226,7 +226,7 @@ index 6e26c7a..8410206 100644
/* Create a new reference so that wr can't go away
* before we can process it again.
@@ -582,7 +587,8 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
@@ -583,7 +588,8 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
/* Move wr to wrcb_to_call, for the next pass. */
wrasgc = AS_GC(wr);
@ -236,7 +236,7 @@ index 6e26c7a..8410206 100644
next isn't, so they can't
be the same */
gc_list_move(wrasgc, &wrcb_to_call);
@@ -598,11 +604,11 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
@@ -599,11 +605,11 @@ handle_weakrefs(PyGC_Head *unreachable, PyGC_Head *old)
gc = wrcb_to_call.gc.gc_next;
op = FROM_GC(gc);
@ -251,7 +251,7 @@ index 6e26c7a..8410206 100644
/* copy-paste of weakrefobject.c's handle_callback() */
temp = PyObject_CallFunctionObjArgs(callback, wr, NULL);
@@ -719,12 +725,14 @@ check_garbage(PyGC_Head *collectable)
@@ -720,12 +726,14 @@ check_garbage(PyGC_Head *collectable)
for (gc = collectable->gc.gc_next; gc != collectable;
gc = gc->gc.gc_next) {
_PyGCHead_SET_REFS(gc, Py_REFCNT(FROM_GC(gc)));
@ -269,10 +269,10 @@ index 6e26c7a..8410206 100644
return -1;
}
diff --git a/Objects/object.c b/Objects/object.c
index ed8a62a..5279b15 100644
index 220aa90..f6c7161 100644
--- a/Objects/object.c
+++ b/Objects/object.c
@@ -2116,6 +2116,35 @@ _PyTrash_thread_destroy_chain(void)
@@ -2177,6 +2177,35 @@ _PyTrash_thread_destroy_chain(void)
--tstate->trash_delete_nesting;
}

View File

@ -13,12 +13,12 @@ URL: https://www.python.org/
# Second alpha
%global prerel b1
%global prerel b2
# WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well
Version: %{pybasever}.0
Release: 0.11.%{?prerel}%{?dist}
Release: 0.12.%{?prerel}%{?dist}
License: Python
@ -1572,6 +1572,9 @@ CheckPython optimized
# ======================================================
%changelog
* Wed Feb 28 2018 Miro Hrončok <mhroncok@redhat.com> - 3.7.0-0.12.b2
- Update to 3.7.0b2
* Wed Feb 21 2018 Miro Hrončok <mhroncok@redhat.com> - 3.7.0-0.11.b1
- Fix the py_byte_compile macro to work on Python 2
- Remove the pybytecompile macro file from the flat package

View File

@ -1 +1 @@
SHA512 (Python-3.7.0b1.tar.xz) = c2c9d76c310987e1998504ae6270350e7afd3834923143fe9f9e7ad130a491f2d1b45f26aff4c3ce5e6133979098da68e865aaabfc1dc6ff4227e6ef969cd50c
SHA512 (Python-3.7.0b2.tar.xz) = 15941cb2c14ad9fbabc6ff7085796ef7d44832bdffd4db662c8578732018154b0385408b28147dbaff1ad8f3158c1cc48d579898436842fc7101580e89503f7d