- update to 3.1.2: http://www.python.org/download/releases/3.1.2/
- drop upstreamed patch 2 (.pyc permissions handling) - drop upstream patch 5 (fix for the test_tk and test_ttk_* selftests) - drop upstreamed patch 200 (path-fixing script)
This commit is contained in:
parent
536a207750
commit
eeb0b9ba0c
@ -1,2 +1,2 @@
|
|||||||
Python-3.1.1.tar.bz2
|
|
||||||
libpython-36a517ef7848cbd0b3dcc7371f32e47ac4c87eba.tar.gz
|
libpython-36a517ef7848cbd0b3dcc7371f32e47ac4c87eba.tar.gz
|
||||||
|
Python-3.1.2.tar.bz2
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
--- Lib/importlib/_bootstrap.py.fix-handling-of-readonly-pyc-files 2009-10-22 15:24:57.575015046 -0400
|
|
||||||
+++ Lib/importlib/_bootstrap.py 2009-10-22 15:25:24.024016069 -0400
|
|
||||||
@@ -522,8 +522,8 @@ class _PyPycFileLoader(PyPycLoader, _PyF
|
|
||||||
bytecode_path = self.bytecode_path(name)
|
|
||||||
if not bytecode_path:
|
|
||||||
bytecode_path = self._base_path + _suffix_list(imp.PY_COMPILED)[0]
|
|
||||||
- file = _io.FileIO(bytecode_path, 'w') # Assuming bytes.
|
|
||||||
try:
|
|
||||||
+ file = _io.FileIO(bytecode_path, 'w') # Assuming bytes.
|
|
||||||
with _closing(file) as bytecode_file:
|
|
||||||
bytecode_file.write(data)
|
|
||||||
return True
|
|
@ -1,10 +0,0 @@
|
|||||||
--- Python-3.1.1/Makefile.pre.in.install-tkinter-tests 2009-10-27 20:00:09.814539776 -0400
|
|
||||||
+++ Python-3.1.1/Makefile.pre.in 2009-10-27 20:01:43.460549947 -0400
|
|
||||||
@@ -835,6 +835,7 @@ EXTRAPLATDIR= @EXTRAPLATDIR@
|
|
||||||
MACHDEPS= $(PLATDIR) $(EXTRAPLATDIR)
|
|
||||||
XMLLIBSUBDIRS= xml xml/dom xml/etree xml/parsers xml/sax
|
|
||||||
LIBSUBDIRS= tkinter site-packages test test/output test/data \
|
|
||||||
+ tkinter/test tkinter/test/test_ttk tkinter/test/test_tkinter \
|
|
||||||
test/decimaltestdata \
|
|
||||||
encodings \
|
|
||||||
email email/mime email/test email/test/data \
|
|
@ -1,61 +0,0 @@
|
|||||||
--- Python-3.1.1.orig/Tools/scripts/pathfix.py 2009-09-24 15:27:04.000000000 -0600
|
|
||||||
+++ Python-3.1.1/Tools/scripts/pathfix.py 2009-09-25 14:05:04.000000000 -0600
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#! /usr/bin/env python
|
|
||||||
+#!/usr/bin/env python3.1
|
|
||||||
|
|
||||||
# Change the #! line occurring in Python scripts. The new interpreter
|
|
||||||
# pathname must be given with a -i option.
|
|
||||||
@@ -43,8 +43,8 @@
|
|
||||||
sys.exit(2)
|
|
||||||
for o, a in opts:
|
|
||||||
if o == '-i':
|
|
||||||
- new_interpreter = a
|
|
||||||
- if not new_interpreter or new_interpreter[0] != '/' or not args:
|
|
||||||
+ new_interpreter = a.encode()
|
|
||||||
+ if not new_interpreter or new_interpreter[0] != b'/'[0] or not args:
|
|
||||||
err('-i option or file-or-directory missing\n')
|
|
||||||
err(usage)
|
|
||||||
sys.exit(2)
|
|
||||||
@@ -61,7 +61,7 @@
|
|
||||||
|
|
||||||
ispythonprog = re.compile('^[a-zA-Z0-9_]+\.py$')
|
|
||||||
def ispython(name):
|
|
||||||
- return ispythonprog.match(name) >= 0
|
|
||||||
+ return bool(ispythonprog.match(name))
|
|
||||||
|
|
||||||
def recursedown(dirname):
|
|
||||||
dbg('recursedown(%r)\n' % (dirname,))
|
|
||||||
@@ -88,7 +88,7 @@
|
|
||||||
def fix(filename):
|
|
||||||
## dbg('fix(%r)\n' % (filename,))
|
|
||||||
try:
|
|
||||||
- f = open(filename, 'r')
|
|
||||||
+ f = open(filename, 'rb')
|
|
||||||
except IOError as msg:
|
|
||||||
err('%s: cannot open: %r\n' % (filename, msg))
|
|
||||||
return 1
|
|
||||||
@@ -101,7 +101,7 @@
|
|
||||||
head, tail = os.path.split(filename)
|
|
||||||
tempname = os.path.join(head, '@' + tail)
|
|
||||||
try:
|
|
||||||
- g = open(tempname, 'w')
|
|
||||||
+ g = open(tempname, 'wb')
|
|
||||||
except IOError as msg:
|
|
||||||
f.close()
|
|
||||||
err('%s: cannot create: %r\n' % (tempname, msg))
|
|
||||||
@@ -139,11 +139,11 @@
|
|
||||||
return 0
|
|
||||||
|
|
||||||
def fixline(line):
|
|
||||||
- if not line.startswith('#!'):
|
|
||||||
+ if not line.startswith(b'#!'):
|
|
||||||
return line
|
|
||||||
- if "python" not in line:
|
|
||||||
+ if b"python" not in line:
|
|
||||||
return line
|
|
||||||
- return '#! %s\n' % new_interpreter
|
|
||||||
+ return b'#!' + new_interpreter + b'\n'
|
|
||||||
|
|
||||||
if __name__ == '__main__':
|
|
||||||
main()
|
|
29
python3.spec
29
python3.spec
@ -38,8 +38,8 @@
|
|||||||
|
|
||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.1
|
Version: %{pybasever}.2
|
||||||
Release: 28%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
||||||
@ -97,11 +97,6 @@ Patch0: python-3.1.1-config.patch
|
|||||||
# Was Patch0 in ivazquez' python3000 specfile:
|
# Was Patch0 in ivazquez' python3000 specfile:
|
||||||
Patch1: Python-3.1.1-rpath.patch
|
Patch1: Python-3.1.1-rpath.patch
|
||||||
|
|
||||||
# Fixup importlib/_bootstrap.py so that it correctly handles being unable to
|
|
||||||
# open .pyc files for writing
|
|
||||||
# Sent upstream as http://bugs.python.org/issue7187
|
|
||||||
Patch2: python-3.1.1-importlib-fix-handling-of-readonly-pyc-files.patch
|
|
||||||
|
|
||||||
# The four TestMIMEAudio tests fail due to "audiotest.au" not being packaged.
|
# The four TestMIMEAudio tests fail due to "audiotest.au" not being packaged.
|
||||||
# It's simplest to remove them:
|
# It's simplest to remove them:
|
||||||
Patch3: python-3.1.1-remove-mimeaudio-tests.patch
|
Patch3: python-3.1.1-remove-mimeaudio-tests.patch
|
||||||
@ -113,13 +108,6 @@ Patch3: python-3.1.1-remove-mimeaudio-tests.patch
|
|||||||
# the expected value in this test:
|
# the expected value in this test:
|
||||||
Patch4: python-3.1.1-apply-our-changes-to-expected-shebang-for-test_imp.patch
|
Patch4: python-3.1.1-apply-our-changes-to-expected-shebang-for-test_imp.patch
|
||||||
|
|
||||||
# test_tk test_ttk_guionly and test_ttk_textonly all rely on tkinter/test, but
|
|
||||||
# upstream's Makefile.pre.in doesn't install that subdirectory; patch it so that
|
|
||||||
# it does:
|
|
||||||
Patch5: python-3.1.1-install-tkinter-tests.patch
|
|
||||||
# (The resulting test support code is in the tkinter subpackage, but
|
|
||||||
# this is not a major problem)
|
|
||||||
|
|
||||||
# Patch the Makefile.pre.in so that the generated Makefile doesn't try to build
|
# Patch the Makefile.pre.in so that the generated Makefile doesn't try to build
|
||||||
# a libpythonMAJOR.MINOR.a (bug 550692):
|
# a libpythonMAJOR.MINOR.a (bug 550692):
|
||||||
Patch6: python-3.1.1-no-static-lib.patch
|
Patch6: python-3.1.1-no-static-lib.patch
|
||||||
@ -137,9 +125,6 @@ Patch8: python-3.1.1-systemtap.patch
|
|||||||
|
|
||||||
Patch102: python-3.1.1-lib64.patch
|
Patch102: python-3.1.1-lib64.patch
|
||||||
|
|
||||||
# http://bugs.python.org/issue6999 -- fixed in r75062
|
|
||||||
Patch200: python-3.1.1-pathfix.patch
|
|
||||||
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildRequires: readline-devel, openssl-devel, gmp-devel
|
BuildRequires: readline-devel, openssl-devel, gmp-devel
|
||||||
@ -252,10 +237,8 @@ rm -r Modules/zlib || exit 1
|
|||||||
#
|
#
|
||||||
%patch0 -p1 -b .config
|
%patch0 -p1 -b .config
|
||||||
%patch1 -p1 -b .rpath
|
%patch1 -p1 -b .rpath
|
||||||
%patch2 -p0 -b .fix-handling-of-readonly-pyc-files
|
|
||||||
%patch3 -p1 -b .remove-mimeaudio-tests
|
%patch3 -p1 -b .remove-mimeaudio-tests
|
||||||
%patch4 -p1 -b .apply-our-changes-to-expected-shebang
|
%patch4 -p1 -b .apply-our-changes-to-expected-shebang
|
||||||
%patch5 -p1 -b .install-tkinter-tests
|
|
||||||
%patch6 -p1 -b .no-static-lib
|
%patch6 -p1 -b .no-static-lib
|
||||||
%patch7 -p1 -b .expat
|
%patch7 -p1 -b .expat
|
||||||
%if 0%{?with_systemtap}
|
%if 0%{?with_systemtap}
|
||||||
@ -266,8 +249,6 @@ rm -r Modules/zlib || exit 1
|
|||||||
%patch102 -p1 -b .lib64
|
%patch102 -p1 -b .lib64
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch200 -p1 -b .pathfix
|
|
||||||
|
|
||||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||||
# are many differences between 2.6 and the Python 3 library.
|
# are many differences between 2.6 and the Python 3 library.
|
||||||
#
|
#
|
||||||
@ -719,6 +700,12 @@ rm -fr %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 21 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-1
|
||||||
|
- update to 3.1.2: http://www.python.org/download/releases/3.1.2/
|
||||||
|
- drop upstreamed patch 2 (.pyc permissions handling)
|
||||||
|
- drop upstream patch 5 (fix for the test_tk and test_ttk_* selftests)
|
||||||
|
- drop upstreamed patch 200 (path-fixing script)
|
||||||
|
|
||||||
* Sat Mar 20 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.1-28
|
* Sat Mar 20 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.1-28
|
||||||
- fix typo in libpython.stp (rhbz:575336)
|
- fix typo in libpython.stp (rhbz:575336)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
d1ddd9f16e3c6a51c7208f33518cd674 Python-3.1.1.tar.bz2
|
|
||||||
e9b2198d72a406698c8de07467654204 libpython-36a517ef7848cbd0b3dcc7371f32e47ac4c87eba.tar.gz
|
e9b2198d72a406698c8de07467654204 libpython-36a517ef7848cbd0b3dcc7371f32e47ac4c87eba.tar.gz
|
||||||
|
45350b51b58a46b029fb06c61257e350 Python-3.1.2.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user