Update to Python 3.6.0 final
Remove patch 250 as it is now upstream Upload the 3.6.0 final sources
This commit is contained in:
parent
eefe139416
commit
e79e900d64
@ -1,25 +0,0 @@
|
|||||||
|
|
||||||
# HG changeset patch
|
|
||||||
# User Benjamin Peterson <benjamin@python.org>
|
|
||||||
# Date 1481183668 28800
|
|
||||||
# Node ID 4745d801cae2d57e3432313acd0b76b8b4cc9c75
|
|
||||||
# Parent 148c46d180b2a1510097a1eae79845b61190c879
|
|
||||||
guard HAVE_LONG_LONG definition to prevent redefinition (#28898)
|
|
||||||
|
|
||||||
diff --git a/Include/pyport.h b/Include/pyport.h
|
|
||||||
--- a/Include/pyport.h
|
|
||||||
+++ b/Include/pyport.h
|
|
||||||
@@ -37,9 +37,10 @@ Used in: Py_SAFE_DOWNCAST
|
|
||||||
* integral synonyms. Only define the ones we actually need.
|
|
||||||
*/
|
|
||||||
|
|
||||||
-// long long is required now. Define HAVE_LONG_LONG unconditionally for
|
|
||||||
-// compatibility.
|
|
||||||
+// long long is required. Ensure HAVE_LONG_LONG is defined for compatibility.
|
|
||||||
+#ifndef HAVE_LONG_LONG
|
|
||||||
#define HAVE_LONG_LONG
|
|
||||||
+#endif
|
|
||||||
#ifndef PY_LONG_LONG
|
|
||||||
#define PY_LONG_LONG long long
|
|
||||||
/* If LLONG_MAX is defined in limits.h, use that. */
|
|
||||||
|
|
17
python3.spec
17
python3.spec
@ -24,8 +24,6 @@
|
|||||||
# Currently these packages are recommended to have been built before a targeted rebuild after a python abi change:
|
# Currently these packages are recommended to have been built before a targeted rebuild after a python abi change:
|
||||||
# python-sphinx, pytest, python-requests, cloud-init, dnf, anaconda, abrt.
|
# python-sphinx, pytest, python-requests, cloud-init, dnf, anaconda, abrt.
|
||||||
|
|
||||||
# First release candidate
|
|
||||||
%global prerel rc1
|
|
||||||
|
|
||||||
%global with_rewheel 1
|
%global with_rewheel 1
|
||||||
|
|
||||||
@ -126,7 +124,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.0
|
Version: %{pybasever}.0
|
||||||
Release: 0.6.%{?prerel}%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
|
|
||||||
@ -193,7 +191,7 @@ BuildRequires: python3-pip
|
|||||||
# Source code and patches
|
# Source code and patches
|
||||||
# =======================
|
# =======================
|
||||||
|
|
||||||
Source: https://www.python.org/ftp/python/%{version}/Python-%{version}%{prerel}.tar.xz
|
Source: https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
|
||||||
|
|
||||||
# Supply an RPM macro "py_byte_compile" for the python3-devel subpackage
|
# Supply an RPM macro "py_byte_compile" for the python3-devel subpackage
|
||||||
# to enable specfiles to selectively byte-compile individual files and paths
|
# to enable specfiles to selectively byte-compile individual files and paths
|
||||||
@ -404,13 +402,6 @@ Patch243: 00243-fix-mips64-triplet.patch
|
|||||||
# Not yet fixed upstream: http://bugs.python.org/issue28787
|
# Not yet fixed upstream: http://bugs.python.org/issue28787
|
||||||
Patch249: 00249-fix-out-of-tree-dtrace-builds.patch
|
Patch249: 00249-fix-out-of-tree-dtrace-builds.patch
|
||||||
|
|
||||||
# 00250 #
|
|
||||||
# Guard HAVE_LONG_LONG definition in pyport.h as gdb also sets this
|
|
||||||
# and by defining it unconditionally in python will make compilation of
|
|
||||||
# gdb to fail.
|
|
||||||
# FIXED UPSTREAM: http://bugs.python.org/issue28898
|
|
||||||
Patch250: 00250-guard-HAVE_LONG_LONG-definition-to-prevent-redefinition.patch
|
|
||||||
|
|
||||||
# (New patches go here ^^^)
|
# (New patches go here ^^^)
|
||||||
#
|
#
|
||||||
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
|
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
|
||||||
@ -648,7 +639,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
|||||||
%patch206 -p1
|
%patch206 -p1
|
||||||
%patch243 -p1
|
%patch243 -p1
|
||||||
%patch249 -p1
|
%patch249 -p1
|
||||||
%patch250 -p1
|
|
||||||
|
|
||||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||||
# are many differences between 2.6 and the Python 3 library.
|
# are many differences between 2.6 and the Python 3 library.
|
||||||
@ -1567,6 +1557,9 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 27 2016 Charalampos Stratakis <cstratak@redhat.com> - 3.6.0-1
|
||||||
|
- Update to Python 3.6.0 final
|
||||||
|
|
||||||
* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 3.6.0-0.6.rc1
|
* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 3.6.0-0.6.rc1
|
||||||
- Enable rewheel
|
- Enable rewheel
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user