Update to 3.5.1, remove unused patches (199, 207)
This commit is contained in:
parent
bbc4c0dbf7
commit
e248727c4f
@ -667,9 +667,9 @@ diff -up Python-3.3.0rc2/Makefile.pre.in.systemtap Python-3.3.0rc2/Makefile.pre.
|
|||||||
# Header files
|
# Header files
|
||||||
|
|
||||||
@@ -1345,6 +1354,7 @@ clean: pycremoval
|
@@ -1345,6 +1354,7 @@ clean: pycremoval
|
||||||
-rm -f pybuilddir.txt
|
|
||||||
-rm -f Lib/lib2to3/*Grammar*.pickle
|
-rm -f Lib/lib2to3/*Grammar*.pickle
|
||||||
-rm -f Programs/_testembed Programs/_freeze_importlib
|
-rm -f Programs/_testembed Programs/_freeze_importlib
|
||||||
|
-rm -rf build
|
||||||
+ -rm -f $(srcdir)/Python/pysystemtap.h
|
+ -rm -f $(srcdir)/Python/pysystemtap.h
|
||||||
|
|
||||||
profile-removal:
|
profile-removal:
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
diff -up Python-3.4.2/Lib/test/test_ssl.py.ssl Python-3.4.2/Lib/test/test_ssl.py
|
|
||||||
--- Python-3.4.2/Lib/test/test_ssl.py.ssl 2014-12-11 12:25:21.886928225 +0100
|
|
||||||
+++ Python-3.4.2/Lib/test/test_ssl.py 2014-12-11 12:25:00.284746529 +0100
|
|
||||||
@@ -674,10 +674,7 @@ class ContextTests(unittest.TestCase):
|
|
||||||
@skip_if_broken_ubuntu_ssl
|
|
||||||
def test_options(self):
|
|
||||||
ctx = ssl.SSLContext(ssl.PROTOCOL_TLSv1)
|
|
||||||
- # OP_ALL | OP_NO_SSLv2 is the default value
|
|
||||||
- self.assertEqual(ssl.OP_ALL | ssl.OP_NO_SSLv2,
|
|
||||||
- ctx.options)
|
|
||||||
- ctx.options |= ssl.OP_NO_SSLv3
|
|
||||||
+ # OP_ALL | OP_NO_SSLv2 | OP_NO_SSLv3 is the default value
|
|
||||||
self.assertEqual(ssl.OP_ALL | ssl.OP_NO_SSLv2 | ssl.OP_NO_SSLv3,
|
|
||||||
ctx.options)
|
|
||||||
if can_clear_options():
|
|
||||||
@@ -2186,7 +2180,7 @@ else:
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv3, ssl.PROTOCOL_TLSv1, False)
|
|
||||||
if no_sslv2_implies_sslv3_hello():
|
|
||||||
# No SSLv2 => client will use an SSLv3 hello on recent OpenSSLs
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv3, ssl.PROTOCOL_SSLv23, 'SSLv3',
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv3, ssl.PROTOCOL_SSLv23, False,
|
|
||||||
client_options=ssl.OP_NO_SSLv2)
|
|
||||||
|
|
||||||
@skip_if_broken_ubuntu_ssl
|
|
||||||
diff -up Python-3.4.3/Lib/test/test_ssl.py.foo Python-3.4.3/Lib/test/test_ssl.py
|
|
||||||
--- Python-3.4.3/Lib/test/test_ssl.py.foo 2015-03-12 10:08:58.268065970 +0100
|
|
||||||
+++ Python-3.4.3/Lib/test/test_ssl.py 2015-03-12 10:10:09.733347118 +0100
|
|
||||||
@@ -2168,17 +2168,17 @@ else:
|
|
||||||
" SSL2 client to SSL23 server test unexpectedly failed:\n %s\n"
|
|
||||||
% str(x))
|
|
||||||
if hasattr(ssl, 'PROTOCOL_SSLv3'):
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, 'SSLv3')
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, False)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv23, True)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_TLSv1, 'TLSv1')
|
|
||||||
|
|
||||||
if hasattr(ssl, 'PROTOCOL_SSLv3'):
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, 'SSLv3', ssl.CERT_OPTIONAL)
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, False, ssl.CERT_OPTIONAL)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv23, True, ssl.CERT_OPTIONAL)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_TLSv1, 'TLSv1', ssl.CERT_OPTIONAL)
|
|
||||||
|
|
||||||
if hasattr(ssl, 'PROTOCOL_SSLv3'):
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, 'SSLv3', ssl.CERT_REQUIRED)
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, False, ssl.CERT_REQUIRED)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv23, True, ssl.CERT_REQUIRED)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_TLSv1, 'TLSv1', ssl.CERT_REQUIRED)
|
|
||||||
|
|
@ -1,63 +0,0 @@
|
|||||||
|
|
||||||
# HG changeset patch
|
|
||||||
# User Victor Stinner <victor.stinner@gmail.com>
|
|
||||||
# Date 1442581594 -7200
|
|
||||||
# Node ID d4fcb362f7c66b25b22ddc0d27db0cc96acc727b
|
|
||||||
# Parent d04a0954e142f873adee88ec5bc1c1d81cd46bc4
|
|
||||||
Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
|
|
||||||
Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
|
|
||||||
becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
|
|
||||||
|
|
||||||
It is important that the _PyThreadState_Current variable is always accessed
|
|
||||||
with the same implementation of pyatomic.h. Use the PyThreadState_Get()
|
|
||||||
function so extension modules will all reuse the same implementation.
|
|
||||||
|
|
||||||
diff --git a/Include/pyatomic.h b/Include/pyatomic.h
|
|
||||||
--- a/Include/pyatomic.h
|
|
||||||
+++ b/Include/pyatomic.h
|
|
||||||
@@ -1,8 +1,6 @@
|
|
||||||
-/* Issue #23644: <stdatomic.h> is incompatible with C++, see:
|
|
||||||
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 */
|
|
||||||
-#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
|
|
||||||
#ifndef Py_ATOMIC_H
|
|
||||||
#define Py_ATOMIC_H
|
|
||||||
+#ifdef Py_BUILD_CORE
|
|
||||||
|
|
||||||
#include "dynamic_annotations.h"
|
|
||||||
|
|
||||||
@@ -248,5 +246,5 @@ static __inline__ void
|
|
||||||
#define _Py_atomic_load_relaxed(ATOMIC_VAL) \
|
|
||||||
_Py_atomic_load_explicit(ATOMIC_VAL, _Py_memory_order_relaxed)
|
|
||||||
|
|
||||||
+#endif /* Py_BUILD_CORE */
|
|
||||||
#endif /* Py_ATOMIC_H */
|
|
||||||
-#endif /* Py_LIMITED_API */
|
|
||||||
diff --git a/Include/pystate.h b/Include/pystate.h
|
|
||||||
--- a/Include/pystate.h
|
|
||||||
+++ b/Include/pystate.h
|
|
||||||
@@ -177,20 +177,13 @@ PyAPI_FUNC(int) PyThreadState_SetAsyncEx
|
|
||||||
/* Variable and macro for in-line access to current thread state */
|
|
||||||
|
|
||||||
/* Assuming the current thread holds the GIL, this is the
|
|
||||||
- PyThreadState for the current thread.
|
|
||||||
-
|
|
||||||
- Issue #23644: pyatomic.h is incompatible with C++ (yet). Disable
|
|
||||||
- PyThreadState_GET() optimization: declare it as an alias to
|
|
||||||
- PyThreadState_Get(), as done for limited API. */
|
|
||||||
-#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
|
|
||||||
+ PyThreadState for the current thread. */
|
|
||||||
+#ifdef Py_BUILD_CORE
|
|
||||||
PyAPI_DATA(_Py_atomic_address) _PyThreadState_Current;
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
-#if defined(Py_DEBUG) || defined(Py_LIMITED_API) || defined(__cplusplus)
|
|
||||||
-#define PyThreadState_GET() PyThreadState_Get()
|
|
||||||
+# define PyThreadState_GET() \
|
|
||||||
+ ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
|
|
||||||
#else
|
|
||||||
-#define PyThreadState_GET() \
|
|
||||||
- ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
|
|
||||||
+# define PyThreadState_GET() PyThreadState_Get()
|
|
||||||
#endif
|
|
||||||
|
|
||||||
typedef
|
|
20
python3.spec
20
python3.spec
@ -111,8 +111,8 @@
|
|||||||
# ==================
|
# ==================
|
||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.0
|
Version: %{pybasever}.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
|
|
||||||
@ -441,11 +441,6 @@ Patch194: temporarily-disable-tests-requiring-SIGHUP.patch
|
|||||||
# Fix test_gdb failure on ppc64le
|
# Fix test_gdb failure on ppc64le
|
||||||
Patch196: 00196-test-gdb-match-addr-before-builtin.patch
|
Patch196: 00196-test-gdb-match-addr-before-builtin.patch
|
||||||
|
|
||||||
# OpenSSL disabled SSLv3 in SSLv23 method
|
|
||||||
# This patch alters python tests to reflect this change
|
|
||||||
# Issue: http://bugs.python.org/issue22638 Upstream discussion about SSLv3 in Python
|
|
||||||
Patch199: 00199-alter-tests-to-reflect-sslv3-disabled.patch
|
|
||||||
|
|
||||||
# 00200 #
|
# 00200 #
|
||||||
# Fix for gettext plural form headers (lines that begin with "#")
|
# Fix for gettext plural form headers (lines that begin with "#")
|
||||||
# Note: Backported from scl
|
# Note: Backported from scl
|
||||||
@ -469,11 +464,6 @@ Patch205: 00205-make-libpl-respect-lib64.patch
|
|||||||
# by debian but fedora infra uses only eabi without hf
|
# by debian but fedora infra uses only eabi without hf
|
||||||
Patch206: 00206-remove-hf-from-arm-triplet.patch
|
Patch206: 00206-remove-hf-from-arm-triplet.patch
|
||||||
|
|
||||||
# https://bugs.python.org/issue25150
|
|
||||||
# Hide the private _Py_atomic_xxx symbols from the public
|
|
||||||
# Python.h header to fix a compilation error with OpenMP.
|
|
||||||
Patch207: 00207-hide-atomic-symbols.patch
|
|
||||||
|
|
||||||
# add correct arch for ppc64/ppc64le
|
# add correct arch for ppc64/ppc64le
|
||||||
# it should be ppc64le-linux-gnu/ppc64-linux-gnu instead powerpc64le-linux-gnu/powerpc64-linux-gnu
|
# it should be ppc64le-linux-gnu/ppc64-linux-gnu instead powerpc64le-linux-gnu/powerpc64-linux-gnu
|
||||||
Patch5001: python3-powerppc-arch.patch
|
Patch5001: python3-powerppc-arch.patch
|
||||||
@ -686,11 +676,9 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
|||||||
|
|
||||||
%patch194 -p1
|
%patch194 -p1
|
||||||
%patch196 -p1
|
%patch196 -p1
|
||||||
%patch199 -p1
|
|
||||||
%patch203 -p1
|
%patch203 -p1
|
||||||
%patch205 -p1
|
%patch205 -p1
|
||||||
%patch206 -p1
|
%patch206 -p1
|
||||||
%patch207 -p1
|
|
||||||
|
|
||||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||||
# are many differences between 2.6 and the Python 3 library.
|
# are many differences between 2.6 and the Python 3 library.
|
||||||
@ -1563,6 +1551,10 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 14 2015 Robert Kuska <rkuska@redhat.com> - 3.5.1-1
|
||||||
|
- Update to 3.5.1
|
||||||
|
- Removed patch 199 and 207 (upstream)
|
||||||
|
|
||||||
* Sun Nov 15 2015 Robert Kuska <rkuska@redhat.com> - 3.5.0-5
|
* Sun Nov 15 2015 Robert Kuska <rkuska@redhat.com> - 3.5.0-5
|
||||||
- Remove versioned libpython from devel package
|
- Remove versioned libpython from devel package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user