Rebased to Python 3.9.0a2

No patches changes since 3.9.0a1.
This commit is contained in:
Miro Hrončok 2019-12-19 12:25:44 +01:00
parent 620353def6
commit d33516835b
9 changed files with 30 additions and 27 deletions

View File

@ -1,4 +1,4 @@
From dd253c4f803a5dfa2ba7dfdb01b722e47c2b02e8 Mon Sep 17 00:00:00 2001
From 5dd33e789d3b70d5021cbceed61494110bbe1540 Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Wed, 13 Jan 2010 21:25:18 +0000
Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
@ -29,5 +29,5 @@ index d10a78da31..4df4b67810 100644
include_dirs=None, extra_preargs=None, extra_postargs=None):
fixed_args = self._fix_compile_args(None, macros, include_dirs)
--
2.23.0
2.24.1

View File

@ -1,4 +1,4 @@
From 25fcefdafb47ee30f4dc802742f49e501d7b2f37 Mon Sep 17 00:00:00 2001
From 19b5b3386f16f53e34b9d37e400b655dbfe912e8 Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Wed, 13 Jan 2010 21:25:18 +0000
Subject: [PATCH] 00102: Change the various install paths to use /usr/lib64/
@ -87,7 +87,7 @@ index 287ab1989e..d4c05e0ab1 100644
check_path(cmd.install_headers,
os.path.join(destination, "include", "python", "foopkg"))
diff --git a/Lib/site.py b/Lib/site.py
index a065ab0b5d..22d53fa562 100644
index 2c71798755..653c1d7203 100644
--- a/Lib/site.py
+++ b/Lib/site.py
@@ -335,11 +335,15 @@ def getsitepackages(prefixes=None):
@ -107,7 +107,7 @@ index a065ab0b5d..22d53fa562 100644
return sitepackages
diff --git a/Lib/sysconfig.py b/Lib/sysconfig.py
index b9e2fafbc0..0ae6d35b69 100644
index 64cf1560d9..f66314b203 100644
--- a/Lib/sysconfig.py
+++ b/Lib/sysconfig.py
@@ -20,10 +20,10 @@ __all__ = [
@ -198,10 +198,10 @@ index 8632d1fe6d..09a818609e 100644
return DECODE_LOCALE_ERR("EXEC_PREFIX macro", len);
}
diff --git a/configure b/configure
index 44f14c3c2c..020531594c 100755
index a2c7ddf595..966a6cae2e 100755
--- a/configure
+++ b/configure
@@ -15192,9 +15192,9 @@ fi
@@ -15205,9 +15205,9 @@ fi
if test x$PLATFORM_TRIPLET = x; then
@ -214,10 +214,10 @@ index 44f14c3c2c..020531594c 100755
diff --git a/configure.ac b/configure.ac
index 0b28dda44c..4fca719c71 100644
index 57dca35723..7ba091ebf2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4679,9 +4679,9 @@ fi
@@ -4689,9 +4689,9 @@ fi
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
AC_SUBST(PY_ENABLE_SHARED)
if test x$PLATFORM_TRIPLET = x; then
@ -257,5 +257,5 @@ index 02f523c42d..559498d14b 100644
libraries=readline_libs))
else:
--
2.23.0
2.24.1

View File

@ -1,4 +1,4 @@
From 796f2a2d1f213e963768e7c987fb49f8c4f47dfa Mon Sep 17 00:00:00 2001
From f7580af0bf9870c81366613213d4268ef00bff5a Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Mon, 18 Jan 2010 17:59:07 +0000
Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
@ -74,5 +74,5 @@ index 4d2f68447d..3cd2f25571 100644
$(INSTALL_DATA) Programs/python.o $(DESTDIR)$(LIBPL)/python.o
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
--
2.23.0
2.24.1

View File

@ -1,4 +1,4 @@
From dad501bdd3ee8d8e22f66416998aeb50c0e7983e Mon Sep 17 00:00:00 2001
From f85b612b86a1e688685fc2f908b50e13d75114bc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Wed, 15 Aug 2018 15:36:29 +0200
Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
@ -63,5 +63,5 @@ index 386ed6c25c..19e7c8787e 100644
additional_paths.append(os.path.join(tmpdir, wheel_name))
--
2.23.0
2.24.1

View File

@ -1,4 +1,4 @@
From 7438360d65b2e000440d7ee126f32d2500dbd82c Mon Sep 17 00:00:00 2001
From d2eb8a55c088caf1bf48e9d998fbc514b820ad6c Mon Sep 17 00:00:00 2001
From: Michal Cyprian <m.cyprian@gmail.com>
Date: Mon, 26 Jun 2017 16:32:56 +0200
Subject: [PATCH] 00251: Change user install location
@ -40,7 +40,7 @@ index ae4f915669..0e4fd5b74a 100644
else:
if self.exec_prefix is None:
diff --git a/Lib/site.py b/Lib/site.py
index 22d53fa562..9513526109 100644
index 653c1d7203..9098f5762f 100644
--- a/Lib/site.py
+++ b/Lib/site.py
@@ -348,7 +348,14 @@ def getsitepackages(prefixes=None):
@ -60,5 +60,5 @@ index 22d53fa562..9513526109 100644
if os.path.isdir(sitedir):
addsitedir(sitedir, known_paths)
--
2.23.0
2.24.1

View File

@ -1,4 +1,4 @@
From 607b2e6099745b2c8c0d55d258ade620e6c35dbd Mon Sep 17 00:00:00 2001
From 29524bf73ef1d39e21dff0c60f8ff76bd36549cb Mon Sep 17 00:00:00 2001
From: Petr Viktorin <pviktori@redhat.com>
Date: Mon, 28 Aug 2017 17:16:46 +0200
Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
@ -29,7 +29,7 @@ index ba37cf99e2..52a9ec6662 100755
ppc64le | powerpc64little)
basic_machine=powerpc64le-unknown
diff --git a/configure.ac b/configure.ac
index 4fca719c71..3d06f82981 100644
index 7ba091ebf2..05a2568f56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -741,9 +741,9 @@ cat >> conftest.c <<EOF
@ -82,5 +82,5 @@ index 4fca719c71..3d06f82981 100644
s390x-linux-gnu
# elif defined(__s390__)
--
2.23.0
2.24.1

View File

@ -1,4 +1,4 @@
From 4c5bee74ff3d4033a60359640bac9f156fdf50ed Mon Sep 17 00:00:00 2001
From d1beb7fb4f912a4beaa2b993919e6d6d019d900d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Thu, 11 Jul 2019 13:44:13 +0200
Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default
@ -31,7 +31,7 @@ index 21736896af..310bed5620 100644
else:
return PycInvalidationMode.TIMESTAMP
diff --git a/Lib/test/test_py_compile.py b/Lib/test/test_py_compile.py
index d6677ab45f..88059b127e 100644
index d4a68c9320..ed09874023 100644
--- a/Lib/test/test_py_compile.py
+++ b/Lib/test/test_py_compile.py
@@ -17,6 +17,7 @@ def without_source_date_epoch(fxn):
@ -51,5 +51,5 @@ index d6677ab45f..88059b127e 100644
return wrapper
--
2.23.0
2.24.1

View File

@ -14,10 +14,10 @@ URL: https://www.python.org/
# WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well
%global general_version %{pybasever}.0
%global prerel a1
%global prerel a2
%global upstream_version %{general_version}%{?prerel}
Version: %{general_version}%{?prerel:~%{prerel}}
Release: 3%{?dist}
Release: 1%{?dist}
License: Python
@ -1565,6 +1565,9 @@ CheckPython optimized
# ======================================================
%changelog
* Thu Dec 19 2019 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~a2-1
- Rebased to Python 3.9.0a2
* Wed Dec 04 2019 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~a1-3
- Build Python with -fno-semantic-interposition for better performance
- https://fedoraproject.org/wiki/Changes/PythonNoSemanticInterpositionSpeedup

View File

@ -1,2 +1,2 @@
SHA512 (Python-3.9.0a1.tar.xz) = 5880ba1707718dbd21926956faebef3e454b7dae15c880f96140deaff571765a760baa17ca109949b7f70f12c999660ab0071f231f58727e232739d026895e91
SHA512 (Python-3.9.0a1.tar.xz.asc) = 5c4f31abca1c20be4b7592c97c1fe99ccc3ce494d8905a4aa6d2c96d59207ce7dd6630364a2fe03c9f37c755279c5e3078cba587ccebe165924d2456015d686c
SHA512 (Python-3.9.0a2.tar.xz) = 3f17869f3ca4db423f66e145e67c9fb4935d8c908c5362de585898343190edb901861701e27ab9187a287880ee42bbb4897aa298967c1862f44b12dbab19d412
SHA512 (Python-3.9.0a2.tar.xz.asc) = 24dc11f516bfc06955742d420b01367330b5b281d6d2292c173ed0e72221004ac3638c98ad6ed36deaaa4ecbaa53d75850a1811153edb94000389429c97cf2b3