Update to 3.10.0a4
This commit is contained in:
parent
eb9dd45945
commit
d059157127
@ -9,7 +9,7 @@ Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
|||||||
1 file changed, 9 insertions(+)
|
1 file changed, 9 insertions(+)
|
||||||
|
|
||||||
diff --git a/Lib/distutils/unixccompiler.py b/Lib/distutils/unixccompiler.py
|
diff --git a/Lib/distutils/unixccompiler.py b/Lib/distutils/unixccompiler.py
|
||||||
index 4d7a6de740..353086a648 100644
|
index f0792de74a..4d837936c6 100644
|
||||||
--- a/Lib/distutils/unixccompiler.py
|
--- a/Lib/distutils/unixccompiler.py
|
||||||
+++ b/Lib/distutils/unixccompiler.py
|
+++ b/Lib/distutils/unixccompiler.py
|
||||||
@@ -82,6 +82,15 @@ class UnixCCompiler(CCompiler):
|
@@ -82,6 +82,15 @@ class UnixCCompiler(CCompiler):
|
||||||
|
@ -21,7 +21,7 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
|||||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||||
index a8912cd418..06ca6bb87f 100644
|
index d8b9e8498d..5f4fbe6eb4 100644
|
||||||
--- a/Makefile.pre.in
|
--- a/Makefile.pre.in
|
||||||
+++ b/Makefile.pre.in
|
+++ b/Makefile.pre.in
|
||||||
@@ -576,7 +576,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
@@ -576,7 +576,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||||
@ -55,7 +55,7 @@ index a8912cd418..06ca6bb87f 100644
|
|||||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||||
|
|
||||||
############################################################################
|
############################################################################
|
||||||
@@ -1604,17 +1598,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
@@ -1647,17 +1641,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||||
else true; \
|
else true; \
|
||||||
fi; \
|
fi; \
|
||||||
done
|
done
|
||||||
|
@ -21,7 +21,7 @@ index cb2882e336..984e587ea0 100644
|
|||||||
import os
|
import os
|
||||||
import os.path
|
import os.path
|
||||||
import sys
|
import sys
|
||||||
@@ -6,16 +8,28 @@ import tempfile
|
@@ -6,16 +8,28 @@
|
||||||
import subprocess
|
import subprocess
|
||||||
from importlib import resources
|
from importlib import resources
|
||||||
|
|
||||||
|
@ -15,10 +15,10 @@ Downstream only: Awaiting resources to work on upstream PEP
|
|||||||
2 files changed, 21 insertions(+), 3 deletions(-)
|
2 files changed, 21 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/Lib/distutils/command/install.py b/Lib/distutils/command/install.py
|
diff --git a/Lib/distutils/command/install.py b/Lib/distutils/command/install.py
|
||||||
index aaa300efa9..f8d453912a 100644
|
index bdead133bd..274ca6d340 100644
|
||||||
--- a/Lib/distutils/command/install.py
|
--- a/Lib/distutils/command/install.py
|
||||||
+++ b/Lib/distutils/command/install.py
|
+++ b/Lib/distutils/command/install.py
|
||||||
@@ -419,8 +419,19 @@ class install(Command):
|
@@ -422,8 +422,19 @@ def finalize_unix(self):
|
||||||
raise DistutilsOptionError(
|
raise DistutilsOptionError(
|
||||||
"must not supply exec-prefix without prefix")
|
"must not supply exec-prefix without prefix")
|
||||||
|
|
||||||
@ -41,10 +41,10 @@ index aaa300efa9..f8d453912a 100644
|
|||||||
else:
|
else:
|
||||||
if self.exec_prefix is None:
|
if self.exec_prefix is None:
|
||||||
diff --git a/Lib/site.py b/Lib/site.py
|
diff --git a/Lib/site.py b/Lib/site.py
|
||||||
index 4d3b869fff..aee20de308 100644
|
index 5f1b31e73d..3e97724131 100644
|
||||||
--- a/Lib/site.py
|
--- a/Lib/site.py
|
||||||
+++ b/Lib/site.py
|
+++ b/Lib/site.py
|
||||||
@@ -364,8 +364,15 @@ def getsitepackages(prefixes=None):
|
@@ -378,8 +378,15 @@ def getsitepackages(prefixes=None):
|
||||||
return sitepackages
|
return sitepackages
|
||||||
|
|
||||||
def addsitepackages(known_paths, prefixes=None):
|
def addsitepackages(known_paths, prefixes=None):
|
||||||
|
@ -14,7 +14,7 @@ URL: https://www.python.org/
|
|||||||
# WARNING When rebasing to a new Python version,
|
# WARNING When rebasing to a new Python version,
|
||||||
# remember to update the python3-docs package as well
|
# remember to update the python3-docs package as well
|
||||||
%global general_version %{pybasever}.0
|
%global general_version %{pybasever}.0
|
||||||
%global prerel a3
|
%global prerel a4
|
||||||
%global upstream_version %{general_version}%{?prerel}
|
%global upstream_version %{general_version}%{?prerel}
|
||||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
@ -1252,6 +1252,7 @@ CheckPython optimized
|
|||||||
%{dynload_dir}/unicodedata.%{SOABI_optimized}.so
|
%{dynload_dir}/unicodedata.%{SOABI_optimized}.so
|
||||||
%{dynload_dir}/_uuid.%{SOABI_optimized}.so
|
%{dynload_dir}/_uuid.%{SOABI_optimized}.so
|
||||||
%{dynload_dir}/xxlimited.%{SOABI_optimized}.so
|
%{dynload_dir}/xxlimited.%{SOABI_optimized}.so
|
||||||
|
%{dynload_dir}/xxlimited_35.%{SOABI_optimized}.so
|
||||||
%{dynload_dir}/_xxsubinterpreters.%{SOABI_optimized}.so
|
%{dynload_dir}/_xxsubinterpreters.%{SOABI_optimized}.so
|
||||||
%{dynload_dir}/zlib.%{SOABI_optimized}.so
|
%{dynload_dir}/zlib.%{SOABI_optimized}.so
|
||||||
%{dynload_dir}/_zoneinfo.%{SOABI_optimized}.so
|
%{dynload_dir}/_zoneinfo.%{SOABI_optimized}.so
|
||||||
@ -1533,6 +1534,8 @@ CheckPython optimized
|
|||||||
%{dynload_dir}/termios.%{SOABI_debug}.so
|
%{dynload_dir}/termios.%{SOABI_debug}.so
|
||||||
%{dynload_dir}/unicodedata.%{SOABI_debug}.so
|
%{dynload_dir}/unicodedata.%{SOABI_debug}.so
|
||||||
%{dynload_dir}/_uuid.%{SOABI_debug}.so
|
%{dynload_dir}/_uuid.%{SOABI_debug}.so
|
||||||
|
%{dynload_dir}/xxlimited.%{SOABI_debug}.so
|
||||||
|
%{dynload_dir}/xxlimited_35.%{SOABI_debug}.so
|
||||||
%{dynload_dir}/_xxsubinterpreters.%{SOABI_debug}.so
|
%{dynload_dir}/_xxsubinterpreters.%{SOABI_debug}.so
|
||||||
%{dynload_dir}/_xxtestfuzz.%{SOABI_debug}.so
|
%{dynload_dir}/_xxtestfuzz.%{SOABI_debug}.so
|
||||||
%{dynload_dir}/zlib.%{SOABI_debug}.so
|
%{dynload_dir}/zlib.%{SOABI_debug}.so
|
||||||
@ -1592,6 +1595,9 @@ CheckPython optimized
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 04 2021 Miro Hrončok <mhroncok@redhat.com> - 3.10.0~a4-1
|
||||||
|
- Update to 3.10.0a4
|
||||||
|
|
||||||
* Tue Dec 08 2020 Tomas Hrnciar <thrnciar@redhat.com> - 3.10.0~a3-1
|
* Tue Dec 08 2020 Tomas Hrnciar <thrnciar@redhat.com> - 3.10.0~a3-1
|
||||||
- Update to 3.10.0a3
|
- Update to 3.10.0a3
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (Python-3.10.0a3.tar.xz) = a361c04081e9bd7e740c3311d92ec1428f12c589613ab39ed2bb1ac5aa20e4d8bc6d6e76eefc20edd459ecf8be1720f3985126be38407fcfb41f5a6efcea3998
|
SHA512 (Python-3.10.0a4.tar.xz) = 2bf756e581315a7f242683931bffb275edcd5d864b8242e3de42ccf07cca27208f0468ba1663ff12263c128060bab400ba2ed707e0c3bcc422a619adc3171c34
|
||||||
SHA512 (Python-3.10.0a3.tar.xz.asc) = 7818e68f131cd1d45a60e7e3603853ab9f4672a6b1504934221a964abd0907f5940df70ec090fda979423f92314056083253641ebcb8f41113f37fc8c36d25f7
|
SHA512 (Python-3.10.0a4.tar.xz.asc) = 6b94e27982e8344f0bd343bb0e04041a82608eff537105815a90a54f48cc6fa4804af10403e9729ada469c876352693144e3922de8fb2e48dc78151fa6520973
|
||||||
|
Loading…
Reference in New Issue
Block a user