3.2.1
3.2.1; refresh lib64 patch (102), subprocess unit test patch (129), disabling of static library build (due to Modules/_testembed; patch 6), autotool intermediates (patch 300)
This commit is contained in:
parent
cfd3e15f77
commit
cce760d4ac
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ Python-3.2a1.tar.bz2
|
|||||||
/Python-3.2rc2.tar.bz2
|
/Python-3.2rc2.tar.bz2
|
||||||
/Python-3.2rc3.tar.bz2
|
/Python-3.2rc3.tar.bz2
|
||||||
/Python-3.2.tar.bz2
|
/Python-3.2.tar.bz2
|
||||||
|
/Python-3.2.1.tar.bz2
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,12 @@
|
|||||||
|
diff -up Python-3.2.1/Lib/test/test_subprocess.py.non-readable-path Python-3.2.1/Lib/test/test_subprocess.py
|
||||||
|
--- Python-3.2.1/Lib/test/test_subprocess.py.non-readable-path 2011-07-09 02:58:51.000000000 -0400
|
||||||
|
+++ Python-3.2.1/Lib/test/test_subprocess.py 2011-07-11 11:34:16.284426005 -0400
|
||||||
|
@@ -618,7 +618,7 @@ class ProcessTestCase(BaseTestCase):
|
||||||
|
for i in range(1024):
|
||||||
|
# Windows raises IOError. Others raise OSError.
|
||||||
|
with self.assertRaises(EnvironmentError) as c:
|
||||||
|
- subprocess.Popen(['nonexisting_i_hope'],
|
||||||
|
+ subprocess.Popen(['/usr/bin/nonexisting_i_hope'],
|
||||||
|
stdout=subprocess.PIPE,
|
||||||
|
stderr=subprocess.PIPE)
|
||||||
|
# ignore errors that indicate the command was not found
|
@ -1,6 +1,6 @@
|
|||||||
diff -up Python-3.2b2/Lib/distutils/command/install.py.lib64 Python-3.2b2/Lib/distutils/command/install.py
|
diff -up Python-3.2.1/Lib/distutils/command/install.py.lib64 Python-3.2.1/Lib/distutils/command/install.py
|
||||||
--- Python-3.2b2/Lib/distutils/command/install.py.lib64 2010-11-24 22:46:44.000000000 -0500
|
--- Python-3.2.1/Lib/distutils/command/install.py.lib64 2011-07-09 02:58:46.000000000 -0400
|
||||||
+++ Python-3.2b2/Lib/distutils/command/install.py 2010-12-29 10:21:55.510184563 -0500
|
+++ Python-3.2.1/Lib/distutils/command/install.py 2011-07-11 11:20:45.980426001 -0400
|
||||||
@@ -47,14 +47,14 @@ else:
|
@@ -47,14 +47,14 @@ else:
|
||||||
INSTALL_SCHEMES = {
|
INSTALL_SCHEMES = {
|
||||||
'unix_prefix': {
|
'unix_prefix': {
|
||||||
@ -18,9 +18,9 @@ diff -up Python-3.2b2/Lib/distutils/command/install.py.lib64 Python-3.2b2/Lib/di
|
|||||||
'headers': '$base/include/python/$dist_name',
|
'headers': '$base/include/python/$dist_name',
|
||||||
'scripts': '$base/bin',
|
'scripts': '$base/bin',
|
||||||
'data' : '$base',
|
'data' : '$base',
|
||||||
diff -up Python-3.2b2/Lib/distutils/sysconfig.py.lib64 Python-3.2b2/Lib/distutils/sysconfig.py
|
diff -up Python-3.2.1/Lib/distutils/sysconfig.py.lib64 Python-3.2.1/Lib/distutils/sysconfig.py
|
||||||
--- Python-3.2b2/Lib/distutils/sysconfig.py.lib64 2010-11-24 14:43:47.000000000 -0500
|
--- Python-3.2.1/Lib/distutils/sysconfig.py.lib64 2011-07-09 02:58:47.000000000 -0400
|
||||||
+++ Python-3.2b2/Lib/distutils/sysconfig.py 2010-12-29 10:21:55.510184563 -0500
|
+++ Python-3.2.1/Lib/distutils/sysconfig.py 2011-07-11 11:20:45.981426001 -0400
|
||||||
@@ -124,8 +124,12 @@ def get_python_lib(plat_specific=0, stan
|
@@ -124,8 +124,12 @@ def get_python_lib(plat_specific=0, stan
|
||||||
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
||||||
|
|
||||||
@ -35,10 +35,10 @@ diff -up Python-3.2b2/Lib/distutils/sysconfig.py.lib64 Python-3.2b2/Lib/distutil
|
|||||||
if standard_lib:
|
if standard_lib:
|
||||||
return libpython
|
return libpython
|
||||||
else:
|
else:
|
||||||
diff -up Python-3.2b2/Lib/site.py.lib64 Python-3.2b2/Lib/site.py
|
diff -up Python-3.2.1/Lib/site.py.lib64 Python-3.2.1/Lib/site.py
|
||||||
--- Python-3.2b2/Lib/site.py.lib64 2010-10-12 18:23:23.000000000 -0400
|
--- Python-3.2.1/Lib/site.py.lib64 2011-07-09 02:58:49.000000000 -0400
|
||||||
+++ Python-3.2b2/Lib/site.py 2010-12-29 10:21:55.511184595 -0500
|
+++ Python-3.2.1/Lib/site.py 2011-07-11 11:20:45.982426001 -0400
|
||||||
@@ -275,12 +275,16 @@ def getsitepackages():
|
@@ -285,12 +285,16 @@ def getsitepackages():
|
||||||
if sys.platform in ('os2emx', 'riscos'):
|
if sys.platform in ('os2emx', 'riscos'):
|
||||||
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
||||||
elif os.sep == '/':
|
elif os.sep == '/':
|
||||||
@ -55,9 +55,9 @@ diff -up Python-3.2b2/Lib/site.py.lib64 Python-3.2b2/Lib/site.py
|
|||||||
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
||||||
if sys.platform == "darwin":
|
if sys.platform == "darwin":
|
||||||
# for framework builds *only* we add the standard Apple
|
# for framework builds *only* we add the standard Apple
|
||||||
diff -up Python-3.2b2/Lib/sysconfig.py.lib64 Python-3.2b2/Lib/sysconfig.py
|
diff -up Python-3.2.1/Lib/sysconfig.py.lib64 Python-3.2.1/Lib/sysconfig.py
|
||||||
--- Python-3.2b2/Lib/sysconfig.py.lib64 2010-11-24 20:34:47.000000000 -0500
|
--- Python-3.2.1/Lib/sysconfig.py.lib64 2011-07-09 02:58:49.000000000 -0400
|
||||||
+++ Python-3.2b2/Lib/sysconfig.py 2010-12-29 10:21:55.512184877 -0500
|
+++ Python-3.2.1/Lib/sysconfig.py 2011-07-11 11:20:45.982426001 -0400
|
||||||
@@ -21,10 +21,10 @@ __all__ = [
|
@@ -21,10 +21,10 @@ __all__ = [
|
||||||
|
|
||||||
_INSTALL_SCHEMES = {
|
_INSTALL_SCHEMES = {
|
||||||
@ -86,10 +86,10 @@ diff -up Python-3.2b2/Lib/sysconfig.py.lib64 Python-3.2b2/Lib/sysconfig.py
|
|||||||
'include': '{userbase}/include/python{py_version_short}',
|
'include': '{userbase}/include/python{py_version_short}',
|
||||||
'scripts': '{userbase}/bin',
|
'scripts': '{userbase}/bin',
|
||||||
'data' : '{userbase}',
|
'data' : '{userbase}',
|
||||||
diff -up Python-3.2b2/Lib/test/test_site.py.lib64 Python-3.2b2/Lib/test/test_site.py
|
diff -up Python-3.2.1/Lib/test/test_site.py.lib64 Python-3.2.1/Lib/test/test_site.py
|
||||||
--- Python-3.2b2/Lib/test/test_site.py.lib64 2010-12-29 10:35:12.417308989 -0500
|
--- Python-3.2.1/Lib/test/test_site.py.lib64 2011-07-09 02:58:51.000000000 -0400
|
||||||
+++ Python-3.2b2/Lib/test/test_site.py 2010-12-29 10:36:27.124059073 -0500
|
+++ Python-3.2.1/Lib/test/test_site.py 2011-07-11 11:20:45.983426001 -0400
|
||||||
@@ -164,12 +164,15 @@ class HelperFunctionsTests(unittest.Test
|
@@ -222,12 +222,15 @@ class HelperFunctionsTests(unittest.Test
|
||||||
wanted = os.path.join('xoxo', 'Lib', 'site-packages')
|
wanted = os.path.join('xoxo', 'Lib', 'site-packages')
|
||||||
self.assertEqual(dirs[0], wanted)
|
self.assertEqual(dirs[0], wanted)
|
||||||
elif os.sep == '/':
|
elif os.sep == '/':
|
||||||
@ -108,10 +108,10 @@ diff -up Python-3.2b2/Lib/test/test_site.py.lib64 Python-3.2b2/Lib/test/test_sit
|
|||||||
else:
|
else:
|
||||||
self.assertEqual(len(dirs), 2)
|
self.assertEqual(len(dirs), 2)
|
||||||
self.assertEqual(dirs[0], 'xoxo')
|
self.assertEqual(dirs[0], 'xoxo')
|
||||||
diff -up Python-3.2b2/Makefile.pre.in.lib64 Python-3.2b2/Makefile.pre.in
|
diff -up Python-3.2.1/Makefile.pre.in.lib64 Python-3.2.1/Makefile.pre.in
|
||||||
--- Python-3.2b2/Makefile.pre.in.lib64 2010-12-29 10:21:55.506183982 -0500
|
--- Python-3.2.1/Makefile.pre.in.lib64 2011-07-11 11:20:45.974426000 -0400
|
||||||
+++ Python-3.2b2/Makefile.pre.in 2010-12-29 10:21:55.512184877 -0500
|
+++ Python-3.2.1/Makefile.pre.in 2011-07-11 11:20:45.984426001 -0400
|
||||||
@@ -102,7 +102,7 @@ LIBDIR= @libdir@
|
@@ -106,7 +106,7 @@ LIBDIR= @libdir@
|
||||||
MANDIR= @mandir@
|
MANDIR= @mandir@
|
||||||
INCLUDEDIR= @includedir@
|
INCLUDEDIR= @includedir@
|
||||||
CONFINCLUDEDIR= $(exec_prefix)/include
|
CONFINCLUDEDIR= $(exec_prefix)/include
|
||||||
@ -120,9 +120,9 @@ diff -up Python-3.2b2/Makefile.pre.in.lib64 Python-3.2b2/Makefile.pre.in
|
|||||||
ABIFLAGS= @ABIFLAGS@
|
ABIFLAGS= @ABIFLAGS@
|
||||||
|
|
||||||
# Detailed destination directories
|
# Detailed destination directories
|
||||||
diff -up Python-3.2b2/Modules/getpath.c.lib64 Python-3.2b2/Modules/getpath.c
|
diff -up Python-3.2.1/Modules/getpath.c.lib64 Python-3.2.1/Modules/getpath.c
|
||||||
--- Python-3.2b2/Modules/getpath.c.lib64 2010-12-03 15:14:31.000000000 -0500
|
--- Python-3.2.1/Modules/getpath.c.lib64 2011-07-09 02:58:54.000000000 -0400
|
||||||
+++ Python-3.2b2/Modules/getpath.c 2010-12-29 10:21:55.513184358 -0500
|
+++ Python-3.2.1/Modules/getpath.c 2011-07-11 11:27:44.596425999 -0400
|
||||||
@@ -122,8 +122,8 @@
|
@@ -122,8 +122,8 @@
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -134,16 +134,16 @@ diff -up Python-3.2b2/Modules/getpath.c.lib64 Python-3.2b2/Modules/getpath.c
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
#ifndef LANDMARK
|
#ifndef LANDMARK
|
||||||
@@ -134,7 +134,7 @@ static wchar_t prefix[MAXPATHLEN+1];
|
@@ -135,7 +135,7 @@ static wchar_t exec_prefix[MAXPATHLEN+1]
|
||||||
static wchar_t exec_prefix[MAXPATHLEN+1];
|
|
||||||
static wchar_t progpath[MAXPATHLEN+1];
|
static wchar_t progpath[MAXPATHLEN+1];
|
||||||
static wchar_t *module_search_path = NULL;
|
static wchar_t *module_search_path = NULL;
|
||||||
|
static int module_search_path_malloced = 0;
|
||||||
-static wchar_t *lib_python = L"lib/python" VERSION;
|
-static wchar_t *lib_python = L"lib/python" VERSION;
|
||||||
+static wchar_t *lib_python = L"lib64/python" VERSION;
|
+static wchar_t *lib_python = L"lib64/python" VERSION;
|
||||||
|
|
||||||
static void
|
static void
|
||||||
reduce(wchar_t *dir)
|
reduce(wchar_t *dir)
|
||||||
@@ -582,7 +582,7 @@ calculate_path(void)
|
@@ -583,7 +583,7 @@ calculate_path(void)
|
||||||
}
|
}
|
||||||
else
|
else
|
||||||
wcsncpy(zip_path, _prefix, MAXPATHLEN);
|
wcsncpy(zip_path, _prefix, MAXPATHLEN);
|
||||||
@ -152,7 +152,7 @@ diff -up Python-3.2b2/Modules/getpath.c.lib64 Python-3.2b2/Modules/getpath.c
|
|||||||
bufsz = wcslen(zip_path); /* Replace "00" with version */
|
bufsz = wcslen(zip_path); /* Replace "00" with version */
|
||||||
zip_path[bufsz - 6] = VERSION[0];
|
zip_path[bufsz - 6] = VERSION[0];
|
||||||
zip_path[bufsz - 5] = VERSION[2];
|
zip_path[bufsz - 5] = VERSION[2];
|
||||||
@@ -592,7 +592,7 @@ calculate_path(void)
|
@@ -593,7 +593,7 @@ calculate_path(void)
|
||||||
fprintf(stderr,
|
fprintf(stderr,
|
||||||
"Could not find platform dependent libraries <exec_prefix>\n");
|
"Could not find platform dependent libraries <exec_prefix>\n");
|
||||||
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
|
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
|
||||||
@ -161,19 +161,19 @@ diff -up Python-3.2b2/Modules/getpath.c.lib64 Python-3.2b2/Modules/getpath.c
|
|||||||
}
|
}
|
||||||
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
||||||
|
|
||||||
diff -up Python-3.2b2/setup.py.lib64 Python-3.2b2/setup.py
|
diff -up Python-3.2.1/setup.py.lib64 Python-3.2.1/setup.py
|
||||||
--- Python-3.2b2/setup.py.lib64 2010-12-04 13:36:03.000000000 -0500
|
--- Python-3.2.1/setup.py.lib64 2011-07-09 02:58:56.000000000 -0400
|
||||||
+++ Python-3.2b2/setup.py 2010-12-29 10:21:55.514184248 -0500
|
+++ Python-3.2.1/setup.py 2011-07-11 11:28:00.193426004 -0400
|
||||||
@@ -373,7 +373,7 @@ class PyBuildExt(build_ext):
|
@@ -396,7 +396,7 @@ class PyBuildExt(build_ext):
|
||||||
# Ensure that /usr/local is always used, but the local build
|
# Ensure that /usr/local is always used, but the local build
|
||||||
# directories (i.e. '.' and 'Include') must be first. See issue
|
# directories (i.e. '.' and 'Include') must be first. See issue
|
||||||
# 10520.
|
# 10520.
|
||||||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
||||||
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
||||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||||
|
self.add_multiarch_paths()
|
||||||
|
|
||||||
# Add paths specified in the environment variables LDFLAGS and
|
@@ -643,11 +643,11 @@ class PyBuildExt(build_ext):
|
||||||
@@ -619,11 +619,11 @@ class PyBuildExt(build_ext):
|
|
||||||
elif curses_library:
|
elif curses_library:
|
||||||
readline_libs.append(curses_library)
|
readline_libs.append(curses_library)
|
||||||
elif self.compiler.find_library_file(lib_dirs +
|
elif self.compiler.find_library_file(lib_dirs +
|
||||||
@ -187,7 +187,7 @@ diff -up Python-3.2b2/setup.py.lib64 Python-3.2b2/setup.py
|
|||||||
extra_link_args=readline_extra_link_args,
|
extra_link_args=readline_extra_link_args,
|
||||||
libraries=readline_libs) )
|
libraries=readline_libs) )
|
||||||
else:
|
else:
|
||||||
@@ -660,8 +660,8 @@ class PyBuildExt(build_ext):
|
@@ -684,8 +684,8 @@ class PyBuildExt(build_ext):
|
||||||
if krb5_h:
|
if krb5_h:
|
||||||
ssl_incs += krb5_h
|
ssl_incs += krb5_h
|
||||||
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
@ -1,7 +1,7 @@
|
|||||||
diff -up Python-3.2rc1/Makefile.pre.in.no-static-lib Python-3.2rc1/Makefile.pre.in
|
diff -up Python-3.2.1/Makefile.pre.in.no-static-lib Python-3.2.1/Makefile.pre.in
|
||||||
--- Python-3.2rc1/Makefile.pre.in.no-static-lib 2010-12-30 17:12:40.000000000 -0500
|
--- Python-3.2.1/Makefile.pre.in.no-static-lib 2011-07-09 02:58:52.000000000 -0400
|
||||||
+++ Python-3.2rc1/Makefile.pre.in 2011-01-17 12:58:32.123947161 -0500
|
+++ Python-3.2.1/Makefile.pre.in 2011-07-11 11:46:27.381425999 -0400
|
||||||
@@ -421,7 +421,7 @@ coverage:
|
@@ -425,7 +425,7 @@ coverage:
|
||||||
|
|
||||||
|
|
||||||
# Build the interpreter
|
# Build the interpreter
|
||||||
@ -10,7 +10,7 @@ diff -up Python-3.2rc1/Makefile.pre.in.no-static-lib Python-3.2rc1/Makefile.pre.
|
|||||||
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||||
|
|
||||||
platform: $(BUILDPYTHON)
|
platform: $(BUILDPYTHON)
|
||||||
@@ -435,18 +435,6 @@ sharedmods: $(BUILDPYTHON)
|
@@ -439,18 +439,6 @@ sharedmods: $(BUILDPYTHON)
|
||||||
*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
|
*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
|
||||||
esac
|
esac
|
||||||
|
|
||||||
@ -29,7 +29,16 @@ diff -up Python-3.2rc1/Makefile.pre.in.no-static-lib Python-3.2rc1/Makefile.pre.
|
|||||||
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
|
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
|
||||||
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
||||||
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
|
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
|
||||||
@@ -1048,18 +1036,6 @@ libainstall: all python-config
|
@@ -540,7 +528,7 @@ Modules/Setup: $(srcdir)/Modules/Setup.d
|
||||||
|
echo "-----------------------------------------------"; \
|
||||||
|
fi
|
||||||
|
|
||||||
|
-Modules/_testembed: Modules/_testembed.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
|
||||||
|
+Modules/_testembed: Modules/_testembed.o $(LDLIBRARY) $(PY3LIBRARY)
|
||||||
|
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||||
|
|
||||||
|
############################################################################
|
||||||
|
@@ -1058,18 +1046,6 @@ libainstall: all python-config
|
||||||
else true; \
|
else true; \
|
||||||
fi; \
|
fi; \
|
||||||
done
|
done
|
@ -1,12 +0,0 @@
|
|||||||
diff -up Python-3.2b2/Lib/test/test_subprocess.py.non-readable-path Python-3.2b2/Lib/test/test_subprocess.py
|
|
||||||
--- Python-3.2b2/Lib/test/test_subprocess.py.non-readable-path 2010-12-29 16:25:38.498184175 -0500
|
|
||||||
+++ Python-3.2b2/Lib/test/test_subprocess.py 2010-12-29 16:25:51.094184539 -0500
|
|
||||||
@@ -578,7 +578,7 @@ class ProcessTestCase(BaseTestCase):
|
|
||||||
for i in range(1024):
|
|
||||||
# Windows raises IOError. Others raise OSError.
|
|
||||||
with self.assertRaises(EnvironmentError) as c:
|
|
||||||
- subprocess.Popen(['nonexisting_i_hope'],
|
|
||||||
+ subprocess.Popen(['/usr/bin/nonexisting_i_hope'],
|
|
||||||
stdout=subprocess.PIPE,
|
|
||||||
stderr=subprocess.PIPE)
|
|
||||||
if c.exception.errno != errno.ENOENT: # ignore "no such file"
|
|
15
python3.spec
15
python3.spec
@ -117,8 +117,8 @@
|
|||||||
# ==================
|
# ==================
|
||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}
|
Version: %{pybasever}.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
|
|
||||||
@ -213,7 +213,7 @@ Patch3: python-3.2b2-remove-mimeaudio-tests.patch
|
|||||||
|
|
||||||
# Patch the Makefile.pre.in so that the generated Makefile doesn't try to build
|
# Patch the Makefile.pre.in so that the generated Makefile doesn't try to build
|
||||||
# a libpythonMAJOR.MINOR.a (bug 550692):
|
# a libpythonMAJOR.MINOR.a (bug 550692):
|
||||||
Patch6: python-3.2rc1-no-static-lib.patch
|
Patch6: python-3.2.1-no-static-lib.patch
|
||||||
|
|
||||||
# Systemtap support: add statically-defined probe points
|
# Systemtap support: add statically-defined probe points
|
||||||
# Patch based on upstream bug: http://bugs.python.org/issue4111
|
# Patch based on upstream bug: http://bugs.python.org/issue4111
|
||||||
@ -222,7 +222,7 @@ Patch6: python-3.2rc1-no-static-lib.patch
|
|||||||
# dmalcolm
|
# dmalcolm
|
||||||
Patch8: python-3.2b2-systemtap.patch
|
Patch8: python-3.2b2-systemtap.patch
|
||||||
|
|
||||||
Patch102: python-3.2b2-lib64.patch
|
Patch102: python-3.2.1-lib64.patch
|
||||||
|
|
||||||
# Add configure-time support for the COUNT_ALLOCS and CALL_PROFILE options
|
# Add configure-time support for the COUNT_ALLOCS and CALL_PROFILE options
|
||||||
# described at http://svn.python.org/projects/python/trunk/Misc/SpecialBuilds.txt
|
# described at http://svn.python.org/projects/python/trunk/Misc/SpecialBuilds.txt
|
||||||
@ -264,7 +264,7 @@ Patch128: python-3.2b2-test_sys-COUNT_ALLOCS.patch
|
|||||||
# Work around this by specifying an absolute path for the non-existant
|
# Work around this by specifying an absolute path for the non-existant
|
||||||
# executable
|
# executable
|
||||||
# Not yet sent upstream
|
# Not yet sent upstream
|
||||||
Patch129: python-3.2b2-fix-test-subprocess-with-nonreadable-path-dir.patch
|
Patch129: python-3.2.1-fix-test-subprocess-with-nonreadable-path-dir.patch
|
||||||
|
|
||||||
# This is the generated patch to "configure"; see the description of
|
# This is the generated patch to "configure"; see the description of
|
||||||
# %{regenerate_autotooling_patch}
|
# %{regenerate_autotooling_patch}
|
||||||
@ -1278,6 +1278,11 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 11 2011 David Malcolm <dmalcolm@redhat.com> - 3.2.1-1
|
||||||
|
- 3.2.1; refresh lib64 patch (102), subprocess unit test patch (129), disabling
|
||||||
|
of static library build (due to Modules/_testembed; patch 6), autotool
|
||||||
|
intermediates (patch 300)
|
||||||
|
|
||||||
* Fri Jul 8 2011 David Malcolm <dmalcolm@redhat.com> - 3.2-5
|
* Fri Jul 8 2011 David Malcolm <dmalcolm@redhat.com> - 3.2-5
|
||||||
- use the gdb hooks from the upstream tarball, rather than keeping our own copy
|
- use the gdb hooks from the upstream tarball, rather than keeping our own copy
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user