Update to 3.10.0a2
This commit is contained in:
parent
13d401b11a
commit
baff8f4745
@ -21,7 +21,7 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
|||||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||||
index 921bd08ea5..ddc55fa410 100644
|
index a8912cd418..06ca6bb87f 100644
|
||||||
--- a/Makefile.pre.in
|
--- a/Makefile.pre.in
|
||||||
+++ b/Makefile.pre.in
|
+++ b/Makefile.pre.in
|
||||||
@@ -576,7 +576,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
@@ -576,7 +576,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||||
@ -55,7 +55,7 @@ index 921bd08ea5..ddc55fa410 100644
|
|||||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||||
|
|
||||||
############################################################################
|
############################################################################
|
||||||
@@ -1600,17 +1594,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
@@ -1604,17 +1598,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||||
else true; \
|
else true; \
|
||||||
fi; \
|
fi; \
|
||||||
done
|
done
|
||||||
|
@ -21,7 +21,7 @@ index cb2882e336..984e587ea0 100644
|
|||||||
import os
|
import os
|
||||||
import os.path
|
import os.path
|
||||||
import sys
|
import sys
|
||||||
@@ -6,16 +8,28 @@ import tempfile
|
@@ -6,16 +8,28 @@
|
||||||
import subprocess
|
import subprocess
|
||||||
from importlib import resources
|
from importlib import resources
|
||||||
|
|
||||||
|
@ -18,7 +18,7 @@ diff --git a/Lib/distutils/command/install.py b/Lib/distutils/command/install.py
|
|||||||
index aaa300efa9..f8d453912a 100644
|
index aaa300efa9..f8d453912a 100644
|
||||||
--- a/Lib/distutils/command/install.py
|
--- a/Lib/distutils/command/install.py
|
||||||
+++ b/Lib/distutils/command/install.py
|
+++ b/Lib/distutils/command/install.py
|
||||||
@@ -419,8 +419,19 @@ class install(Command):
|
@@ -419,8 +419,19 @@ def finalize_unix(self):
|
||||||
raise DistutilsOptionError(
|
raise DistutilsOptionError(
|
||||||
"must not supply exec-prefix without prefix")
|
"must not supply exec-prefix without prefix")
|
||||||
|
|
||||||
|
@ -14,10 +14,10 @@ URL: https://www.python.org/
|
|||||||
# WARNING When rebasing to a new Python version,
|
# WARNING When rebasing to a new Python version,
|
||||||
# remember to update the python3-docs package as well
|
# remember to update the python3-docs package as well
|
||||||
%global general_version %{pybasever}.0
|
%global general_version %{pybasever}.0
|
||||||
%global prerel a1
|
%global prerel a2
|
||||||
%global upstream_version %{general_version}%{?prerel}
|
%global upstream_version %{general_version}%{?prerel}
|
||||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
|
|
||||||
|
|
||||||
@ -1584,6 +1584,9 @@ CheckPython optimized
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 04 2020 Miro Hrončok <mhroncok@redhat.com> - 3.10.0~a2-1
|
||||||
|
- Update to 3.10.0a2
|
||||||
|
|
||||||
* Mon Oct 12 2020 Miro Hrončok <mhroncok@redhat.com> - 3.10.0~a1-2
|
* Mon Oct 12 2020 Miro Hrončok <mhroncok@redhat.com> - 3.10.0~a1-2
|
||||||
- Finish initial bootstrap, build Python 3.10 with Python 3.10
|
- Finish initial bootstrap, build Python 3.10 with Python 3.10
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (Python-3.10.0a1.tar.xz) = eb1a0f6dd023efe67cfc2c833b0a7d390765d288e4da7aae932ba66b970d63ad377dbe48ddf0548c5cca5334a3aa1c7e92f972b68c54e4238ea1f3610adb8910
|
SHA512 (Python-3.10.0a2.tar.xz) = f6ec66db9ac87f3bf4264759dde4380a49a66980a8959ea2dda34561d6bcb827a221c553711173cb1dd5675e74d1ae143ca1e8cbf3f444f4fa4e6fc7be3d7ed2
|
||||||
SHA512 (Python-3.10.0a1.tar.xz.asc) = c4bf5bc1d497053fc05b71bda23e6872ae612bee76549fc0e697f0a6691a9b63ce4038e2f43a5442c10da8a49bbf3165a26598fa6c211d892157f9d558acd214
|
SHA512 (Python-3.10.0a2.tar.xz.asc) = 9382e6f3aba51ff1571ba9bb7dbfcd10e338c1a1d56bb4f26ede26fa2007bff92ad8c434c15091f908850df5ff5b02bd4cf1158c83e751a777fcf3a8d6afb67c
|
||||||
|
Loading…
Reference in New Issue
Block a user