3.3.0-10: fix gcc 4.8 incompatibility (rhbz#927358)

* Mon Mar 25 2013 David Malcolm <dmalcolm@redhat.com> - 3.3.0-10
- fix gcc 4.8 incompatibility (rhbz#927358); regenerate autotool intermediates
This commit is contained in:
David Malcolm 2013-03-25 16:12:35 -04:00
parent ff7dfb66f1
commit b4d586e100
3 changed files with 49 additions and 20 deletions

View File

@ -0,0 +1,12 @@
diff -up Python-3.3.0/configure.ac.fix-configure-Wformat Python-3.3.0/configure.ac
--- Python-3.3.0/configure.ac.fix-configure-Wformat 2013-03-25 16:09:09.127667472 -0400
+++ Python-3.3.0/configure.ac 2013-03-25 16:09:16.442666967 -0400
@@ -1308,7 +1308,7 @@ if test "$GCC" = "yes"
then
AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
],[

View File

@ -1,6 +1,6 @@
diff -up ./configure.autotool-intermediates ./configure
--- ./configure.autotool-intermediates 2012-08-07 17:21:25.249311751 -0400
+++ ./configure 2012-08-07 17:21:35.503311049 -0400
--- ./configure.autotool-intermediates 2013-03-25 16:11:38.140657282 -0400
+++ ./configure 2013-03-25 16:11:46.922656680 -0400
@@ -779,6 +779,8 @@ with_thread
enable_ipv6
with_doc_strings
@ -19,10 +19,28 @@ diff -up ./configure.autotool-intermediates ./configure
--with(out)-pymalloc disable/enable specialized mallocs
--with-valgrind Enable Valgrind support
--with(out)-systemtap disable/enable SystemTap support
@@ -10017,6 +10021,50 @@ $as_echo "no" >&6; }
fi
@@ -6471,7 +6475,7 @@ then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether gcc supports ParseTuple __format__" >&5
$as_echo_n "checking whether gcc supports ParseTuple __format__... " >&6; }
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -10008,6 +10012,50 @@ $as_echo "#define WITH_TSC 1" >>confdefs
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
+else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-count-allocs" >&5
+$as_echo_n "checking for --with-count-allocs... " >&6; }
+
@ -58,16 +76,7 @@ diff -up ./configure.autotool-intermediates ./configure
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+$as_echo "yes" >&6; }
+else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
# Check for Python-specific malloc support
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --with-pymalloc" >&5
$as_echo_n "checking for --with-pymalloc... " >&6; }
else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
fi
diff -up ./pyconfig.h.in.autotool-intermediates ./pyconfig.h.in

View File

@ -126,7 +126,7 @@
Summary: Version 3 of the Python programming language aka Python 3000
Name: python3
Version: %{pybasever}.0
Release: 9%{?dist}
Release: 10%{?dist}
License: Python
Group: Development/Languages
@ -547,8 +547,13 @@ Patch173: 00173-workaround-ENOPROTOOPT-in-bind_port.patch
# TODO: python3 status?
# 00175 #
# Patch175: 00175-fix-configure-Wformat.patch
# TODO: python3 status?
# Fix for configure.ac mistakenly detecting
# checking whether gcc supports ParseTuple __format__... yes
# when it doesn't, when compiling with gcc 4.8
#
# Sent upstream as http://bugs.python.org/issue17547
# (rhbz#927358)
Patch175: 00175-fix-configure-Wformat.patch
# 00176 #
# Potential patch for so extensions being wrong since SOABI in upstream python3.
@ -813,7 +818,7 @@ done
#00172: TODO
%patch173 -p1
#00174: TODO
#00175: TODO
%patch175 -p1
%patch176 -p1
%patch177 -p1
@ -1672,6 +1677,9 @@ rm -fr %{buildroot}
# ======================================================
%changelog
* Mon Mar 25 2013 David Malcolm <dmalcolm@redhat.com> - 3.3.0-10
- fix gcc 4.8 incompatibility (rhbz#927358); regenerate autotool intermediates
* Mon Mar 25 2013 David Malcolm <dmalcolm@redhat.com> - 3.3.0-9
- renumber patches to keep them in sync with python.spec