Updated to Python 3.3.2.

- Refreshed patches: 153 (gdb test noise)
- Dropped patches: 175 (configure -Wformat, fixed upstream)
- Synced patch numbers with python.spec.
This commit is contained in:
Bohuslav Kabrda 2013-05-16 16:35:48 +02:00
parent 9d658b4031
commit a60a842ced
5 changed files with 38 additions and 57 deletions

View File

@ -1,7 +1,6 @@
diff -up cpython-59223da36dec/Lib/test/test_gdb.py.fix-test_gdb-noise cpython-59223da36dec/Lib/test/test_gdb.py
--- cpython-59223da36dec/Lib/test/test_gdb.py.fix-test_gdb-noise 2012-08-07 06:10:57.000000000 -0400
+++ cpython-59223da36dec/Lib/test/test_gdb.py 2012-08-07 17:13:46.592343113 -0400
@@ -115,6 +115,15 @@ class DebuggerTests(unittest.TestCase):
--- Lib/test/test_gdb.py.old 2012-04-11 21:04:01.367073855 -0400
+++ Lib/test/test_gdb.py 2012-04-12 08:52:58.320288761 -0400
@@ -96,6 +96,15 @@ class DebuggerTests(unittest.TestCase):
# Generate a list of commands in gdb's language:
commands = ['set breakpoint pending yes',
'break %s' % breakpoint,
@ -17,20 +16,16 @@ diff -up cpython-59223da36dec/Lib/test/test_gdb.py.fix-test_gdb-noise cpython-59
'run']
if cmds_after_breakpoint:
commands += cmds_after_breakpoint
@@ -154,8 +163,16 @@ class DebuggerTests(unittest.TestCase):
'Do you need "set solib-search-path" or '
'"set sysroot"?\n',
'')
+ err = '\n'.join([line
+ for line in err.splitlines()
+ if not line.startswith('warning: Unable to open')
+ if not line.startswith('Missing separate debuginfo for')
+ if not line.startswith('Try: yum --disablerepo=')
+ # In case 'set print entry-values no' failed:
+ if not line.startswith('Undefined set print command')])
# Ensure no unexpected error messages:
+ self.maxDiff = None
self.assertEqual(err, '')
return out
--- Lib/test/test_gdb.py.old 2012-04-11 21:04:01.367073855 -0400
+++ Lib/test/test_gdb.py 2012-04-12 08:52:58.320288761 -0400
@@ -144,6 +153,10 @@
'Do you need "set solib-search-path" or '
'"set sysroot"?',
)
+ ignore_patterns += ('warning: Unable to open',
+ 'Missing separate debuginfo for',
+ 'Try: yum --disablerepo=',
+ 'Undefined set print command')
for line in errlines:
if not line.startswith(ignore_patterns):
unexpected_errlines.append(line)

View File

@ -19,15 +19,6 @@ diff -up ./configure.autotool-intermediates ./configure
--with(out)-pymalloc disable/enable specialized mallocs
--with-valgrind Enable Valgrind support
--with(out)-systemtap disable/enable SystemTap support
@@ -6529,7 +6533,7 @@ then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether gcc supports ParseTuple __format__" >&5
$as_echo_n "checking whether gcc supports ParseTuple __format__... " >&6; }
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -10117,6 +10121,50 @@ $as_echo "#define WITH_TSC 1" >>confdefs
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
@ -79,16 +70,3 @@ diff -up ./configure.autotool-intermediates ./configure
else { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
fi
diff -up ./pyconfig.h.in.autotool-intermediates ./pyconfig.h.in
--- ./pyconfig.h.in.autotool-intermediates 2013-04-09 14:52:49.829773431 +0200
+++ ./pyconfig.h.in 2013-04-09 14:52:53.488764667 +0200
@@ -1193,9 +1193,6 @@
/* Define if setpgrp() must be called as setpgrp(0, 0). */
#undef SETPGRP_HAVE_ARG
-/* Define this to be extension of shared libraries (including the dot!). */
-#undef SHLIB_EXT
-
/* Define if i>>j for signed int i does not extend the sign bit when i < 0 */
#undef SIGNED_RIGHT_SHIFT_ZERO_FILLS

View File

@ -125,8 +125,8 @@
# ==================
Summary: Version 3 of the Python programming language aka Python 3000
Name: python3
Version: %{pybasever}.1
Release: 4%{?dist}
Version: %{pybasever}.2
Release: 1%{?dist}
License: Python
Group: Development/Languages
@ -545,13 +545,8 @@ Patch173: 00173-workaround-ENOPROTOOPT-in-bind_port.patch
# TODO: python3 status?
# 00175 #
# Fix for configure.ac mistakenly detecting
# checking whether gcc supports ParseTuple __format__... yes
# when it doesn't, when compiling with gcc 4.8
#
# Sent upstream as http://bugs.python.org/issue17547
# (rhbz#927358)
Patch175: 00175-fix-configure-Wformat.patch
# Upstream as of Python 3.3.2
# Patch175: 00175-fix-configure-Wformat.patch
# 00176 #
# Fixed upstream as of Python 3.3.1
@ -584,13 +579,19 @@ Patch179: 00179-dont-raise-error-on-gdb-corrupted-frames-in-backtrace.patch
# Not appropriate for upstream, Fedora-specific naming
Patch180: 00180-python-add-support-for-ppc64p7.patch
# 00181 #
# python.spec has
# Patch181: 00181-allow-arbitrary-timeout-in-condition-wait.patch
# Does not affect python3
# 00181 #
# Fix test.test_gdb.PyBtTests.test_threads on ppc64
# Cherrypicked from upstream commit:
# http://hg.python.org/cpython/rev/f4a6b731905a/
# for upstream issue http://bugs.python.org/issue17833
# (rhbz#960010)
Patch181: 00181-fix-test_gdb-test_threads.patch
Patch182: 00182-fix-test_gdb-test_threads.patch
# (New patches go here ^^^)
#
@ -815,7 +816,7 @@ done
%endif
# 00151: not for python3
# 00152: upstream as of Python 3.3.0b2
%patch153 -p1
%patch153 -p0
# 00154: not for this branch
%patch155 -p1
%patch156 -p1
@ -839,13 +840,14 @@ done
#00172: TODO
%patch173 -p1
#00174: TODO
%patch175 -p1
# 00175: upstream as of Python 3.3.2
# 00176: upstream as of Python 3.3.1
%patch177 -p1
%patch178 -p1
%patch179 -p1
%patch180 -p1
%patch181 -p1
# 00181: not for python3
%patch182 -p1
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
# are many differences between 2.6 and the Python 3 library.
@ -1686,6 +1688,12 @@ rm -fr %{buildroot}
# ======================================================
%changelog
* Thu May 16 2013 Bohuslav Kabrda <bkabrda@redhat.com> - 3.3.2-1
- Updated to Python 3.3.2.
- Refreshed patches: 153 (gdb test noise)
- Dropped patches: 175 (configure -Wformat, fixed upstream)
- Synced patch numbers with python.spec.
* Thu May 9 2013 David Malcolm <dmalcolm@redhat.com> - 3.3.1-4
- fix test.test_gdb.PyBtTests.test_threads on ppc64 (patch 181; rhbz#960010)

View File

@ -1 +1 @@
993232d9f4d9b4863cc1ec69a792e9cd Python-3.3.1.tar.xz
c94b78ea3b68a9bbc9906af4d5b4fdc7 Python-3.3.2.tar.xz