Update to 3.8.0b1
This commit is contained in:
parent
7aab0ddc87
commit
a292838ccc
@ -1,4 +1,4 @@
|
||||
From 39b5f58db91eea63fae2883c74f8a3f7fe49bc17 Mon Sep 17 00:00:00 2001
|
||||
From 068ae6b9d422e5deeb950d1354a003025642413a Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||
Subject: [PATCH 1/7] 00001: Fixup distutils/unixccompiler.py to remove
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c601ae9643cda53d9e1b898ea941bf9207c9f2f6 Mon Sep 17 00:00:00 2001
|
||||
From 1b28c83def441be0e9377058b9a29a1ea3558ae0 Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||
Subject: [PATCH 2/7] 00102: Change the various install paths to use
|
||||
@ -154,7 +154,7 @@ index 41c4229919..543c88432a 100644
|
||||
'site-packages')
|
||||
self.assertEqual(dirs[0], wanted)
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index 75eb66be3c..f1e21784af 100644
|
||||
index a0bc9c1f1c..780118c410 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -143,7 +143,7 @@ LIBDIR= @libdir@
|
||||
@ -167,28 +167,28 @@ index 75eb66be3c..f1e21784af 100644
|
||||
|
||||
# Detailed destination directories
|
||||
diff --git a/Modules/getpath.c b/Modules/getpath.c
|
||||
index 3991ad719c..1baf8a2ff4 100644
|
||||
index 5f80738188..73d7913441 100644
|
||||
--- a/Modules/getpath.c
|
||||
+++ b/Modules/getpath.c
|
||||
@@ -688,7 +688,7 @@ calculate_exec_prefix(const _PyCoreConfig *core_config,
|
||||
@@ -689,7 +689,7 @@ calculate_exec_prefix(const PyConfig *config,
|
||||
if (safe_wcscpy(exec_prefix, calculate->exec_prefix, exec_prefix_len) < 0) {
|
||||
return PATHLEN_ERR();
|
||||
}
|
||||
- err = joinpath(exec_prefix, L"lib/lib-dynload", exec_prefix_len);
|
||||
+ err = joinpath(exec_prefix, L"lib64/lib-dynload", exec_prefix_len);
|
||||
if (_Py_INIT_FAILED(err)) {
|
||||
return err;
|
||||
- status = joinpath(exec_prefix, L"lib/lib-dynload", exec_prefix_len);
|
||||
+ status = joinpath(exec_prefix, L"lib64/lib-dynload", exec_prefix_len);
|
||||
if (_PyStatus_EXCEPTION(status)) {
|
||||
return status;
|
||||
}
|
||||
@@ -1015,7 +1015,7 @@ calculate_zip_path(PyCalculatePath *calculate, const wchar_t *prefix)
|
||||
@@ -1016,7 +1016,7 @@ calculate_zip_path(PyCalculatePath *calculate, const wchar_t *prefix)
|
||||
return PATHLEN_ERR();
|
||||
}
|
||||
}
|
||||
- err = joinpath(calculate->zip_path, L"lib/python00.zip", zip_path_len);
|
||||
+ err = joinpath(calculate->zip_path, L"lib64/python00.zip", zip_path_len);
|
||||
if (_Py_INIT_FAILED(err)) {
|
||||
return err;
|
||||
- status = joinpath(calculate->zip_path, L"lib/python00.zip", zip_path_len);
|
||||
+ status = joinpath(calculate->zip_path, L"lib64/python00.zip", zip_path_len);
|
||||
if (_PyStatus_EXCEPTION(status)) {
|
||||
return status;
|
||||
}
|
||||
@@ -1144,7 +1144,7 @@ calculate_init(PyCalculatePath *calculate,
|
||||
@@ -1145,7 +1145,7 @@ calculate_init(PyCalculatePath *calculate,
|
||||
if (!calculate->prefix) {
|
||||
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
|
||||
}
|
||||
@ -198,10 +198,10 @@ index 3991ad719c..1baf8a2ff4 100644
|
||||
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
|
||||
}
|
||||
diff --git a/configure b/configure
|
||||
index e6e4007351..b01e6fa9b7 100755
|
||||
index b606fc808c..50b578a551 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15159,9 +15159,9 @@ fi
|
||||
@@ -15175,9 +15175,9 @@ fi
|
||||
|
||||
|
||||
if test x$PLATFORM_TRIPLET = x; then
|
||||
@ -214,10 +214,10 @@ index e6e4007351..b01e6fa9b7 100755
|
||||
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a02597da2d..7f86f286b6 100644
|
||||
index 3d589ac258..3bb44e6993 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4653,9 +4653,9 @@ fi
|
||||
@@ -4649,9 +4649,9 @@ fi
|
||||
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
||||
AC_SUBST(PY_ENABLE_SHARED)
|
||||
if test x$PLATFORM_TRIPLET = x; then
|
||||
@ -230,10 +230,10 @@ index a02597da2d..7f86f286b6 100644
|
||||
AC_SUBST(LIBPL)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 96a49b4e35..64420838af 100644
|
||||
index 598f5819f8..0685620484 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -610,7 +610,7 @@ class PyBuildExt(build_ext):
|
||||
@@ -648,7 +648,7 @@ class PyBuildExt(build_ext):
|
||||
# directories (i.e. '.' and 'Include') must be first. See issue
|
||||
# 10520.
|
||||
if not CROSS_COMPILING:
|
||||
@ -242,7 +242,7 @@ index 96a49b4e35..64420838af 100644
|
||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||
# only change this for cross builds for 3.3, issues on Mageia
|
||||
if CROSS_COMPILING:
|
||||
@@ -906,11 +906,11 @@ class PyBuildExt(build_ext):
|
||||
@@ -944,11 +944,11 @@ class PyBuildExt(build_ext):
|
||||
elif curses_library:
|
||||
readline_libs.append(curses_library)
|
||||
elif self.compiler.find_library_file(self.lib_dirs +
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 0acdfa7c697ffb1087ded14819c7dcfe4784ca7c Mon Sep 17 00:00:00 2001
|
||||
From 79544450450248e4967a8b41aa6d08d32d5cd41a Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Mon, 18 Jan 2010 17:59:07 +0000
|
||||
Subject: [PATCH 3/7] 00111: Don't try to build a libpythonMAJOR.MINOR.a
|
||||
@ -21,10 +21,10 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index f1e21784af..414aa96008 100644
|
||||
index 780118c410..3431ca815e 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -559,7 +559,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
@@ -560,7 +560,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
|
||||
|
||||
# Build the interpreter
|
||||
@ -33,7 +33,7 @@ index f1e21784af..414aa96008 100644
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||
|
||||
platform: $(BUILDPYTHON) pybuilddir.txt
|
||||
@@ -607,12 +607,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
||||
@@ -608,12 +608,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
||||
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
||||
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
||||
|
||||
@ -46,7 +46,7 @@ index f1e21784af..414aa96008 100644
|
||||
libpython$(LDVERSION).so: $(LIBRARY_OBJS) $(DTRACE_OBJS)
|
||||
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
||||
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM); \
|
||||
@@ -690,7 +684,7 @@ Makefile Modules/config.c: Makefile.pre \
|
||||
@@ -691,7 +685,7 @@ Makefile Modules/config.c: Makefile.pre \
|
||||
@echo "The Makefile was updated, you may need to re-run make."
|
||||
|
||||
|
||||
@ -55,7 +55,7 @@ index f1e21784af..414aa96008 100644
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||
|
||||
############################################################################
|
||||
@@ -1532,17 +1526,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@@ -1546,17 +1540,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
else true; \
|
||||
fi; \
|
||||
done
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 7bb76d766aa5394e845f656b3f68b7910e9ee4e6 Mon Sep 17 00:00:00 2001
|
||||
From 56d0cce46e634840578af18492f3dffea55774a5 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Wed, 15 Aug 2018 15:36:29 +0200
|
||||
Subject: [PATCH 4/7] 00189: Instead of bundled wheels, use our RPM packaged
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 377daf65817790e78ccec966221724f4523693c1 Mon Sep 17 00:00:00 2001
|
||||
From 31460771d57aa535ed4672547d268c38f9eed755 Mon Sep 17 00:00:00 2001
|
||||
From: Michal Cyprian <m.cyprian@gmail.com>
|
||||
Date: Mon, 26 Jun 2017 16:32:56 +0200
|
||||
Subject: [PATCH 5/7] 00251: Change user install location
|
||||
|
@ -1,4 +1,4 @@
|
||||
From e9def22e31801d9d75017e6752d3daf4099bc836 Mon Sep 17 00:00:00 2001
|
||||
From d63983e350f673cf9a5f4267e73475535432ebe7 Mon Sep 17 00:00:00 2001
|
||||
From: Petr Viktorin <pviktori@redhat.com>
|
||||
Date: Mon, 28 Aug 2017 17:16:46 +0200
|
||||
Subject: [PATCH 6/7] 00274: Upstream uses Debian-style architecture naming,
|
||||
@ -29,10 +29,10 @@ index ba37cf99e2..52a9ec6662 100755
|
||||
ppc64le | powerpc64little)
|
||||
basic_machine=powerpc64le-unknown
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 7f86f286b6..6d7430e014 100644
|
||||
index 3bb44e6993..98b5e32ad9 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -740,9 +740,9 @@ cat >> conftest.c <<EOF
|
||||
@@ -741,9 +741,9 @@ cat >> conftest.c <<EOF
|
||||
alpha-linux-gnu
|
||||
# elif defined(__ARM_EABI__) && defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
||||
@ -44,7 +44,7 @@ index 7f86f286b6..6d7430e014 100644
|
||||
# endif
|
||||
# elif defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
||||
@@ -782,7 +782,7 @@ cat >> conftest.c <<EOF
|
||||
@@ -783,7 +783,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64el-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
@ -53,7 +53,7 @@ index 7f86f286b6..6d7430e014 100644
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
||||
@@ -792,22 +792,22 @@ cat >> conftest.c <<EOF
|
||||
@@ -793,22 +793,22 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a44fa78c34634c580e3f5922aed600d7a777fe93 Mon Sep 17 00:00:00 2001
|
||||
From 736a0ca9fd2ee3f74ebdef187c5616288cc70351 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Thu, 20 Dec 2018 12:46:25 +0100
|
||||
Subject: [PATCH 7/7] 00316: Mark bdist_wininst unsupported
|
||||
|
@ -14,10 +14,10 @@ URL: https://www.python.org/
|
||||
# WARNING When rebasing to a new Python version,
|
||||
# remember to update the python3-docs package as well
|
||||
%global general_version %{pybasever}.0
|
||||
%global prerel a4
|
||||
%global prerel b1
|
||||
%global upstream_version %{general_version}%{?prerel}
|
||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Python
|
||||
|
||||
|
||||
@ -882,6 +882,7 @@ rm %{buildroot}%{_bindir}/2to3
|
||||
rm %{buildroot}%{_libdir}/libpython3.so
|
||||
rm %{buildroot}%{_mandir}/man1/python3.1*
|
||||
rm %{buildroot}%{_libdir}/pkgconfig/python3.pc
|
||||
rm %{buildroot}%{_libdir}/pkgconfig/python3-embed.pc
|
||||
%endif
|
||||
|
||||
|
||||
@ -1184,6 +1185,11 @@ CheckPython optimized
|
||||
%{pylibdir}/importlib/*.py
|
||||
%{pylibdir}/importlib/__pycache__/*%{bytecode_suffixes}
|
||||
|
||||
%dir %{pylibdir}/importlib/metadata/
|
||||
%dir %{pylibdir}/importlib/metadata/__pycache__/
|
||||
%{pylibdir}/importlib/metadata/*.py
|
||||
%{pylibdir}/importlib/metadata/__pycache__/*%{bytecode_suffixes}
|
||||
|
||||
%dir %{pylibdir}/json/
|
||||
%dir %{pylibdir}/json/__pycache__/
|
||||
%{pylibdir}/json/*.py
|
||||
@ -1243,6 +1249,7 @@ CheckPython optimized
|
||||
%if %{without flatpackage}
|
||||
%{_bindir}/python3-config
|
||||
%{_libdir}/pkgconfig/python3.pc
|
||||
%{_libdir}/pkgconfig/python3-embed.pc
|
||||
%{_bindir}/pathfix.py
|
||||
%{_bindir}/pygettext3.py
|
||||
%{_bindir}/msgfmt3.py
|
||||
@ -1256,7 +1263,9 @@ CheckPython optimized
|
||||
%{_bindir}/python%{LDVERSION_optimized}-*-config
|
||||
%{_libdir}/libpython%{LDVERSION_optimized}.so
|
||||
%{_libdir}/pkgconfig/python-%{LDVERSION_optimized}.pc
|
||||
%{_libdir}/pkgconfig/python-%{LDVERSION_optimized}-embed.pc
|
||||
%{_libdir}/pkgconfig/python-%{pybasever}.pc
|
||||
%{_libdir}/pkgconfig/python-%{pybasever}-embed.pc
|
||||
|
||||
|
||||
%if %{without flatpackage}
|
||||
@ -1424,6 +1433,7 @@ CheckPython optimized
|
||||
%{_libdir}/libpython%{LDVERSION_debug}.so
|
||||
%{_libdir}/libpython%{LDVERSION_debug}.so.1.0
|
||||
%{_libdir}/pkgconfig/python-%{LDVERSION_debug}.pc
|
||||
%{_libdir}/pkgconfig/python-%{LDVERSION_debug}-embed.pc
|
||||
|
||||
# Analog of the -tools subpackage's files:
|
||||
# None for now; we could build precanned versions that have the appropriate
|
||||
@ -1463,6 +1473,9 @@ CheckPython optimized
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Wed Jun 05 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~b1-1
|
||||
- Update to 3.8.0b1
|
||||
|
||||
* Fri May 17 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~a4-2
|
||||
- Remove a faulty patch that resulted in invalid value of
|
||||
distutils.sysconfig.get_config_var('LIBPL') (#1710767)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Python-3.8.0a4.tar.xz) = 76088206e3eb4ff0b9060f35e0bf994018452cc98d7f576bf7d6842158a6f6ae173b281c442f1175402428c683667b7bacebb2b989a561a9f12db1ad5f0f42cb
|
||||
SHA512 (Python-3.8.0b1.tar.xz) = 0e2547691fde3a88408211146cd3be0de8e3e79c11485aec1062c17fabccefbcf2c1b188c96e570387f86b2e1b6a2fcbbb7329b241ff978974ca43e01ef014ca
|
||||
|
Loading…
Reference in New Issue
Block a user