Update to 3.8.0a3

Rebased patches: 102
Updated pip/setuptools versions in spec and patch 189
This commit is contained in:
Miro Hrončok 2019-03-27 01:14:40 +01:00
parent ad7d856a30
commit 804ec7c37d
4 changed files with 42 additions and 39 deletions

View File

@ -23,7 +23,7 @@ diff --git a/Lib/distutils/sysconfig.py b/Lib/distutils/sysconfig.py
index e07a6c8..554740d 100644 index e07a6c8..554740d 100644
--- a/Lib/distutils/sysconfig.py --- a/Lib/distutils/sysconfig.py
+++ b/Lib/distutils/sysconfig.py +++ b/Lib/distutils/sysconfig.py
@@ -129,8 +129,12 @@ def get_python_lib(plat_specific=0, standard_lib=0, prefix=None): @@ -140,8 +140,12 @@ def get_python_lib(plat_specific=0, standard_lib=0, prefix=None):
prefix = plat_specific and EXEC_PREFIX or PREFIX prefix = plat_specific and EXEC_PREFIX or PREFIX
if os.name == "posix": if os.name == "posix":
@ -108,7 +108,7 @@ diff --git a/Lib/test/test_site.py b/Lib/test/test_site.py
index 266adf0..e8513b6 100644 index 266adf0..e8513b6 100644
--- a/Lib/test/test_site.py --- a/Lib/test/test_site.py
+++ b/Lib/test/test_site.py +++ b/Lib/test/test_site.py
@@ -275,8 +275,8 @@ class HelperFunctionsTests(unittest.TestCase): @@ -266,8 +266,8 @@ class HelperFunctionsTests(unittest.TestCase):
dirs = site.getsitepackages() dirs = site.getsitepackages()
if os.sep == '/': if os.sep == '/':
# OS X, Linux, FreeBSD, etc # OS X, Linux, FreeBSD, etc
@ -123,7 +123,7 @@ diff --git a/Makefile.pre.in b/Makefile.pre.in
index 59ba9d4..5780ed8 100644 index 59ba9d4..5780ed8 100644
--- a/Makefile.pre.in --- a/Makefile.pre.in
+++ b/Makefile.pre.in +++ b/Makefile.pre.in
@@ -133,7 +133,7 @@ LIBDIR= @libdir@ @@ -140,7 +140,7 @@ LIBDIR= @libdir@
MANDIR= @mandir@ MANDIR= @mandir@
INCLUDEDIR= @includedir@ INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include CONFINCLUDEDIR= $(exec_prefix)/include
@ -133,28 +133,28 @@ index 59ba9d4..5780ed8 100644
# Detailed destination directories # Detailed destination directories
diff --git a/Modules/getpath.c b/Modules/getpath.c diff --git a/Modules/getpath.c b/Modules/getpath.c
index 85e737b..2a1fc79 100644 index dd188c6..6e69eed 100644
--- a/Modules/getpath.c --- a/Modules/getpath.c
+++ b/Modules/getpath.c +++ b/Modules/getpath.c
@@ -500,7 +500,7 @@ calculate_exec_prefix(const _PyCoreConfig *core_config, @@ -688,7 +688,7 @@ calculate_exec_prefix(const _PyCoreConfig *core_config,
"Could not find platform dependent libraries <exec_prefix>\n"); if (safe_wcscpy(exec_prefix, calculate->exec_prefix, exec_prefix_len) < 0) {
return PATHLEN_ERR();
}
- err = joinpath(exec_prefix, L"lib/lib-dynload", exec_prefix_len);
+ err = joinpath(exec_prefix, L"lib64/lib-dynload", exec_prefix_len);
if (_Py_INIT_FAILED(err)) {
return err;
}
@@ -1015,7 +1015,7 @@ calculate_zip_path(PyCalculatePath *calculate, const wchar_t *prefix)
return PATHLEN_ERR();
} }
wcsncpy(exec_prefix, calculate->exec_prefix, MAXPATHLEN);
- joinpath(exec_prefix, L"lib/lib-dynload");
+ joinpath(exec_prefix, L"lib64/lib-dynload");
} }
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */ - err = joinpath(calculate->zip_path, L"lib/python00.zip", zip_path_len);
} + err = joinpath(calculate->zip_path, L"lib64/python00.zip", zip_path_len);
@@ -742,7 +742,7 @@ calculate_zip_path(PyCalculatePath *calculate, const wchar_t *prefix) if (_Py_INIT_FAILED(err)) {
else { return err;
wcsncpy(calculate->zip_path, calculate->prefix, MAXPATHLEN);
} }
- joinpath(calculate->zip_path, L"lib/python00.zip"); @@ -1144,7 +1144,7 @@ calculate_init(PyCalculatePath *calculate,
+ joinpath(calculate->zip_path, L"lib64/python00.zip");
/* Replace "00" with version */
size_t bufsz = wcslen(calculate->zip_path);
@@ -867,7 +867,7 @@ calculate_init(PyCalculatePath *calculate,
if (!calculate->prefix) { if (!calculate->prefix) {
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len); return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
} }
@ -164,29 +164,29 @@ index 85e737b..2a1fc79 100644
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len); return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
} }
diff --git a/setup.py b/setup.py diff --git a/setup.py b/setup.py
index f1933f7..450cd8a 100644 index 0258d3d..4b969bf 100644
--- a/setup.py --- a/setup.py
+++ b/setup.py +++ b/setup.py
@@ -531,7 +531,7 @@ class PyBuildExt(build_ext): @@ -610,7 +610,7 @@ class PyBuildExt(build_ext):
# directories (i.e. '.' and 'Include') must be first. See issue # directories (i.e. '.' and 'Include') must be first. See issue
# 10520. # 10520.
if not cross_compiling: if not CROSS_COMPILING:
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib') - add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64') + add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia # only change this for cross builds for 3.3, issues on Mageia
if cross_compiling: if CROSS_COMPILING:
@@ -830,11 +830,11 @@ class PyBuildExt(build_ext): @@ -902,11 +902,11 @@ class PyBuildExt(build_ext):
elif curses_library: elif curses_library:
readline_libs.append(curses_library) readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs + elif self.compiler.find_library_file(self.lib_dirs +
- ['/usr/lib/termcap'], - ['/usr/lib/termcap'],
+ ['/usr/lib64/termcap'], + ['/usr/lib64/termcap'],
'termcap'): 'termcap'):
readline_libs.append('termcap') readline_libs.append('termcap')
exts.append( Extension('readline', ['readline.c'], self.add(Extension('readline', ['readline.c'],
- library_dirs=['/usr/lib/termcap'], - library_dirs=['/usr/lib/termcap'],
+ library_dirs=['/usr/lib64/termcap'], + library_dirs=['/usr/lib64/termcap'],
extra_link_args=readline_extra_link_args, extra_link_args=readline_extra_link_args,
libraries=readline_libs) ) libraries=readline_libs))
else: else:

View File

@ -16,9 +16,9 @@ index 4748ba4..fc02255 100644
+_WHEEL_DIR = "/usr/share/python-wheels/" +_WHEEL_DIR = "/usr/share/python-wheels/"
-_SETUPTOOLS_VERSION = "40.6.2" -_SETUPTOOLS_VERSION = "40.8.0"
-_PIP_VERSION = "18.1" -_PIP_VERSION = "19.0.3"
+def _get_most_recent_wheel_version(pkg): +def _get_most_recent_wheel_version(pkg):
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg)) + prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
+ suffix = "-py2.py3-none-any.whl" + suffix = "-py2.py3-none-any.whl"

View File

@ -14,7 +14,7 @@ URL: https://www.python.org/
# WARNING When rebasing to a new Python version, # WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well # remember to update the python3-docs package as well
%global general_version %{pybasever}.0 %global general_version %{pybasever}.0
%global prerel a2 %global prerel a3
%global upstream_version %{general_version}%{?prerel} %global upstream_version %{general_version}%{?prerel}
Version: %{general_version}%{?prerel:~%{prerel}} Version: %{general_version}%{?prerel:~%{prerel}}
Release: 1%{?dist} Release: 1%{?dist}
@ -379,8 +379,8 @@ Summary: Python runtime libraries
Requires: python-setuptools-wheel Requires: python-setuptools-wheel
Requires: python-pip-wheel Requires: python-pip-wheel
%else %else
Provides: bundled(python3-pip) = 18.1 Provides: bundled(python3-pip) = 19.0.3
Provides: bundled(python3-setuptools) = 40.6.2 Provides: bundled(python3-setuptools) = 40.8.0
%endif %endif
# There are files in the standard library that have python shebang. # There are files in the standard library that have python shebang.
@ -521,8 +521,8 @@ so extensions for both versions can co-exist in the same directory.
Requires: python-setuptools-wheel Requires: python-setuptools-wheel
Requires: python-pip-wheel Requires: python-pip-wheel
%else %else
Provides: bundled(python3-pip) = 18.1 Provides: bundled(python3-pip) = 19.0.3
Provides: bundled(python3-setuptools) = 40.6.2 Provides: bundled(python3-setuptools) = 40.8.0
%endif %endif
# The description for the flat package # The description for the flat package
@ -1489,6 +1489,9 @@ CheckPython optimized
# ====================================================== # ======================================================
%changelog %changelog
* Tue Mar 26 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~a3-1
- Update to 3.8.0a3
* Mon Feb 25 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~a2-1 * Mon Feb 25 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~a2-1
- Update to 3.8.0a2 - Update to 3.8.0a2

View File

@ -1 +1 @@
SHA512 (Python-3.8.0a2.tar.xz) = ebba962aa73bf690f33f4e2183da5f64f13cdd892d94c48b433cd04f7cdbc8baf88ff60d7998c330683b590f7c02fa2f426c9cbde461f36871bda728ab4f07ac SHA512 (Python-3.8.0a3.tar.xz) = 2348416c3118d1ff6b88b1ee823046de6a26305c10dd900fcb59fbc5b37a8f54db7afcd2f8e7c927c50c4f317a8c20370478030f996f93c63381d2167247e6fd