Remove patch 157, which contained test changes left over after upstreaming
This commit is contained in:
parent
c4a5733df6
commit
61c2d437a2
@ -1,68 +0,0 @@
|
|||||||
diff --git a/Lib/test/test_os.py b/Lib/test/test_os.py
|
|
||||||
index e9fdb07..ea60e6e 100644
|
|
||||||
--- a/Lib/test/test_os.py
|
|
||||||
+++ b/Lib/test/test_os.py
|
|
||||||
@@ -1723,30 +1723,36 @@ class PosixUidGidTests(unittest.TestCase):
|
|
||||||
def test_setuid(self):
|
|
||||||
if os.getuid() != 0:
|
|
||||||
self.assertRaises(OSError, os.setuid, 0)
|
|
||||||
+ self.assertRaises(TypeError, os.setuid, 'not an int')
|
|
||||||
self.assertRaises(OverflowError, os.setuid, 1<<32)
|
|
||||||
|
|
||||||
@unittest.skipUnless(hasattr(os, 'setgid'), 'test needs os.setgid()')
|
|
||||||
def test_setgid(self):
|
|
||||||
if os.getuid() != 0 and not HAVE_WHEEL_GROUP:
|
|
||||||
self.assertRaises(OSError, os.setgid, 0)
|
|
||||||
+ self.assertRaises(TypeError, os.setgid, 'not an int')
|
|
||||||
self.assertRaises(OverflowError, os.setgid, 1<<32)
|
|
||||||
|
|
||||||
@unittest.skipUnless(hasattr(os, 'seteuid'), 'test needs os.seteuid()')
|
|
||||||
def test_seteuid(self):
|
|
||||||
if os.getuid() != 0:
|
|
||||||
self.assertRaises(OSError, os.seteuid, 0)
|
|
||||||
+ self.assertRaises(TypeError, os.seteuid, 'not an int')
|
|
||||||
self.assertRaises(OverflowError, os.seteuid, 1<<32)
|
|
||||||
|
|
||||||
@unittest.skipUnless(hasattr(os, 'setegid'), 'test needs os.setegid()')
|
|
||||||
def test_setegid(self):
|
|
||||||
if os.getuid() != 0 and not HAVE_WHEEL_GROUP:
|
|
||||||
self.assertRaises(OSError, os.setegid, 0)
|
|
||||||
+ self.assertRaises(TypeError, os.setegid, 'not an int')
|
|
||||||
self.assertRaises(OverflowError, os.setegid, 1<<32)
|
|
||||||
|
|
||||||
@unittest.skipUnless(hasattr(os, 'setreuid'), 'test needs os.setreuid()')
|
|
||||||
def test_setreuid(self):
|
|
||||||
if os.getuid() != 0:
|
|
||||||
self.assertRaises(OSError, os.setreuid, 0, 0)
|
|
||||||
+ self.assertRaises(TypeError, os.setreuid, 'not an int', 0)
|
|
||||||
+ self.assertRaises(TypeError, os.setreuid, 0, 'not an int')
|
|
||||||
self.assertRaises(OverflowError, os.setreuid, 1<<32, 0)
|
|
||||||
self.assertRaises(OverflowError, os.setreuid, 0, 1<<32)
|
|
||||||
|
|
||||||
@@ -1762,6 +1768,8 @@ class PosixUidGidTests(unittest.TestCase):
|
|
||||||
def test_setregid(self):
|
|
||||||
if os.getuid() != 0 and not HAVE_WHEEL_GROUP:
|
|
||||||
self.assertRaises(OSError, os.setregid, 0, 0)
|
|
||||||
+ self.assertRaises(TypeError, os.setregid, 'not an int', 0)
|
|
||||||
+ self.assertRaises(TypeError, os.setregid, 0, 'not an int')
|
|
||||||
self.assertRaises(OverflowError, os.setregid, 1<<32, 0)
|
|
||||||
self.assertRaises(OverflowError, os.setregid, 0, 1<<32)
|
|
||||||
|
|
||||||
diff --git a/Lib/test/test_pwd.py b/Lib/test/test_pwd.py
|
|
||||||
index ac9cff7..db98159 100644
|
|
||||||
--- a/Lib/test/test_pwd.py
|
|
||||||
+++ b/Lib/test/test_pwd.py
|
|
||||||
@@ -104,11 +104,11 @@ class PwdTest(unittest.TestCase):
|
|
||||||
# In some cases, byuids isn't a complete list of all users in the
|
|
||||||
# system, so if we try to pick a value not in byuids (via a perturbing
|
|
||||||
# loop, say), pwd.getpwuid() might still be able to find data for that
|
|
||||||
- # uid. Using sys.maxint may provoke the same problems, but hopefully
|
|
||||||
+ # uid. Using 2**32 - 2 may provoke the same problems, but hopefully
|
|
||||||
# it will be a more repeatable failure.
|
|
||||||
# Android accepts a very large span of uids including sys.maxsize and
|
|
||||||
# -1; it raises KeyError with 1 or 2 for example.
|
|
||||||
- fakeuid = sys.maxsize
|
|
||||||
+ fakeuid = 2**32 - 2
|
|
||||||
self.assertNotIn(fakeuid, byuids)
|
|
||||||
if not support.is_android:
|
|
||||||
self.assertRaises(KeyError, pwd.getpwuid, fakeuid)
|
|
18
python3.spec
18
python3.spec
@ -293,22 +293,6 @@ Patch132: 00132-add-rpmbuild-hooks-to-unittest.patch
|
|||||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=814391
|
# See https://bugzilla.redhat.com/show_bug.cgi?id=814391
|
||||||
Patch155: 00155-avoid-ctypes-thunks.patch
|
Patch155: 00155-avoid-ctypes-thunks.patch
|
||||||
|
|
||||||
# 00157 #
|
|
||||||
# Update uid/gid handling throughout the standard library: uid_t and gid_t are
|
|
||||||
# unsigned 32-bit values, but existing code often passed them through C long
|
|
||||||
# values, which are signed 32-bit values on 32-bit architectures, leading to
|
|
||||||
# negative int objects for uid/gid values >= 2^31 on 32-bit architectures.
|
|
||||||
#
|
|
||||||
# Introduce _PyObject_FromUid/Gid to convert uid_t/gid_t values to python
|
|
||||||
# objects, using int objects where the value will fit (long objects otherwise),
|
|
||||||
# and _PyArg_ParseUid/Gid to convert int/long to uid_t/gid_t, with -1 allowed
|
|
||||||
# as a special case (since this is given special meaning by the chown syscall)
|
|
||||||
#
|
|
||||||
# Update standard library to use this throughout for uid/gid values, so that
|
|
||||||
# very large uid/gid values are round-trippable, and -1 remains usable.
|
|
||||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=697470
|
|
||||||
Patch157: 00157-uid-gid-overflows.patch
|
|
||||||
|
|
||||||
# 00160 #
|
# 00160 #
|
||||||
# Python 3.3 added os.SEEK_DATA and os.SEEK_HOLE, which may be present in the
|
# Python 3.3 added os.SEEK_DATA and os.SEEK_HOLE, which may be present in the
|
||||||
# header files in the build chroot, but may not be supported in the running
|
# header files in the build chroot, but may not be supported in the running
|
||||||
@ -689,7 +673,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
|||||||
%patch111 -p1
|
%patch111 -p1
|
||||||
%patch132 -p1
|
%patch132 -p1
|
||||||
%patch155 -p1
|
%patch155 -p1
|
||||||
%patch157 -p1
|
|
||||||
%patch160 -p1
|
%patch160 -p1
|
||||||
%patch163 -p1
|
%patch163 -p1
|
||||||
%patch170 -p1
|
%patch170 -p1
|
||||||
@ -1681,6 +1664,7 @@ fi
|
|||||||
- Run autotools to generate the configure script before building
|
- Run autotools to generate the configure script before building
|
||||||
- Merge lib64 patches (104 into 102)
|
- Merge lib64 patches (104 into 102)
|
||||||
- Skip test_bdist_rpm using test config rather than a patch (removes patch 137)
|
- Skip test_bdist_rpm using test config rather than a patch (removes patch 137)
|
||||||
|
- Remove patch 157, which contained test changes left over after upstreaming
|
||||||
|
|
||||||
* Mon Aug 28 2017 Michal Cyprian <mcyprian@redhat.com> - 3.6.2-12
|
* Mon Aug 28 2017 Michal Cyprian <mcyprian@redhat.com> - 3.6.2-12
|
||||||
- Use python3 style of calling super() without arguments in rpath
|
- Use python3 style of calling super() without arguments in rpath
|
||||||
|
Loading…
Reference in New Issue
Block a user