Update to 3.10.0b3

This commit is contained in:
Miro Hrončok 2021-06-18 01:17:19 +02:00
parent b8586120e5
commit 51d9e334af
3 changed files with 51 additions and 4 deletions

View File

@ -0,0 +1,36 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Fri, 18 Jun 2021 15:16:04 +0200
Subject: [PATCH] 00363: Reset DeprecationWarning filters in
test_importlib.test_entry_points_by_index
This avoids StopIteration error when running tests.
https://bugs.python.org/issue44451
---
Lib/test/test_importlib/test_metadata_api.py | 1 +
.../NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst | 3 +++
2 files changed, 4 insertions(+)
create mode 100644 Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst
diff --git a/Lib/test/test_importlib/test_metadata_api.py b/Lib/test/test_importlib/test_metadata_api.py
index 3506493463..2bfc44b18e 100644
--- a/Lib/test/test_importlib/test_metadata_api.py
+++ b/Lib/test/test_importlib/test_metadata_api.py
@@ -139,6 +139,7 @@ def test_entry_points_by_index(self):
"""
eps = distribution('distinfo-pkg').entry_points
with warnings.catch_warnings(record=True) as caught:
+ warnings.filterwarnings("default", category=DeprecationWarning)
eps[0]
# check warning
diff --git a/Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst b/Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst
new file mode 100644
index 0000000000..0f635cfe18
--- /dev/null
+++ b/Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst
@@ -0,0 +1,3 @@
+Reset ``DeprecationWarning`` filters in
+``test.test_importlib.test_metadata_api.APITests.test_entry_points_by_index``
+to avoid ``StopIteration`` error if ``DeprecationWarnings`` are ignored.

View File

@ -14,10 +14,10 @@ URL: https://www.python.org/
# WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well
%global general_version %{pybasever}.0
%global prerel b2
%global prerel b3
%global upstream_version %{general_version}%{?prerel}
Version: %{general_version}%{?prerel:~%{prerel}}
Release: 3%{?dist}
Release: 1%{?dist}
License: Python
@ -292,6 +292,14 @@ Patch251: 00251-change-user-install-location.patch
# Ideally, we should talk to upstream and explain why we don't want this
Patch328: 00328-pyc-timestamp-invalidation-mode.patch
# 00363 # bcb4a805ad54d3a810fb54582e67c5f5fe6d9773
# Reset DeprecationWarning filters in test_importlib.test_entry_points_by_index
#
# This avoids StopIteration error when running tests.
#
# https://bugs.python.org/issue44451
Patch363: 00363-reset-deprecationwarning-filters-in-test_importlib-test_entry_points_by_index.patch
# (New patches go here ^^^)
#
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
@ -1578,6 +1586,9 @@ CheckPython optimized
# ======================================================
%changelog
* Thu Jun 17 2021 Miro Hrončok <mhroncok@redhat.com> - 3.10.0~b3-1
- Update to 3.10.0b3
* Tue Jun 01 2021 Python Maint <python-maint@redhat.com> - 3.10.0~b2-3
- Rebuilt for Python 3.10

View File

@ -1,2 +1,2 @@
SHA512 (Python-3.10.0b2.tar.xz) = ace86ef11608fbb016d0b8efc7d20cccede4663cd09f07a07e067530537b1e4989379a6c18e7aa9b86b87b108d65efedc39eaf946d27df6ea474a829c763ebdd
SHA512 (Python-3.10.0b2.tar.xz.asc) = 9a84ab98a5215f13302c7a983e9224096d15c07d9a7899b28daff49405c46efdf7770263ca57e6e0f85ce1cbc0cafec373baf1675ade6ddb0eb268e99753907d
SHA512 (Python-3.10.0b3.tar.xz) = ef0dc5eddb5f9702ab88faa2827455347caa81ab6c03192d6e37c968a40c53ab485d5c923905c511d19bc35e10129aa302f6733e0a7d296da8f725367dd1b258
SHA512 (Python-3.10.0b3.tar.xz.asc) = 6b8d2caf753f0d92019e18d1441e323a44aff06ee8bdc272572a67359dc4bece833db56b9318c91962d39ee4d09bf701b548d71ae02c4b64f3c21f1c23ed1d36