Update to Python 3.9.0a6
Sed a SyntaxError out not to bother with a patch that would most likely go away in a7. No other patch changes.
This commit is contained in:
parent
1b0f2ac365
commit
341bcbc115
@ -1,4 +1,4 @@
|
|||||||
From 5cca0c5e66319d1e7f431b31b2059593d0d581fd Mon Sep 17 00:00:00 2001
|
From e50f6e3a63d4b96c24c58f7e2ed87aa401068e93 Mon Sep 17 00:00:00 2001
|
||||||
From: David Malcolm <dmalcolm@redhat.com>
|
From: David Malcolm <dmalcolm@redhat.com>
|
||||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||||
Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
||||||
@ -9,7 +9,7 @@ Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
|||||||
1 file changed, 9 insertions(+)
|
1 file changed, 9 insertions(+)
|
||||||
|
|
||||||
diff --git a/Lib/distutils/unixccompiler.py b/Lib/distutils/unixccompiler.py
|
diff --git a/Lib/distutils/unixccompiler.py b/Lib/distutils/unixccompiler.py
|
||||||
index d10a78da31..4df4b67810 100644
|
index 4d7a6de740..353086a648 100644
|
||||||
--- a/Lib/distutils/unixccompiler.py
|
--- a/Lib/distutils/unixccompiler.py
|
||||||
+++ b/Lib/distutils/unixccompiler.py
|
+++ b/Lib/distutils/unixccompiler.py
|
||||||
@@ -82,6 +82,15 @@ class UnixCCompiler(CCompiler):
|
@@ -82,6 +82,15 @@ class UnixCCompiler(CCompiler):
|
||||||
@ -29,5 +29,5 @@ index d10a78da31..4df4b67810 100644
|
|||||||
include_dirs=None, extra_preargs=None, extra_postargs=None):
|
include_dirs=None, extra_preargs=None, extra_postargs=None):
|
||||||
fixed_args = self._fix_compile_args(None, macros, include_dirs)
|
fixed_args = self._fix_compile_args(None, macros, include_dirs)
|
||||||
--
|
--
|
||||||
2.26.0.rc2
|
2.26.2
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From d6d13e87c507c77211dbd340b159ca4410849f13 Mon Sep 17 00:00:00 2001
|
From 97a0ffada41660301257e303b7cbddc96e70c7a3 Mon Sep 17 00:00:00 2001
|
||||||
From: David Malcolm <dmalcolm@redhat.com>
|
From: David Malcolm <dmalcolm@redhat.com>
|
||||||
Date: Mon, 18 Jan 2010 17:59:07 +0000
|
Date: Mon, 18 Jan 2010 17:59:07 +0000
|
||||||
Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
|
Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
|
||||||
@ -21,10 +21,10 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
|||||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||||
index caa1d37648..3178f16000 100644
|
index 18fa97bec3..4c8e73583b 100644
|
||||||
--- a/Makefile.pre.in
|
--- a/Makefile.pre.in
|
||||||
+++ b/Makefile.pre.in
|
+++ b/Makefile.pre.in
|
||||||
@@ -563,7 +563,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
@@ -578,7 +578,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||||
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
|
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
|
||||||
|
|
||||||
# Build the interpreter
|
# Build the interpreter
|
||||||
@ -33,7 +33,7 @@ index caa1d37648..3178f16000 100644
|
|||||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||||
|
|
||||||
platform: $(BUILDPYTHON) pybuilddir.txt
|
platform: $(BUILDPYTHON) pybuilddir.txt
|
||||||
@@ -611,12 +611,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
@@ -626,12 +626,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
||||||
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
||||||
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
||||||
|
|
||||||
@ -46,7 +46,7 @@ index caa1d37648..3178f16000 100644
|
|||||||
libpython$(LDVERSION).so: $(LIBRARY_OBJS) $(DTRACE_OBJS)
|
libpython$(LDVERSION).so: $(LIBRARY_OBJS) $(DTRACE_OBJS)
|
||||||
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
||||||
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM); \
|
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM); \
|
||||||
@@ -694,7 +688,7 @@ Makefile Modules/config.c: Makefile.pre \
|
@@ -709,7 +703,7 @@ Makefile Modules/config.c: Makefile.pre \
|
||||||
@echo "The Makefile was updated, you may need to re-run make."
|
@echo "The Makefile was updated, you may need to re-run make."
|
||||||
|
|
||||||
|
|
||||||
@ -55,7 +55,7 @@ index caa1d37648..3178f16000 100644
|
|||||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||||
|
|
||||||
############################################################################
|
############################################################################
|
||||||
@@ -1570,17 +1564,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
@@ -1598,17 +1592,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||||
else true; \
|
else true; \
|
||||||
fi; \
|
fi; \
|
||||||
done
|
done
|
||||||
@ -74,5 +74,5 @@ index caa1d37648..3178f16000 100644
|
|||||||
$(INSTALL_DATA) Programs/python.o $(DESTDIR)$(LIBPL)/python.o
|
$(INSTALL_DATA) Programs/python.o $(DESTDIR)$(LIBPL)/python.o
|
||||||
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
|
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
|
||||||
--
|
--
|
||||||
2.26.0.rc2
|
2.26.2
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 0eb96d45196adaa7dc1362590ae44ddfb175e29c Mon Sep 17 00:00:00 2001
|
From b81c3b618760bd400dbcec7ac945a1f42bd4268b Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||||
Date: Wed, 15 Aug 2018 15:36:29 +0200
|
Date: Wed, 15 Aug 2018 15:36:29 +0200
|
||||||
Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
|
Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
|
||||||
@ -70,5 +70,5 @@ index 545fce656f..f86992c90c 100644
|
|||||||
additional_paths.append(os.path.join(tmpdir, wheel_name))
|
additional_paths.append(os.path.join(tmpdir, wheel_name))
|
||||||
|
|
||||||
--
|
--
|
||||||
2.26.0.rc2
|
2.26.2
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 792ba3f5ca938abfb276b6b938312b6af44619fb Mon Sep 17 00:00:00 2001
|
From 00c0c0c861e38ee97f5f26b1a17724cac131bed9 Mon Sep 17 00:00:00 2001
|
||||||
From: Michal Cyprian <m.cyprian@gmail.com>
|
From: Michal Cyprian <m.cyprian@gmail.com>
|
||||||
Date: Mon, 26 Jun 2017 16:32:56 +0200
|
Date: Mon, 26 Jun 2017 16:32:56 +0200
|
||||||
Subject: [PATCH] 00251: Change user install location
|
Subject: [PATCH] 00251: Change user install location
|
||||||
@ -60,5 +60,5 @@ index e981a14208..63e05ff2ad 100644
|
|||||||
if os.path.isdir(sitedir):
|
if os.path.isdir(sitedir):
|
||||||
addsitedir(sitedir, known_paths)
|
addsitedir(sitedir, known_paths)
|
||||||
--
|
--
|
||||||
2.26.0.rc2
|
2.26.2
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From df0b3431e564d5f999086c060f1080b59338877a Mon Sep 17 00:00:00 2001
|
From ff8c136ae25718141c95a83aa5ffec832427ffc2 Mon Sep 17 00:00:00 2001
|
||||||
From: Petr Viktorin <pviktori@redhat.com>
|
From: Petr Viktorin <pviktori@redhat.com>
|
||||||
Date: Mon, 28 Aug 2017 17:16:46 +0200
|
Date: Mon, 28 Aug 2017 17:16:46 +0200
|
||||||
Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
|
Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
|
||||||
@ -29,7 +29,7 @@ index ba37cf99e2..52a9ec6662 100755
|
|||||||
ppc64le | powerpc64little)
|
ppc64le | powerpc64little)
|
||||||
basic_machine=powerpc64le-unknown
|
basic_machine=powerpc64le-unknown
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
index 8eed0151eb..73d3b136a4 100644
|
index 240ddeb9b3..b9b22f8e28 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -759,9 +759,9 @@ cat >> conftest.c <<EOF
|
@@ -759,9 +759,9 @@ cat >> conftest.c <<EOF
|
||||||
@ -82,5 +82,5 @@ index 8eed0151eb..73d3b136a4 100644
|
|||||||
s390x-linux-gnu
|
s390x-linux-gnu
|
||||||
# elif defined(__s390__)
|
# elif defined(__s390__)
|
||||||
--
|
--
|
||||||
2.26.0.rc2
|
2.26.2
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 7b5490ad6889846a944f4441eab5007875fcfc9f Mon Sep 17 00:00:00 2001
|
From c3caf64b6b336b3b6d536d6f0a08c5a19385b5fc Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||||
Date: Thu, 11 Jul 2019 13:44:13 +0200
|
Date: Thu, 11 Jul 2019 13:44:13 +0200
|
||||||
Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default
|
Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default
|
||||||
@ -51,5 +51,5 @@ index d4a68c9320..ed09874023 100644
|
|||||||
return wrapper
|
return wrapper
|
||||||
|
|
||||||
--
|
--
|
||||||
2.26.0.rc2
|
2.26.2
|
||||||
|
|
||||||
|
@ -14,7 +14,7 @@ URL: https://www.python.org/
|
|||||||
# WARNING When rebasing to a new Python version,
|
# WARNING When rebasing to a new Python version,
|
||||||
# remember to update the python3-docs package as well
|
# remember to update the python3-docs package as well
|
||||||
%global general_version %{pybasever}.0
|
%global general_version %{pybasever}.0
|
||||||
%global prerel a5
|
%global prerel a6
|
||||||
%global upstream_version %{general_version}%{?prerel}
|
%global upstream_version %{general_version}%{?prerel}
|
||||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
@ -626,6 +626,10 @@ rm Lib/ensurepip/_bundled/*.whl
|
|||||||
%patch274 -p1
|
%patch274 -p1
|
||||||
%patch328 -p1
|
%patch328 -p1
|
||||||
|
|
||||||
|
# https://bugs.python.org/issue40431
|
||||||
|
# https://github.com/python/cpython/pull/19777
|
||||||
|
sed -i 's/ else"/ else "/' Lib/turtledemo/__main__.py
|
||||||
|
|
||||||
|
|
||||||
# Remove files that should be generated by the build
|
# Remove files that should be generated by the build
|
||||||
# (This is after patching, so that we can use patches directly from upstream)
|
# (This is after patching, so that we can use patches directly from upstream)
|
||||||
@ -870,6 +874,7 @@ install -d -m 0755 %{buildroot}%{_prefix}/lib/python%{pybasever}/site-packages/_
|
|||||||
install -D -m 0644 Lib/idlelib/Icons/idle_16.png %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/idle3.png
|
install -D -m 0644 Lib/idlelib/Icons/idle_16.png %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/idle3.png
|
||||||
install -D -m 0644 Lib/idlelib/Icons/idle_32.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/idle3.png
|
install -D -m 0644 Lib/idlelib/Icons/idle_32.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/idle3.png
|
||||||
install -D -m 0644 Lib/idlelib/Icons/idle_48.png %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/idle3.png
|
install -D -m 0644 Lib/idlelib/Icons/idle_48.png %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/idle3.png
|
||||||
|
install -D -m 0644 Lib/idlelib/Icons/idle_256.png %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/idle3.png
|
||||||
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE10}
|
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE10}
|
||||||
|
|
||||||
# Install and validate appdata file
|
# Install and validate appdata file
|
||||||
@ -1569,6 +1574,9 @@ CheckPython optimized
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 28 2020 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~a6-1
|
||||||
|
- Update to Python 3.9.0a6
|
||||||
|
|
||||||
* Tue Mar 24 2020 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~a5-1
|
* Tue Mar 24 2020 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~a5-1
|
||||||
- Update to Python 3.9.0a5
|
- Update to Python 3.9.0a5
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (Python-3.9.0a5.tar.xz) = b2f884a492eeb9fa7347c664bb6fd1dc3c25f663ebb4f9455b66540e12ce8da845c2ad4960999d5475625bc64c834f3cff28f61cd37881bdf53efa349c44bff3
|
SHA512 (Python-3.9.0a6.tar.xz) = edb71840347ab2b5e18b3a2b831a3d9a26e1af52de9b1c6c088ce2d20f8e96a22c87fc3677b62e49c91a00d8b531028bdc739f00fe220dbdeb343daf17829be4
|
||||||
SHA512 (Python-3.9.0a5.tar.xz.asc) = c3988caedfa183af563a6fddabc16357863834ce2460ce05d7adaa78de76dc08c5bb6d078f10bb4f58775e1d4b5d9168f59319b488638010f6066c2c2a21a211
|
SHA512 (Python-3.9.0a6.tar.xz.asc) = 94490b9646b364fdc4d1faaa57fecb852fc9d63a00c3346093f633b0bcdbb9e45ffe346949300a8a01b18d6c6f55956a82211600e28004e3fbef8e58ada0303c
|
||||||
|
Loading…
Reference in New Issue
Block a user