Update to 3.8.0b3

This commit is contained in:
Miro Hrončok 2019-07-30 00:48:16 +02:00 committed by churchyard
parent 69c2d11d9a
commit 29530ba2a8
9 changed files with 41 additions and 39 deletions

View File

@ -1,8 +1,8 @@
From 8738c39204297788bcb07940a99608f80592829f Mon Sep 17 00:00:00 2001
From 8a93e612de3f9f1e1c04ca2b31f207a2ce611fe1 Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Wed, 13 Jan 2010 21:25:18 +0000
Subject: [PATCH 1/7] 00001: Fixup distutils/unixccompiler.py to remove
standard library path from rpath Was Patch0 in ivazquez' python3000 specfile
Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
library path from rpath Was Patch0 in ivazquez' python3000 specfile
---
Lib/distutils/unixccompiler.py | 9 +++++++++

View File

@ -1,8 +1,8 @@
From 6a503d0ad4512af57ef8a784f12bc439701d8cc7 Mon Sep 17 00:00:00 2001
From ee7b218babbed91c283445021a99d4b28fc12b2f Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Wed, 13 Jan 2010 21:25:18 +0000
Subject: [PATCH 2/7] 00102: Change the various install paths to use
/usr/lib64/ instead or /usr/lib/
Subject: [PATCH] 00102: Change the various install paths to use /usr/lib64/
instead or /usr/lib/
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@ -154,7 +154,7 @@ index 41c4229919..543c88432a 100644
'site-packages')
self.assertEqual(dirs[0], wanted)
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 88abb56360..6c2edf32f7 100644
index 6a9f4b5270..61d650882f 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -143,7 +143,7 @@ LIBDIR= @libdir@
@ -198,10 +198,10 @@ index 5f80738188..73d7913441 100644
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
}
diff --git a/configure b/configure
index 6e7f277bac..6cd8344c21 100755
index cb5f130d38..b30b4008f2 100755
--- a/configure
+++ b/configure
@@ -15181,9 +15181,9 @@ fi
@@ -15195,9 +15195,9 @@ fi
if test x$PLATFORM_TRIPLET = x; then
@ -214,10 +214,10 @@ index 6e7f277bac..6cd8344c21 100755
diff --git a/configure.ac b/configure.ac
index 324ce0bd99..9a587f3c3f 100644
index b31ed242f1..42d17bc0ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4655,9 +4655,9 @@ fi
@@ -4663,9 +4663,9 @@ fi
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
AC_SUBST(PY_ENABLE_SHARED)
if test x$PLATFORM_TRIPLET = x; then
@ -230,7 +230,7 @@ index 324ce0bd99..9a587f3c3f 100644
AC_SUBST(LIBPL)
diff --git a/setup.py b/setup.py
index edc3434242..59cfc01a2a 100644
index 6cbbec9e12..a5092861cf 100644
--- a/setup.py
+++ b/setup.py
@@ -648,7 +648,7 @@ class PyBuildExt(build_ext):

View File

@ -1,7 +1,7 @@
From efbafc6328f45da6d38a1848933a37497206fb3f Mon Sep 17 00:00:00 2001
From 65208ffdf868d06e6e16eeb12e3f47205a738ed3 Mon Sep 17 00:00:00 2001
From: David Malcolm <dmalcolm@redhat.com>
Date: Mon, 18 Jan 2010 17:59:07 +0000
Subject: [PATCH 3/7] 00111: Don't try to build a libpythonMAJOR.MINOR.a
Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@ -21,10 +21,10 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
1 file changed, 2 insertions(+), 19 deletions(-)
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 6c2edf32f7..28c0cead24 100644
index 61d650882f..3f5be819c4 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -560,7 +560,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
@@ -561,7 +561,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
# Build the interpreter
@ -33,7 +33,7 @@ index 6c2edf32f7..28c0cead24 100644
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
platform: $(BUILDPYTHON) pybuilddir.txt
@@ -608,12 +608,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
@@ -609,12 +609,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@ -46,7 +46,7 @@ index 6c2edf32f7..28c0cead24 100644
libpython$(LDVERSION).so: $(LIBRARY_OBJS) $(DTRACE_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM); \
@@ -691,7 +685,7 @@ Makefile Modules/config.c: Makefile.pre \
@@ -692,7 +686,7 @@ Makefile Modules/config.c: Makefile.pre \
@echo "The Makefile was updated, you may need to re-run make."
@ -55,7 +55,7 @@ index 6c2edf32f7..28c0cead24 100644
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
############################################################################
@@ -1551,17 +1545,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
@@ -1552,17 +1546,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
else true; \
fi; \
done

View File

@ -1,8 +1,7 @@
From 2edaa31dec042fb8720add80814ca4a3cc4f788f Mon Sep 17 00:00:00 2001
From 327e040bd14b6bd05314b24e59ffcdb2179f9757 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Wed, 15 Aug 2018 15:36:29 +0200
Subject: [PATCH 4/7] 00189: Instead of bundled wheels, use our RPM packaged
wheels
Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
We keep them in /usr/share/python-wheels
---
@ -10,7 +9,7 @@ We keep them in /usr/share/python-wheels
1 file changed, 17 insertions(+), 9 deletions(-)
diff --git a/Lib/ensurepip/__init__.py b/Lib/ensurepip/__init__.py
index 6f2569da81..4d17e413db 100644
index 63de20e288..4d17e413db 100644
--- a/Lib/ensurepip/__init__.py
+++ b/Lib/ensurepip/__init__.py
@@ -1,16 +1,27 @@
@ -27,9 +26,9 @@ index 6f2569da81..4d17e413db 100644
+_WHEEL_DIR = "/usr/share/python-wheels/"
-_SETUPTOOLS_VERSION = "40.8.0"
-_SETUPTOOLS_VERSION = "41.0.1"
-_PIP_VERSION = "19.0.3"
-_PIP_VERSION = "19.2.1"
+def _get_most_recent_wheel_version(pkg):
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
+ suffix = "-py2.py3-none-any.whl"

View File

@ -1,7 +1,7 @@
From 3e26b01573488b015065139689be3aa47dac17cf Mon Sep 17 00:00:00 2001
From 27348866d660c1344a1f78a6337436443e1ed19c Mon Sep 17 00:00:00 2001
From: Michal Cyprian <m.cyprian@gmail.com>
Date: Mon, 26 Jun 2017 16:32:56 +0200
Subject: [PATCH 5/7] 00251: Change user install location
Subject: [PATCH] 00251: Change user install location
Set values of prefix and exec_prefix in distutils install command
to /usr/local if executable is /usr/bin/python* and RPM build

View File

@ -1,8 +1,8 @@
From b92e29a8cc17f9c02a08b7a005e5ece71a409a0b Mon Sep 17 00:00:00 2001
From c827bec294a7fb9481a55c1f7d78e80007e38816 Mon Sep 17 00:00:00 2001
From: Petr Viktorin <pviktori@redhat.com>
Date: Mon, 28 Aug 2017 17:16:46 +0200
Subject: [PATCH 6/7] 00274: Upstream uses Debian-style architecture naming,
change to match Fedora
Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
to match Fedora
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@ -29,7 +29,7 @@ index ba37cf99e2..52a9ec6662 100755
ppc64le | powerpc64little)
basic_machine=powerpc64le-unknown
diff --git a/configure.ac b/configure.ac
index 9a587f3c3f..695ff85e4b 100644
index 42d17bc0ad..637a99f159 100644
--- a/configure.ac
+++ b/configure.ac
@@ -741,9 +741,9 @@ cat >> conftest.c <<EOF

View File

@ -1,4 +1,4 @@
From 746a45acd333174c3174230833b45f537bd92889 Mon Sep 17 00:00:00 2001
From 1df081ef9044c6b30fd75d591b6999eb62c48d9b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Thu, 11 Jul 2019 13:44:13 +0200
Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default

View File

@ -14,10 +14,10 @@ URL: https://www.python.org/
# WARNING When rebasing to a new Python version,
# remember to update the python3-docs package as well
%global general_version %{pybasever}.0
%global prerel b2
%global prerel b3
%global upstream_version %{general_version}%{?prerel}
Version: %{general_version}%{?prerel:~%{prerel}}
Release: 2%{?dist}
Release: 1%{?dist}
License: Python
@ -379,8 +379,8 @@ Summary: Python runtime libraries
Requires: python-setuptools-wheel
Requires: python-pip-wheel
%else
Provides: bundled(python3-pip) = 19.0.3
Provides: bundled(python3-setuptools) = 40.8.0
Provides: bundled(python3-pip) = 19.2.1
Provides: bundled(python3-setuptools) = 41.0.1
%endif
%{?python_provide:%python_provide python3-libs}
@ -554,8 +554,8 @@ The debug runtime additionally supports debug builds of C-API extensions
Requires: python-setuptools-wheel
Requires: python-pip-wheel
%else
Provides: bundled(python3-pip) = 19.0.3
Provides: bundled(python3-setuptools) = 40.8.0
Provides: bundled(python3-pip) = 19.2.1
Provides: bundled(python3-setuptools) = 41.0.1
%endif
# The description for the flat package
@ -1531,6 +1531,9 @@ CheckPython optimized
# ======================================================
%changelog
* Mon Jul 29 2019 Miro Hrončok <mhroncok@redhat.com> - 3.8.0~b3-1
- Update to 3.8.0b3
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.0~b2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (Python-3.8.0b2.tar.xz) = 5d4fdabad098b5273d34ecd939e7f7c104f4f9fc1460e5abaf4a8d1ad1c5d2ff26d579de03106f000672e0a20fcd6e4e1e44ce03be4bb4a734f937f3cc81cb3e
SHA512 (Python-3.8.0b3.tar.xz) = 5b29e580514704150b397850b5bf5f3e4b98a45d9a9f8ac0364bef51caac74862f9f349b5d3d1bbcdcc5b48b2722f1a9e5e0a9837bf44360fe74a396e915ae35