Update to 3.7.2
Already upstreamed patches: 313, 315 Patches rebased: 111, 189 (new pip/setuptools versions only)
This commit is contained in:
parent
15d5b5cfc5
commit
1385d6e65a
@ -1,17 +1,17 @@
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index 0eddd13..7ed4f3c 100644
|
||||
index 0db0dd0..bd8f769 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -565,7 +565,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
@@ -574,7 +574,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
|
||||
|
||||
# Build the interpreter
|
||||
-$(BUILDPYTHON): Programs/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
|
||||
+$(BUILDPYTHON): Programs/python.o $(LDLIBRARY) $(PY3LIBRARY)
|
||||
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||
|
||||
platform: $(BUILDPYTHON) pybuilddir.txt
|
||||
@@ -609,12 +609,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
||||
@@ -622,12 +622,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
||||
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
||||
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
||||
|
||||
@ -24,16 +24,16 @@ index 0eddd13..7ed4f3c 100644
|
||||
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
|
||||
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
||||
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
|
||||
@@ -702,7 +696,7 @@ Modules/Setup: $(srcdir)/Modules/Setup.dist
|
||||
@@ -715,7 +709,7 @@ Modules/Setup: $(srcdir)/Modules/Setup.dist
|
||||
echo "-----------------------------------------------"; \
|
||||
fi
|
||||
|
||||
-Programs/_testembed: Programs/_testembed.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
|
||||
+Programs/_testembed: Programs/_testembed.o $(LDLIBRARY) $(PY3LIBRARY)
|
||||
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||
|
||||
############################################################################
|
||||
@@ -1460,17 +1454,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@@ -1483,17 +1477,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
else true; \
|
||||
fi; \
|
||||
done
|
||||
|
@ -16,9 +16,9 @@ index 4748ba4..fc02255 100644
|
||||
|
||||
+_WHEEL_DIR = "/usr/share/python-wheels/"
|
||||
|
||||
-_SETUPTOOLS_VERSION = "39.0.1"
|
||||
-_SETUPTOOLS_VERSION = "40.6.2"
|
||||
|
||||
-_PIP_VERSION = "10.0.1"
|
||||
-_PIP_VERSION = "18.1"
|
||||
+def _get_most_recent_wheel_version(pkg):
|
||||
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
|
||||
+ suffix = "-py2.py3-none-any.whl"
|
||||
|
@ -1,61 +0,0 @@
|
||||
commit c36e8721f276e7cc09cecdb9c04783630f0ba82a
|
||||
Author: Victor Stinner <vstinner@redhat.com>
|
||||
Date: Wed Nov 7 00:34:22 2018 +0100
|
||||
|
||||
bpo-23420: Verify the value of '-s' when execute the CLI of cProfile
|
||||
|
||||
Verify the value for the parameter '-s' of the cProfile CLI. Patch by Robert
|
||||
Kuska.
|
||||
|
||||
Resolves: rhbz#1160640
|
||||
|
||||
diff --git a/Lib/cProfile.py b/Lib/cProfile.py
|
||||
index c044be8..f6e423b 100755
|
||||
--- a/Lib/cProfile.py
|
||||
+++ b/Lib/cProfile.py
|
||||
@@ -124,6 +124,7 @@ def main():
|
||||
import os
|
||||
import sys
|
||||
import runpy
|
||||
+ import pstats
|
||||
from optparse import OptionParser
|
||||
usage = "cProfile.py [-o output_file_path] [-s sort] [-m module | scriptfile] [arg] ..."
|
||||
parser = OptionParser(usage=usage)
|
||||
@@ -132,7 +133,8 @@ def main():
|
||||
help="Save stats to <outfile>", default=None)
|
||||
parser.add_option('-s', '--sort', dest="sort",
|
||||
help="Sort order when printing to stdout, based on pstats.Stats class",
|
||||
- default=-1)
|
||||
+ default=-1,
|
||||
+ choices=sorted(pstats.Stats.sort_arg_dict_default))
|
||||
parser.add_option('-m', dest="module", action="store_true",
|
||||
help="Profile a library module", default=False)
|
||||
|
||||
diff --git a/Lib/test/test_cprofile.py b/Lib/test/test_cprofile.py
|
||||
index 1430d22..5c4ec5b 100644
|
||||
--- a/Lib/test/test_cprofile.py
|
||||
+++ b/Lib/test/test_cprofile.py
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
import sys
|
||||
from test.support import run_unittest, TESTFN, unlink
|
||||
+import unittest
|
||||
|
||||
# rip off all interesting stuff from test_profile
|
||||
import cProfile
|
||||
@@ -50,8 +51,14 @@ class CProfileTest(ProfileTest):
|
||||
assert_python_ok('-m', 'cProfile', '-m', 'timeit', '-n', '1')
|
||||
|
||||
|
||||
+class TestCommandLine(unittest.TestCase):
|
||||
+ def test_sort(self):
|
||||
+ rc, out, err = assert_python_failure('-m', 'cProfile', '-s', 'demo')
|
||||
+ self.assertGreater(rc, 0)
|
||||
+ self.assertIn(b"option -s: invalid choice: 'demo'", err)
|
||||
+
|
||||
def test_main():
|
||||
- run_unittest(CProfileTest)
|
||||
+ run_unittest(CProfileTest, TestCommandLine)
|
||||
|
||||
def main():
|
||||
if '-r' not in sys.argv:
|
@ -1,46 +0,0 @@
|
||||
From 0165caf04ef9c615c8b86dd16f7c201ca7a0befa Mon Sep 17 00:00:00 2001
|
||||
From: Victor Stinner <vstinner@redhat.com>
|
||||
Date: Tue, 27 Nov 2018 12:40:50 +0100
|
||||
Subject: [PATCH] bpo-35317: Fix mktime() error in test_email (GH-10721)
|
||||
|
||||
Fix mktime() overflow error in test_email: run
|
||||
test_localtime_daylight_true_dst_true() and
|
||||
test_localtime_daylight_false_dst_true() with a specific timezone.
|
||||
(cherry picked from commit cfaafda8e3e19764682abb4bd4c574accb784c42)
|
||||
|
||||
Co-authored-by: Victor Stinner <vstinner@redhat.com>
|
||||
---
|
||||
Lib/test/test_email/test_utils.py | 2 ++
|
||||
.../NEWS.d/next/Tests/2018-11-26-16-54-21.bpo-35317.jByGP2.rst | 3 +++
|
||||
2 files changed, 5 insertions(+)
|
||||
create mode 100644 Misc/NEWS.d/next/Tests/2018-11-26-16-54-21.bpo-35317.jByGP2.rst
|
||||
|
||||
diff --git a/Lib/test/test_email/test_utils.py b/Lib/test/test_email/test_utils.py
|
||||
index 6dcb3bbe7aab..4e3c3f3a195f 100644
|
||||
--- a/Lib/test/test_email/test_utils.py
|
||||
+++ b/Lib/test/test_email/test_utils.py
|
||||
@@ -75,6 +75,7 @@ def test_localtime_daylight_false_dst_false(self):
|
||||
t2 = utils.localtime(t1)
|
||||
self.assertEqual(t1, t2)
|
||||
|
||||
+ @test.support.run_with_tz('Europe/Minsk')
|
||||
def test_localtime_daylight_true_dst_true(self):
|
||||
test.support.patch(self, time, 'daylight', True)
|
||||
t0 = datetime.datetime(2012, 3, 12, 1, 1)
|
||||
@@ -82,6 +83,7 @@ def test_localtime_daylight_true_dst_true(self):
|
||||
t2 = utils.localtime(t1)
|
||||
self.assertEqual(t1, t2)
|
||||
|
||||
+ @test.support.run_with_tz('Europe/Minsk')
|
||||
def test_localtime_daylight_false_dst_true(self):
|
||||
test.support.patch(self, time, 'daylight', False)
|
||||
t0 = datetime.datetime(2012, 3, 12, 1, 1)
|
||||
diff --git a/Misc/NEWS.d/next/Tests/2018-11-26-16-54-21.bpo-35317.jByGP2.rst b/Misc/NEWS.d/next/Tests/2018-11-26-16-54-21.bpo-35317.jByGP2.rst
|
||||
new file mode 100644
|
||||
index 000000000000..73a30f71927f
|
||||
--- /dev/null
|
||||
+++ b/Misc/NEWS.d/next/Tests/2018-11-26-16-54-21.bpo-35317.jByGP2.rst
|
||||
@@ -0,0 +1,3 @@
|
||||
+Fix ``mktime()`` overflow error in ``test_email``: run
|
||||
+``test_localtime_daylight_true_dst_true()`` and
|
||||
+``test_localtime_daylight_false_dst_true()`` with a specific timezone.
|
30
python3.spec
30
python3.spec
@ -13,8 +13,8 @@ URL: https://www.python.org/
|
||||
|
||||
# WARNING When rebasing to a new Python version,
|
||||
# remember to update the python3-docs package as well
|
||||
Version: %{pybasever}.1
|
||||
Release: 5%{?dist}
|
||||
Version: %{pybasever}.2
|
||||
Release: 1%{?dist}
|
||||
License: Python
|
||||
|
||||
|
||||
@ -307,18 +307,6 @@ Patch274: 00274-fix-arch-names.patch
|
||||
# See: https://bugzilla.redhat.com/show_bug.cgi?id=1644936
|
||||
Patch312: 00312-revert-bpo-6721.patch
|
||||
|
||||
# 00313 #
|
||||
# Verify the value of '-s' when execute the CLI of cProfile
|
||||
# http://bugs.python.org/issue23420
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1160640
|
||||
Patch313: 00313-cprofile-sort-option.patch
|
||||
|
||||
# 00315 #
|
||||
# Fix mktime() error in test_email
|
||||
# http://bugs.python.org/issue35317
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1652843
|
||||
Patch315: 00315-test_email-mktime.patch
|
||||
|
||||
# 00316 #
|
||||
# We remove the exe files from distutil's bdist_wininst
|
||||
# So we mark the command as unsupported - and the tests are skipped
|
||||
@ -427,8 +415,8 @@ Requires: gdbm-libs%{?_isa} >= 1:1.13
|
||||
Requires: python-setuptools-wheel
|
||||
Requires: python-pip-wheel
|
||||
%else
|
||||
Provides: bundled(python3-pip) = 10.0.1
|
||||
Provides: bundled(python3-setuptools) = 39.0.1
|
||||
Provides: bundled(python3-pip) = 18.1
|
||||
Provides: bundled(python3-setuptools) = 40.6.2
|
||||
%endif
|
||||
|
||||
# There are files in the standard library that have python shebang.
|
||||
@ -605,8 +593,8 @@ Requires: redhat-rpm-config
|
||||
Requires: python-setuptools-wheel
|
||||
Requires: python-pip-wheel
|
||||
%else
|
||||
Provides: bundled(python3-pip) = 10.0.1
|
||||
Provides: bundled(python3-setuptools) = 39.0.1
|
||||
Provides: bundled(python3-pip) = 18.1
|
||||
Provides: bundled(python3-setuptools) = 40.6.2
|
||||
%endif
|
||||
|
||||
# The description for the flat package
|
||||
@ -659,8 +647,6 @@ rm Lib/ensurepip/_bundled/*.whl
|
||||
%patch251 -p1
|
||||
%patch274 -p1
|
||||
%patch312 -p1
|
||||
%patch313 -p1
|
||||
%patch315 -p1
|
||||
%patch316 -p1
|
||||
|
||||
|
||||
@ -1356,6 +1342,7 @@ CheckPython optimized
|
||||
%exclude %{_includedir}/python%{LDVERSION_optimized}/%{_pyconfig_h}
|
||||
%endif
|
||||
%{_includedir}/python%{LDVERSION_optimized}/*.h
|
||||
%{_includedir}/python%{LDVERSION_optimized}/internal/
|
||||
%doc Misc/README.valgrind Misc/valgrind-python.supp Misc/gdbinit
|
||||
|
||||
%if %{without flatpackage}
|
||||
@ -1576,6 +1563,9 @@ CheckPython optimized
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Tue Dec 25 2018 Miro Hrončok <mhroncok@redhat.com> - 3.7.2-1
|
||||
- Update to 3.7.2
|
||||
|
||||
* Fri Dec 07 2018 Miro Hrončok <mhroncok@redhat.com> - 3.7.1-5
|
||||
- Make sure we don't ship any exe files (not needed an prebuilt)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Python-3.7.1.tar.xz) = 3eb62a0127609b14420a47442727702f396519c649625aca59883d04f4c02e5f37ba1d58ac8e93c49d14a63f17ae7909315c33fc813293dbcdb6127f39a148b0
|
||||
SHA512 (Python-3.7.2.tar.xz) = 6cd2d6d8455558783b99d55985cd7b22d67b98f41a09b4fdd96f680a630a4e035220d2b903f8c59ed513aa5ffe6730fa947ddb55bb72ce36f0e945ef8af5d971
|
||||
|
Loading…
Reference in New Issue
Block a user